Official HITMAN 2 Bug Report Thread


#1276

Question for PS4 players:

Does HITMAN 2 seem to give a hard time to your PS4’s screenshot/recording system?

I use the ‘easy screenshot’ button layout so I can take screenshots and videos faster. (One click for Screenshot. Two Clicks for Start/Stop recording. Hold Button for Share options.)
For me, when taking a screenshot (by pressing the ‘share’ button) the console always takes about 10 seconds before giving me the notification that the screenshot has been taken/saved. I’m always worried that the effect is delayed, so I always wait, staring at whatever I want the picture of before moving on.

Another thing that seems bugged for me is the video recording system. I tend to take videos of my runs and upload them for contests here on the forums. I’ve noticed that when viewing the videos either on the console or after exporting to a USB, there are a number of times where the recording skips a couple seconds, but there’s no way to fix it. That’s just how it saves onto the system. The recording software seems to be bugged on PS4, not entirely recording the game at times. I never had this problem with HITMAN 2016.


#1277

Yes, always delayed a solid 60-90 seconds before confirming screenshot taken on PS4 Pro for me.
Also both HITMAN 2016 and HITMAN 2 were only games I had to suspend to use spotify on them. Once I initiate Spotify I can return to game and it’s fine then playing music.
It’s like whatever way HITMAN is programmed, it uses full RAM of the PS4 or wrongfully allocates it etc.
Every other game splits RAM so spotify can be used and accessed simultaneously it seems.


#1278

Sinks in the Swedish Embassy cannot be interacted/overflowed.
In particular I tried one on the Second Floor near Strandberg’s office.


#1279

Ive had the same problem i regret even touching the Icon now… ive hit mastery 20 of Soupienza and now i am unable to get my trophy for this. Is there any other way to delete save data so i can restart this whole thing or am i going to have 1 missing trophy from my collection cause of this glitch…


#1280

Uh this is not a bug but something that might need reworking. In Another Life sometimes when Janus goes down into the basement his first monologue will be triggered by the Geiger Counter in the back corner instead of the porcelain vase on his desk. So when he talks about the item being on Lenin’s desk it is for a device invented four years after his death.:joy:


#1281

Hi IOI,

Issue 1: When Agent 47 is standing in a position, people will walk up to him and comment about how they need their space… Even though they’re the ones that walked into 47.

Issue 2: Being shot at for being spotted when doing restricted activities. e.g. Someone has spotted me turning off the fuse box so I start getting shot at with lethal force.

Thanks guys, I LOVE the game and hope this assists with ironing up some minor issues.


#1282

Morgue doctor in Hokkaido (in basement) who holds the clipboard and walks from one side of the operating table and the other, is often standing on top of the operating table.


#1283

I lured the men out of the sauna using coins, and then turned up the heat.


#1284

hard to do Crazy 8 feat because the katana isn’t registered.


#1285

On Xbox.
In Mumbai contract creation mode the ‘go india’ tour guide is named {0} now as far as naming conventions go that has to be the oddest I’ve seen. Not to ridicule the poor lass, but the name also glitches out when I try to mark her. Now I’m not saying, change her name to make me comfortable or anything, but heck at least commit and get that glitch out. 15437309669091325103945|666x500


#1286

On PC

I just finished The Undying elusive target. I tried to go for silent assassin, using the bomb in the lab, making sure only to hit the target. I managed to pull it off, getting credit for an accidental kill, unnoticed kill, and no additional casualties. When i got to the score screen however, I had lost credit for No Bodies Found. As far as I’m aware accidental kills ignore the need to hide a body.


#1287

Your image didn’t upload correctly.


#1288

The game is wonderful but it crashes a lot,say about 20minutes and the screen goes still and jump out of the game without any sign. Plz fix it because it’s so disturbing while you are enjoying the game…plz contact me through email [email protected]


#1289

@Lasse_IOI

Place in Miami where you can’t interact with radio.

Miami, you can’t dump body inside the Security Room

Problem with Robot’s arm

Columbia - invisible wall

Strange “thing” in corner of image (Alerdy Fixed)

47 Mark isn’t visible at UI. Should be “Pink” instead of “gray”.

Mumbai, 47 can’t drop down from balcony

Mumbai, is hard to get top - option to “hang” is hard to do

Sometimes in Summary Screen i don’t have 20 lvl of mastery even i’ve done that alerdy

20181118201617_1

Mumbai Guard outfit have different glasses in mirror

Rifle doesn’t have magazine even i have plenty of ammo

20181122205035_1

There is option to be frisked as a Guard in Whinston Creek

This pool of water from this hydrant doesn’t work with car battery, teaser etc

there is a noticeable difference in the textures between body and head

20181124100103_1

Lack of feature to turn off the water

This pistol don’t have information about ammo

There should be an option to change clothes even if you have that same outfit, but different pattern

20181124134545_1

Another invisible wall

You can’t take this saber, it’s too high

You can punch with that other NPCs (use silent attack), it sounds like breaking the bottle, but bottle is not broken

Levitating card

Similar item, differences in description

20181202095239_1

You can wear Elite Guard outfit, but 47 have different mask after change clothes

Viking axe grip is riddiclous big


#1290

He’s just too jacked! Simple shirt cannot contain his genetically enhanced figure =D


#1291

Hello,
I am playing on Xbox one. I just finished mumbay, and tried to access whittleton creek. The game asks for an update, but there is no such thing available. I am connected, though not through Xbox live gold. How do I get it solved?


Edit: updates just appeared.


#1292

I did Whittleton Creek SA/SO on Master, and i got the SA/SO Whittleton Creek Master challenge, but in the end i only have 4 stars because apperantly i had been spotted. I dont remember being spotted at all


#1293

She flies. And not only she. I encounter this problem quite often
20181125155523_1


#1294

Yeah,this way works.thanks


#1295

Already done with euler13’s way,sitll thanks