Official HITMAN 2 Bug Report Thread


#1317

PC platform, got SA rating for the first ET, but I didn’t get my terminus suit


#1318

You’re seriously saying this is not a bug?

It is simply impossible to unlock the sniper assassin challenge now, because you fail to meet the “Do Not Get Spotted” requirement.

I’d played the Legacy pack before the 20 November patch and even Colorado worked fine for me. It looked like they had finally fixed one of the most annoying bugs from season 1. I was able to snipe from the water tower all four targets and as long as I kept out of the guards’ vertical vision, which slowly filled up the suspicion meter - as you’d expect - I was never spotted. After I realised how stupid this bug had become I did some research to see what others have been doing.

I present exhibit A: a fabulous master difficulty run (pre-patch), which also earns the Within A Broader Scope challenge. He’s even standing up in the tower and there is zero detection, which you’d expect from such a distance.

HITMAN™ 2 Master Difficulty Walkthrough - Sniper Assassin Suit Only, Mumbai, India

Exhibit B: Mr Freeze2244 on professional difficulty. Yet again, this was done before the 20 November patch. No issues of being spotted.

HITMAN 2 | Mumbai | Within Scope & Within A Broader Scope | Assassination Challenge | Walkthrough

I’ve managed to unlock all the master sniper assassin challenges on all the new maps I’ve played since the patch, but it is absolutely no fun at all.


#1319

It’s the same glasses, it’s just not rendering the lenses in them due to the way they do reflections. I think it’s an engine limitation.

You shoot it.


#1320

I also managed to do Sniper Assassin in Sapienza, Bangkok, and Colorado with this patch.

You are NOT Spotted when they blind fire… In fact, if they blindfire, they tend not to run anymore to your location (which is actually ideal!)

But I also agree it was MORE FUN before this change when they seemed to just have no idea where the shot was coming from.


#1321

What platform are you playing on? I’m on Xbox and possibly that’s the difference. Trust me, on Xbox there is no blind fire. Once that happens you’ve lost your “Do Not Get Spotted” status and the challenge will not unlock.

But you’re missing the point. Pre-patch there was no impossible detection at a massive distance through solid assets. Now they know instantly where you shot from and you get spotted. That is a bug and has ruined this element of the game. Hopefully IOI know this and are planning to fix it.


#1322

Steam PC.

What happens in my case is I take the shot. Target Dies. I get “Unnoticed Kill”. Then “Body Found” (sometimes not even because they turn around immediately and blindfire. I hear the zing-zing of blindfire. Sometimes I even get hit. No Combat.

Pack up my rifle… Check instinct… No one’s coming… they’re still shooting where I once was… I walk out.
Sniper Assassin confirmed.

But I would also prefer to have it back to the state it was on release day. That was more like C47 which was a bit too powerful but only if you had good position and many yards distance.


#1323

PS4 free prologue, recently upgraded my Legacy Pack to GOTY. Here’s some stuff:

  • I have completed every Mission Story in Paris. However, I have not been awarded the related PS4 trophy for doing so (“So Many Ways to Stop the Show”).

  • I have reached Mastery Level 20 in Marrakesh. However, I have not been awarded the related PS4 trophy for doing so (“Ancient Marrakesh”).

  • In Contracts mode, soon after tagging your very first target, the “Mission Accomplished” theme starts playing and won’t end until you exit the mission, no matter how many targets you still have left to tag. I think it plays over the regular level music, and you can hear both at the same time. This was not the case in Hitman 2016.

  • The game lags a bit when shooting or aiming a gun through glass. For example, when sniping at Soders’ heart from the hallway to the garage, there’s a noticeable frame drop for a few seconds soon after shooting.

  • It seems that in the hospital area of both Hokkaido missions, guard NPCs can somehow throw flashbang grenades though solid walls and windows.

  • The Concealable Baton doesn’t have an illegal item warning sign (pink square with a ‘!’) in the inventory, although the sign does show up correctly in the weapon HUD.

  • Also, on the screenshot above it seems that the middle inventory is mismatched and doesn’t line up correctly with the minimap and weapon HUD.

  • There’s a Hacker blend-in point in the Colorado house where you can blend-in with any disguise.

  • In The Author, there’s a sign in the church square that is not solid, that you can easily walk through.

  • In World of Tomorrow, this regular bodyguard NPC located by the cemetery has an incorrect target portrait in Contracts mode, where he is shown as an Ether biolab bodyguard instead.

Most of these bugs are minor, but the first two about the PS4 trophies are not. I will report more bugs if I see any.


#1324

Trying to get the making waves challenge. Game consistently crashes when I try to dump bodies. Here’s an autosave. Just dump a few bodies on the cliffs and it should crash.


#1325

I am sadly writing to you today with frustrated emotions. I play on the PS4. I loved Hitman 1 and played it for hours on end. I paid for all maps and even got the DLC to keep enjoying the game. Then, when I heard Hitman 2 was coming out I pre-ordered Hitman 2 silver edition almost as soon as possible. And to say the least, I am not disappointed. The beautiful maps and in-depth storylines weaved in and out makes the game such a blast to play. When ioi said that they were going to remaster all the season 1 maps and that previous owners of Hitman season 1 would be able to play the old maps for free, I was thrilled. This is where the problem begins. When I went to the old maps on Hitman 2 I saw that they said no access. So I did some searching on why and saw that I had to download the legacy pack on the original Hitman 1 game. So I went back onto Hitman 1 to download the pack. To my surprise, my Hitman 1 account did not have access to any of the maps either! Even though I have progress on the maps and have challenges completed it says I have no access. Because my account no longer has access to any of the maps that I have paid for, I not only lose the ability to play Hitman 1. I also do not have the ability to play the season 1 maps on Hitman 2. I have no idea why suddenly I have no access to maps that I have played and bought before. Hopefully, you have some solution you can offer me. Any reply would be appreciated, as I do not want to buy the GOTY legacy pack to get maps and content that I have paid for.


As you can see I have 61 challenges completed and mastery level 20 on Hokkaido but when I go into it, everything says I have no access. I would show an image of that but I can’t because I am a new member.
I would love a reply, Thank you.


#1326

Yes this happens every fuckin time
Pc master difficulty


#1327

The suit description for the signature suit is still the old one. I am pretty sure this isn’t a burgundy tie, that was the description for the 2016 suit right?


#1328

Start another thread about this and tag @Travis_IOI… This is not a bug but may be an account issue with IOI.
They have ways to verify your purchase. They will help.


#1329

Platform:PC
Bug:0 score gained even if I got a silent assassin rate in Mumbai.
screenshot:


#1330

It’s unlikely a bug, but with those non-lethal fire extinguishers and new physics the Slam Dunk kill challenge in The Source mission becomes impracticable.
No matter how many FEs you put there, but in HITMAN 2 you can’t make Sister Yulduz fly in any manner.
So, either bring back HITMAN 2016 physics, or remove this challenge from game.
Cuz this challenge is impossible to achieve.
And all the fun from HITMAN 2016 disappeared in general


#1331

Wat’s wrong with this subtitle?


#1332
  1. Santa Fortuna - One female NPC in the hostel window who is chatting with guy sitting on chair outside is an enforcer for Shaman/ Taita disguise. I think it is a bug. Otherwise makes no sense.

  2. Miami - saving and loading caused race to finish instantly. (already reported issue, but still bugs me)


#1333

Not sure if it’s a bug or if it’s intentional, but “The Cheveyo Calibration” (in night Marrakesh) has the Sieger 300 Ghost spawning in a S1-style ICA smuggle spot rather than in a briefcase.

Was quite surprised to see that there. Thought they’d all been removed.


#1334

Because part of that escalation is to sneak with the sniper rifle visible


#1335

Yeah happened me me also. Once i did out early while hiding and they dismissed it. Then i waited and did it right before the Gaurd walls in and it worked…


#1336

Challenge on Santa Fortuna “Got any ID” is broken, and won’t pop as complete no matter how many times I enter the caves as the hippie.