Official HITMAN 2 Technical Support Thread

Can you try with all your settings on low/off? Even audio

After playing on low for a an hour without a single crash so far and after the first hour I set everything back to ultra except for simulation quality in both video and audio and the next hour it also didn’t crash so I think I found the culprit. I will say though that I am a bit confused since after reading that the setting only affects graphics in two maps I haven’t played yet and audio affects the whole game but I’m pretty sure I had it set to base when the crashes started for me. I’m guessing at this point it’s an audio driver issue but I don’t really know how to go about fixing that if I even can.
Edit: Nevermind the next time I launched the game without changing settings it went back to crashing every 5-20 minutes.

I’ve managed to solve my issue after finding out that windows driver updates and my own motherboard’s driver download page have been saying that the most up to date drivers for my system were outdated by 3 years. After personally going driver hunting in forums I was able to actually get an up to date audio driver released this year and have not crashed since.

I am playing on a gaming laptop. I have bought the game on Steam and many of its DLCs. At the momment I have 58 hours spent in-game. Now when I click on the “Play” button, the game starts, but before anything could be done it closes back up. Also as much as the game is on (from 1 to 3 seconds) all I can see is a black screen. How can I make the game play again? I have all the space I need on the laptop and it still does not launch.

  1. If you have Razer peripherals and Hitman crashes, it’s likely caused by RzChromaSDK64.dll found in C:\Program File\Razer Chroma SDK\bin and/or C:\Windows\System32, rename or delete the .dll file(s) IF IT SHOWS IN THE ERROR LOG (SEE VIDEO) (You only need it if you program software for the hardware)
  2. From the Launcher: Options -> Graphics API -> Direct3D 12
  3. Update everything with drivers
  4. Delete these three folders and verify gamefiles \Steam\steamapps\common\HITMAN2\dx12Retail \Steam\steamapps\common\HITMAN2\Retail C:\Users\XXXX\AppData\Local\IO Interactive\HITMAN2\ShaderCache.bin
  5. Verify your Windows https://support.microsoft.com/en-us/help/4026529/windows-10-using-system-file-checker


This is what you asked me to show. All windows updates are in place and the folders have been deleted. I did as the video showed me and you can find the result at the begining of the reply. Everything else is updated.

I have been playing the game for a bit and have been experiencing game crashes even though my game does not lag at all. The game suddenly goes to the pause menu, not letting me do anything, then shortly after, closes. I am using a shared library if that helps at all.

Your platform name will surely help.
If you’re using PC, try to set DX12 in game launcher settings

Nope, didn’t help. But yes, i am using PC and steam. Any other suggestions?

Take a look at theese 2 threads that recently been issued:

Seems like my issues are caused by the nvlddmkm errors. I will try to get this fixed.

I’m playing HITMAN 2 on PC steam platform, and there is a situation in Colombia mission where the games crashes each time at an exact moment.
I have a save before it too when after loading the save, about 1 min later game will crash each time.

Start a new game.
Most likely the save you’re loading is corrupted.
I have been through it a few times.
Every time game crashes at the same moment.
I don’t know what exactly causes it, but fresh game always runs perfectly

Hi! i have a problem im running hitman 2 (GOTY:Legacy pack) first time on my Laptop.
Screen looks like this.! UI is displaying normally.

PLEASE HELP!![
I having this problem with every mission!

  1. I had to change the desktop resolution from 19201080 to lower (for example 16801050)
  2. run the game (should now start normally at full screen on lower resolution)
  3. set display settings in game and mainly the resolution to your desktop (mine 1920*1080)
  4. exit game
  5. change back desktop resolution to normal settings (mine 1920*1080)
  6. run game again should now start normally at full screen in full resolution :smiley:
    https://steamcommunity.com/app/578330/discussions/0/135514507320124365/

Not working bro :disappointed_relieved::disappointed_relieved::disappointed_relieved::disappointed_relieved::disappointed_relieved:

Try looking around here: https://www.google.com/search?q=game+only+top+left+screen+site%3Awww.reddit.com

Sorry but i uninstalled the game