Official HITMAN 2 Technical Support Thread


#210

Same problem here. Was working like a dream until hotfix. Now it crashes seconds after loading a saved game.have gone through all recommended fixes (except reinstall) with no success. All drivers are up to date
My system is
Win 8.1
Amd fx8320
Gtx 1070
8Gb ram
Running on an ssd.
I may be forced to reinstall but I am not really happy about that.


#211

I have Hitman 2 on PS4, my issue is, I’ve redeemed the Legacy Pack and downloaded all the content. But when I come to access the missions in Season 1, they won’t let me play them, they say “Get Access” and message pops up saying “Downloadable content not installed”. I tried different options, I re-download them all, restarted the PS4, restarted the game, shut down the PS4 and tried again, deleted the whole game and reinstalled it, deleted Hitman 1 (After updating and redeeming the Pack). Nothing seems to work, only way I can play the first season is on the old Hitman game and not the updated editions. As you can see in the images below, the in game image saying I don’t have the content install, and the others showing what content is installed on my PS4.


#212


#213

Dear IOI,

I don’t know how to start since I am very frustrated.

I have preordered the Gold Edition and started to play on sunday.
At first I did a run of Hawke’s Bay and was happy to play a new Hitman game at last, did SA/SO on my first run, just imagine how happy I was. I have played the first Hitman season one for almost 500 hours.

Then I began to thoroughly explore Miami, killed Robert (that took almost 5 hours) and went for Sierra. I haven’t experienced any crashes. But when I entered the VIP area with a huge crowd the sound began to stutter and went mute. I thought that may be because of the crowd so I went back to the starting location and the sound returned. I thought I’d call it a day anyway.
When I started to play on tuesday I reentered the crowd, the game went mute again. I thought it may be something with many concurrent sounds that you’d fix later and thought I might just endure playing without sound for a while or at least until it gets less crowded and the sound might reappear again.
But when I reached the garage area the game began to CRASH to desktop. I reloaded my latest save and it crashed again. And again. And again.
Then I thought of the timer feature, that is disabled by default, I turned it on and noticed that the game always crashes at the exact the same time of 3:34:28 (I know I said it took me 5 hours to kill Robert, but I reloaded a lot). It did not matter whether I sttod in place, moved my mouse, killed people or ran around in circles. The game always crashed at 3:34:28. The time of the save was around 3:31:ss.
Then I loaded my previous save from 3:27:ss and it did NOT crash at 3:34:28.
Instead I was able to play for a while longer, explored the clinic, ran to the hotel and BANG, it crashed again, this time at 3:56:33. And it’s the same again; Whatever I do, it always crashes at that exact same time.

My specs:
Hitman 2 PC Steam Gold Edition
MB: MSI Z170A Gaming M3
CPU: i7-6700K (not overclocked)
RAM: Kingston HyperX Savage 2800MHz DDR4 CL14 DIMM Kit (2x8GB) (not overclocked)
GPU: MSI Nvidia GeForce GTX 1080 Gaming X (not overclocked)
SSD: Samsung 850 Pro 512 Gb

OS: Windows 7 x64 Ultimate
GPU Driver: 416.94

What I tried so far:

  • Checked Steam game cache
  • Got all possible Windows Updates.
  • Downgraded GPU Drivers to 416.81
  • Disabled NVIDIA DSR
  • Moved the game to another HDD (Seagate)
  • Disabled steam overlay/steam sync
  • turned all graphical settings to minimum
  • closed all background apps incuding AV and Firewall
  • tried to play around with NVIDIA panel settings
  • performed a clean install of the latest NVIDIA driver 416.94
  • rebooted a lot

The only thing I can think of that I didn’t do is uninstalling and redownloading the game, but that’d take almost a whole day to redownload 100 Gb since I’m on a f** ADSL with 8m DL if I get lucky.

Please help me, I never felt so frustraded because of technicel stuff because I never had any problems like that. I have enjoyed the 2016 game season since it’s beta mission on a ship, I loved the episodic releases and I spent almost every evening that year playing your game without any issues, crashes or whatever. And I did an SA on every Elusive Target but 1 (The Bad Boy), so that’d be even more frustrating if I can’t SA Sean Bean because of crashes or something that isn’t my own fault.

Best regards,

  • Alex

Hitman 2 Crashing with 0xc0000005
#214

Forgot to include this:
Problematic Event Name: APPCRASH
Application Name: hitman2.exe
Application Version: 2.10.1.0
Application Time Stamp: 5bec3527
Error Module Name: hitman2.exe
Error Module Version: 2.10.1.0
Error Module Time Stamp: 5bec3527
Custom Status Code: c0000005
Exception Condition: 000000000ec14f7e
OS Version: 6.1.7601.2.1.0.256.1
Local ID: 1049
Additional Information 1: 0aa7
Additional Information 2: 0aa71365584f9463fe8beb187d957f1b
Additional Information 3: 3cc7
Additional Information 4: 3cc7beaa1cbfa47ff9aa956f1926894c


#215

Upgraded my HITMAN golden edition, with GOTY legacy pack, lost my black suit with black gloves…

HELP!

Send ducks!


#216

I started Sapienza again and after a while the game developed the same crash-to-desktop. There is no specific pattern; at one point I tried three times to get one particular person knocked out and it crashed every time after putting her in a specific hiding place. I changed what I did and it worked - for a while, then just crashed to desktop before the game loaded. This forum is very difficult to navigate.


#219

Can’t access the legacy pack in Hitman 2

It seems I can’t access the legacy pack in Hitman 2. Everytime I go to the older maps the game tries to lead me to the PlayStation store but it can’t find the content and brings me back to the game.

I patched the latest update for Hitman 2016 and already downloaded and installed the legacy packs.

I bought Hitman 2016 digitally on the United Stats PlayStation store and bought Hitman 2 digitally on the Japan PlayStation store.

I guess the cross region is the problem here. Do I have to repurchase them again if I want to access the legacy pack in Hitman 2?:sob::sob::sob:


#220

Playing on Xbox One. Standard edition downloaded today.

Issue from the very start that Agent 47 continuously walks forward even when letting go of the thumb stick. Have to apply very slight and particular back pressure to stop him walking. Same issue on several different missions. Makes it unplayable.

Definitely a game issue as then tried playing previous Hitman with no problem.

Uninstalled and reinstalled game fully and same issue. Reset Xbox and same issue. Controller is connected to the console through the usb wire.


#221

^^^Same issue. Xbox…
Also after changing disguise, freezes the game, have to restart entire console.


#222

Hi, I’ve been having an issue on xbox one where every map will download, install and play EXCEPT miami. I tried deleting and reinstalling the game and the map, tried the uninstall from offline and restart and install online trick, but it wont work. Also, I have bought the expansion pass, and though it has downloaded and installed, but it doesn’t have a tick next to it in game like the goty legacy pack.


#223

Playing on PC and any time I try to launch the game it tries to update and has been for hours. I have went through steam and tried to repair the files, it said 4 files were incorrect and repaired them but the game still won’t launch. I was hoping I could get help on how to fix it.
Thanks


#224

Others have probably reported the same issue too, but I might as well throw my hat into the ring.
I’ve been able to play through the game perfectly up until Colombia, and then some. I’ve killed 2 of the targets (Martinez and then Rico), but now trying to go after Franco my game just keeps consistently crashing. It started occurring as soon as I killed Rico and started to leave the mansion, the game just crashed. If I reloaded the same save, it would crash ~10-15 seconds over and over. I reloaded a different save which was only a few minutes older, and was able to make it to the neighboring farm before randomly crashing again. Saves I made along the way crash as well, and now even the save in the mansion that worked before crashes as well. I know the game updated last night while I was playing, but I don’t know if the patch was applied mid-game or something somehow, if it’s the patch’s fault (I killed Rico, crashed, and as far as I can remember Steam started downloading the new update.)

I have tried disabling Ansel, Geforce Experience, and the “ignore memory safeguards” option in the launcher as suggested on the Steam forums, but none have worked for me. I’m also on the latest Nvidia drivers (which, as far as I can tell, is not the reason for the problem as no one else has reported it as making issues for the game,sinces newer Nvidia drivers have done with other games in the past), and reinstalled the game, so I really have no clue what the issue is.
I’m not the only one either, as there are a few threads on the Steam forums that report the same issue on Colombia. I believe I’ve exhausted everything I can do. At this rate I’m just gonna ensure I keep one of the saves to go back to (it was a 2 hour suit only run), and move onto the next level and pray I don’t crash there.

If you need my specs they’re:
Windows 10 64 bit
AMD Ryzen 5 (overclocked)
GTX 1070
16 GB ram
ASRock X470 Master SLI/ac


#225

Could you post the solution xbox gave you?? It would be really helpful to anyone else looking for an answer :slight_smile:


#226

Hey IOI, I got a new OMEN HP computer recently, no parts taken out/changed in the computer. Just like it was in the box. I am having a problem connecting to the Hitman 2 servers, and the message displayed is: Saving dynamic resources FAILED: “Permission denied”. I looked on a forum and saw a fix for the first game, but it does not work on the second. I have reinstalled the game once, and onto a different hard drive. I got the error both times I installed the game. Any help would be greatly appreciated!


#227

I have been having the same problem, I hope for both of us that we will get a response soon


#228

I frequently cannot connect to the H2 servers on my Xbox One.


#229

So for anyone on Xbox One having trouble with Santa Fortuna here is the solution.

Uninstall the Santa Fortuna mission then hold down the xbox power button for 10 - 15 seconds, once done then unplug the console from the wall for 3 minutes. When this is over plug everything back in, turn the console on and re-install Santa Fortuna.

This worked a treat for me and I am now able to play the game in full.


#230

I’ve just started to go pack over the 2016 maps after completing 2’s story but having a strange issue on Sapienza, I’ll be able to start the map fine and play for a few minutes but with no warning all of a sudden it’ll freeze and eventually crash to desktop. It doesn’t seem to be triggered by anything as the three times I played it just now I went to different locations, different loadouts etc.

I haven’t had this issue on any of the 2 maps nor Paris or Marrakesh so far. Should I re-download the map? I’ve already verified the game files and that produced no errors


#231

Hey dude,
I wrote a similar report just yesterday, so I’m being curious.
If you enable the in-game timer under Settings->Gameplay, and load a save, will it always crash at exact the same time, like it’s in my case?
For me it’s basically:
Manual Save X -> always crashes at 3:34:28 whatever I do
Manual Save Y -> always crashes at 3:56:33 whatever I do
and so on.