Official HITMAN 2 Technical Support Thread


#295

I patched but I’m still crashing. Took only a minute this time. Please see my post earlier in the thread for details about my setup.

It really sucks that I’m going to miss the elusive target.


#296

I don’t know if this is the right place to send this message, but here it goes:
I played hitman 1 and got mastery of some levels, but in hitman 2 it doesn’t show up. I have both games linked and it all seems ok. Can you help?

Thanks


#297

Progress doesn’t transfer from game to game. You have to redo all of the unlocks and challenges.


#298

Hi! I gave another user a breakdown as to why progress does not transfer over here in another thread!

Hope this helps :ok_hand::grin:


#299

Uninstall then download the game again, reinstall.


#300

When I start as ninjas in Hokkaido and try to get the sauna people to get out after killing Eric elders. Instead of making them leave after turning up the temperature,they just die in the sauna.


#301

Hi there,
just downloaded the nov 20 update.
Last played yesterday but now that the download is done all of the levels legacy and new redirect me to the store where it says I own and have downloaded the content


#302

Hello i have a quesiton does anyone else have a problem like i do with disguises whenever i get a disguise, i think they did such a nice job with the idle blending in animation like when you pick a security disguise 47 acts as a security guard right. But for me every time i get an outfit it bugs out like the animation never goes threw 47 arms always bug out and the animation stops, is my ps4 pro broken is the game broken can anyone address this issue ?


#303

See 8 bugs spotted by me: Hitman 2 - new bugs spotted, Santa Fortuna and global

(Sorry for double reporting, I’m not sure where to post bugs.)


#304

Sorry if this is not the place to post my issue.
I have H1 GOTY digitally installed on PS4 Pro.The size was ~66GB.
A week ago I bought H2 gold edition psysical.After the patch installed the size was ~48GB.
I redeemed GOTY Legacy Pack within H1 store and started the download of the 6+1 seperate packs.
The total download of ~30GB was done today and I noticed the size of H1 app increased to 96.05GB.
I can see the add-ons of the legacy maps appear there as well.
On the other hand the H2 size seems to be increased too and it appears as ~78Bg total.
I tried to move H1 to my external drive to free space , and the size of H2 on my base drive decreases to 48GB.Unforunately the legacy maps turned red within H2 and I cannot access them.When reconnecting my external I can see them being playable again.
I restored licences , rebuilt database and the poblem is still there.
The legacy pack FAQ doesn’t mention that we need both H1 and H2 installed to access the maps…

Why is the initial download of the legacy pack been stored to Hitman1 app at all??
If I had both H1 & H2 on the PS4 Pro installed and tried to delete H1 would the 30GB pack been lost??
Can you fix this problem or the only solution is to download again (another week of slow internet) the same 30GB while the H1 app is on the external drive for this to finally been applied to the H2app??
I would appreciate if you answered me as soon as possible!!! @Travis_IOI


#305

I’ve redownloaded miami in en effort to play the undying. It was acessable this morning before work I’ve come home and now it’s been uninstalled. I paid quite a bit for this game and was loving it before the nov 20 update


#306

I have played quite a lot today with minimal crashes, but this last hour or two I have been constantly crashing after 1 minute in game, crashes to desktop. Anyone else experience this on PC?


#307

No I have not but it hasn’t impacted my gameplay yet


#308

I have hitman 2 from steam family share but after the update of 16/11 the game does not launch and a window about codefusion appears.


#309

Hello, my problem is that i have HITMAN 2, and i also had HITMAN 1, but, in HITMAN 2 every progress i’ve done in the previous game just resetted themselves,so now i’m level 0,like i’ve just bought that game, and it’s a little bit wierd because all my work is just lost. Is this like a normal thing and i should restart from 0 normally or i can recover my progresses? I’m currently playing on PC) Thank you!


#310

Hi all,

Previously gsync had worked very well with this game for me with gsync doing what is is supposed to do very well - smoothing out the fluctuating frame rate.

Now however, with gsync one I can notice some very obvious juddering. Not stutter or frame skipping, but rather juddering. there’s a difference between stutter and juddering and the experienced will understand.

If I launch the game on my second monitor, which is a basic 1080p 60hz monitor, vsync on, the game will run silky smooth. yet on my expensive AOC 144hz G2460 monitor, its sadly not performing well at all.

Anyone else having this issue?


#311

I’ve been playing Hitman 2 on my Xbox One X and I also own the first Hitman on the same account. I can play every mission except for Legacy: Hokkaido. Is there anything I can do to fix this? I’ve tried to reinstall it several times but even when it’s all installed it doesn’t recognize me owning Hokkaido.


#312

I bought the Standard Edition on the Expansion Pass. I have every level except Miami unlock, and when I try to play Miami it directs my to the Gold Edition. What should I do (I have found no information on this online)?


#313

Hello, I have a bug with the Elusive Targets Challenges , namely the Silent Assassin part of the Elusive Targets Chalenges… I completed the first Elusive Target ‘The Undying’ in Hitman 2 with a Silent Assassin rating and got The Elusive Targets Silent Assassin challenge for the Undying, but The Elusive Targets "Silent Assassin Elusive Target I did not complete or register in the challenges… can you fix this please by unlocking it on my profile if possible? or reset the elusive target so i can do it again? it is a real bummer cause i cant play it again… Here is a screenshots of my problem…! you can clearly see on the right side of the screenshot i do have the silent assassin rating challenge done for the Undying


#314

0/5 Did not register the silent assassin rating from The Undying Elusive Target