Official HITMAN 2 Technical Support Thread


#356

When using the peephole in A house built on sand, aren’t you supposed to be able to hear Kwong’s Phone call?


#357

I am playing on a PS4 and both the Miami and Columbia missions crash with a CE-34878-0 error every time the number of hidden bodies increases over a certain amount (a number that I would think would not be inconsistent with a normal playthrough). This basically translates to a crash every time I approach the level’s completion on “Suit Only”. I have exhausted Sony’s system support for this error and have also tested this out on a brand new PS4 Pro, and the crash still persists. Has anyone else experienced this?


#358

^^^ Yes I have.

I fear I may have posted this incorrectly in the ‘Bug Report Thread’ so I will post it here.

The final level ‘The Ark Society’ bricked my PS4 Pro yesterday. I had a total of 23 ‘CE-34878-0’ errors in the space of 3.5 hours until I was forced to restart my console which resulted in the dreaded CE-34355-8 ‘PS4 cannot access system storage’ fatal error. I changed the SSHD out, couldn’t boot into safe mode, power cycled and left it overnight. Nothing sorted it.

Went out and bought a new PS4 Pro this morning and, lo and behold, 16 CE-34878-0 crashes/errors in 2 hours:

Tried switching between framerate/resolution priority, turning boost mode off, HDR on/off etc. but I could only play about 15 seconds of the game before it crashed. It happened with every save file, but only on The Ark Society.

I’ve knocked it on the head as I can’t risk having another system bricking. Shame as it was an enjoyable game.


#359

I was having that frequent crash, and disabling VSync suddenly made it so that I can’t get past the opening cinematic :confused:


#360

Constant random crashing for me on ps4. Mostly triggered by Auto saves i think… I have did everything possible including 2 ps4 and 3 game copies! First location plays without a single issue. Move to Miami and the constant crashing starts. 5 before I eliminated the first target!


#361

PS4
When I heard Hitman 2 was coming out I pre-ordered Hitman 2 silver edition almost as soon as possible. And to say the least, I am not disappointed. When ioi said that they were going to remaster all the season 1 maps and that previous owners of Hitman season 1 would be able to play the old maps for free, I was thrilled. This is where the problem begins. When I went to the old maps on Hitman 2 I saw that they said no access. So I did some searching on why and saw that I had to download the legacy pack on the original Hitman 1 game. So I went back onto Hitman 1 to download the pack. To my surprise, my Hitman 1 account did not have access to any of the maps either! Even though I have progress on the maps and have challenges completed it says I have no access. Because my account no longer has access to any of the maps that I have paid for, I not only lose the ability to play Hitman 1. I also do not have the ability to play the season 1 maps on Hitman 2. I have no idea why suddenly I have no access to maps that I have played and bought before. Hopefully, you have some solution you can offer me. Any reply would be appreciated, as I do not want to buy the GOTY legacy pack to get maps and content that I have paid for.


As you can see I have 61 challenges completed and mastery level 20 on Hokkaido but when I go into it, everything says I ha ave no access. I would show the other image but because I am new member I can not.
I would love a reply, Thank you. @travis_ioi


#362

I cant access the legacy pack levels. I open Hitman (1) and select the Legacy Pack link, it takes me to Xbox Store (Im on XBOne) but it says the pack is currently unavailable. I am unsure if this is something i should be bringing to you guys or MS.

Edit: After uninstalling Hitman 2, making sure the disc wasnt inserted, reinstalling the prologue, I was able to download the Legacy pack. It says my Hitman 2 levels are still unavailable, but I’m waiting for it to finish downloading and installing the legacy levels to start worrying about that.


#363

PC
i5 4690k
nvidia gtx 970
Graphic issue, after updating the nvidia drivers to 417.22 version Nightcall and Three-Headed Serpent look like those screenshots:


#364

now you know how enemies feel when you use instinct =D


#365

1080ti 8700k etc i played this lvl 2 days ago (everything was ok even this lvl). then nvidia driver update came and now i have this s.it


#366

hello I am having an issue removing hint guides out of the mission stories in Isle of Sgail on PS4. Specifically the mission story, “final club.” No matter what I turn off in the advanced gameplay tab, I am still able to see trackers over where to find all the coins. They are light blue triangles giving me the distance I am from the coins I need to find.

I want to enjoy the game without it telling me where to find everything. I turned off every single option allowed under the game play tab and it still shows me where all the coins are.

Please help! Thank you :grinning:


#367

Hi,

Possible issue report: Three-headed serpent, possible bug: the drug mule/cocaine souvenir story

  1. Learn about the broken cocaine souvenir by listening to the hippies conversation

  2. Hippie Mule asks hotel manager for glue, answer go to a store.

  3. I cannot interact with the shopkeeper until I have tried to glue the cocaine souvenir or maybe pick up the Drug smuggler memo (maybe normal?)

  4. When I can interact with the shopkeeper “I want to buy some glue”, the shopkeeper crouch down looking for the glue, gestures putting the glue on the desk saying “Here you are, señor” but no glue on the counter. :thinking:

Platform is PC running an up to date version of the Steam edition

  • CPU is Intel Core 2 Quad Q9550
  • GPU is NVidia GTX 780 Ti

Happy bug hunting :yum:
P.S. I would have provided more screen capture, but I am limited to one image as a new user.


#368

I had exactly the same artefacts on my GTX970, Only it was on most water surfaces.

Then good samaritan here told me to update my graphics drivers which I did one week before H2 release.

I *relactantly updated again - to newer still and Ta-Daaa! it had fixed it self.

So maybe wait for even newer version or roll back this one. It is weird nontheless.


#369

Ps4 Pro Gold Edition physical with legacy pack installed.
5 crashes in ten minutes when loading saves either auto or manual near the train area…
Error CE-34878-0.Will you fix it soon???


#370

The achievement on steam “One Night in Bangkok” is glitched? I reached level 20 in Bangkok several days before, yesterday i was tracking the remaining achievements and saw it didn’t unlock.

Anyone had this problem? Any workaround?


#371

Has there been anyone from IO that has said or acknowledged PS4 issues yet? Not trying to be a a$$, it’s just i do not hear much.


#372

I’m on Xbox and i have the legacy pack for Hitman 2, but I haven’t received the Aluminium travel Briefcase? Any idea when I might gain access to it? thanks
ColBilly


#373

Please add support for dualshock 4 without wire. On the wire, the game sees my gamepad, but without a wire, I see buttons from the Xbox.


#374

Hi I got the ICA Tripwire weapon but it wont let me apply it anywhere. its like you guys for got to code it as a item that you place. it is coded as a throwing object only! has anyone else notice this?
PlayStation 4


#375

New poster, sorry if not in proper format or topic. I have a issue with finishing my challenges. It may already have been addressed, but I have nit seen any fixes or links to info. Here is a pic of the issue. I have this issue across multiple locations. This image and location is for reference.

. My system is an Xbox one x.