Official HITMAN 2 Technical Support Thread


#398

Reloading a save, sometimes even saving at all, destroys some game mechanics, like challenges, timed events, AI behaviour is broken then, etc…, all after the last update.


#399

And it should be fixed in the upcoming patch

https://www.ioi.dk/hitman-2-game-update-2-12/


#400

Hi, I have encountered an error after the latest patch on 18/12/18.

The error is that whenever I open the “load game” menu while playing, it will load for a long while and a message will pop up saying there is an error. (as attached) It has happened at least thrice now and it is really infuriating. I hope some help can be provided. Thank you!


#401

After patch 2.12.0 still very low GPU utilization. This resulting, in low FPS. Screenshot shows that. I cannot get a stable 60 FPS, although the GPU is only 51% loaded.

The same problem was in season 1 of the game, but DirectX 12 was there and the situation was noticeably better. Also game sometimes stutters. For example, when saving occurs, but not only at this moment. This spoils the impression of the game. I ordered the game as soon as it became available and really want to get pleasure, not disappointment. Please fix it problems.

Windows 10 Pro (x64) 1809, Core i7-4790K up to 4.40GHz, 16Gb RAM @ 1866MHz, MSI GTX 1070 Gaming X 8Gb (any driver).


#402

i have posted this a few weeks ago on the bug forum section, but i guess it better fits here:
back then i did Mumbai silent assasin suit only on master, i escaped via boat and at the moment that my final screen should pop up (score) i got the disconnect error.
Tried to reconnect but failed so i had to go offline and restart the game.

After restart i noticed that i got the silent assasin suit only on master difficulty challenge completed but the bar of the classics challenge for Mumbai is still at 0 out of 5.

After that i redid the silent assasin suit only again from start, this time it got completed en i did not got the disconnect message but that counter is still 0 of 5.

Am i screwed now forever for getting that suitcase and lockpick or can this be fixed?
Also do other people have this issue as well?

screenshot of having Mumbai SA/SO checked:

Screenshot of having the classics still at 0 out of 5

playing on PC


#403

Platform: PS4
Version: After the Dec. 18 update

Issue:
In Hokkaido, when I’m on the mountain path, starting to aim with a sniper rifle, the game crashes. Goes to a black screen, and then the game shuts off. And this happens EVERY time. And with any outfit and any rifle. Please fix this soon. This did not happen in the previous version.

Edit: This seems to happen with every map. So I cant use a sniper rifle anywhere. PLEASE FIX THIS. Also, I had no problems with the game crashing until this new patch. At least for me, it broke the game.

Edit2: I had a new update arrive today, but the problem still exists. Can’t snipe.


#404

I’ve had this problem for a few weeks and the latest update hasn’t changed anything. On Hawke’s Bay my Versatile Assassin challenge is stuck at 4/5 even though I have 10/11 Feats completed. Additionally, The Classics (Casual and Professional) are both stuck on 1/5 even though I’ve completed all the classic challenges.


#405

[quote=“Travis_IOI, post:1, topic:26144, full:true”]
HITMAN 2 is on the verge of launching officially. (Hello New Zealand!)

To help us track issues and stay on top of any problems at launch, please use this thread to report what you are experiencing. Please only report technical issues here. If you have a bug report, please use this thread:

When reporting an issue, please include the following details:

  • Describe the issue in as much detail as possible
  • Tell us what platform you are on
  • Provide any images or videos that might help

Please remember that you can also report issues to the HITMAN 2 publisher, Warner Brothers, through their dedicated customer support page, found here: https://wbgamessupport.wbgames.com/hc/en-us/categories/360000132307-Hitman-2
[/quote]
When I was playing sapienza, i tried to save game but it just keep loading and after one to two mins, it appeared like this, hope the developers will fix it as soon as u guys can


#406

The game can’t load anything. Error message: “Unable to load the requested item”. This seems to be about the servers at your end.

On my end:
5GHz connection
Windows 10
1080ti graphics
etc.

Just a thought: can you please release us from depending on your overloaded servers when playing?


#407

So, It seems as though every time I try to scope in on a sniper the game crashes. Playing on ps4.

edit: beaten by Killer-77


#408

Hello Im playing in PC and recently been experiencing the save/load issue or more specifically the “unable to load the requested menu” error. Hope you can fix this ASAP.

Thanks!


#409

Yep same issue here. Have already submitted a ticket 8 hours ago. Hopefully this gets fixed before Christmas :slight_smile:


#410

Flash bangs thrown from guards are also crashing my game on ps4.


#411

@infernostew Same thing here. :persevere:


#412

Having the same Save/Load problems as everybody else, at first I thought it had something to do with my razer keyboard interacting with the game (the colours, and how it reflects actions/HP) but then I realized it might have something to do with the latest patch. Hoping for a hotfix, since this makes the game kind of unplayable.


#413

I’m currently playing on PS4 (all updates are downloaded) and the game keeps crashing when I go to zoom on the Sieger 300 Ghost sniper.

I get the error code CE-34878-0. I’ve reinstalled the game and updated it but still have issues. Can you please release a patch to fix this, the game is virtually unplayable with the error happening.

Any other recommendations welcome.


#414

Hi. I am having a blast playing Hitman 2, and was able to play all the main content seamlessly. However, the legacy Hitman 1 content seems to be giving me some issues. Specifically, while playing on those missions, when opening the save or loading screens, the game hangs and seems to fall offline. I don’t have any internet issues while this is happening, I can still browse the web and everything. It won’t work even if I wait for it to fail and retry, or even unplug from the web and let it fail. I just have to keep force quitting the game. Not a super fun experience. Would love some help with this!!


#415

Same here - after patch my pc will not load any saves - amd fx / win 8.1


#416

Same problem as everebody else "unable to load the requested menu” when save/load
Hope you fix quickly the issue :slight_smile:


#417

Is there a log file anywhere? I got a random crash in Ghost Mode, complete crash with no pop-up message. Windows 7, HD 7950, 16gb, i5 2500k.