Official HITMAN 2 Technical Support Thread


#418

O.K so I’m wondering if someone here can help me, in a way that’s actually useful.
I had this problem with Hitman 2, in which it defaulted to 1920x1080 resolution and won’t let me set it any higher. The setting isn’t greyed out, it’s entirely absent. If I use another program (like Nvidia Experience) to set it to my monitors native Resolution (2560x1440), Hitman 2 “defaults” it back to 1920x1080.
I’ve been in contact with WB since the day after it came out (I got the gold edition on Steam) and yesterday they tried telling me that if a resolution isn’t displayed in the settings then the game doesn’t support it, an obvious lie!
When I called them out on it they just responded with “We’ve passed your request for support to the team that supports the game”. I’ve had no further response from them about it.
My specs:
i7 8700k
32GB RAM (3200mhz)
1080ti
ViewSonic XG2703-GS monitor


#419

I have hitman 2 but I dont own the legacy pack and I didnt get the holiday hoarders to my hitman although on the ps4 I have just the demo and I got the holiday hoarders there


#420

Playing on PC Windows 10

Been waiting for this new elusive target and was so happy to finally play it. I have eliminated the target successfully but the game decided to crash and not respond to any of my actions right before I was exiting the mission causing me to lose as I got killed. I would very much appreciate if there was a way to some kind of relaunch my elusive target so that I get to play it one more time hopefully without crashing. It wasn’t my fault to lose at all, it was the technical issue with the game itself. That is not what I expected when finally getting a chance to try elusive target out.


#421

Hi just a quick bug report. I’m almost finished with Holiday Hoardes. Last night I completed find all Paris locations. The progress bar said so and the PIP notice said so as well but I’m still showing only 38 out 39. Your thoughts?


#422

After I press Play in the launcher, the launcher closes and nothing happens, after a few seconds steam also doesn’t show anymore that I’m playing. I don’t know what to do or how to fix this.

Rly Appreciate your help


#423

Hey, @Travis_IOI so I think I deserve an Elusive Target reset for The Revolutionary due to a fault I’m the games pause menu. So I was doing the target and I paused it mere seconds before he died to be a little faster. I went ahead and attempted to restart and it wouldn’t let me, but it let me replan the mission. When I accepted the replay it just shows the revolutionary and a failed above it. I’m not so upset that I failed just upset that the game allows you to replan leading to the fail. So please Travis help me on this one especially since this predicament is one where are planning lead to me failing.


#424

I’ve got a serious problem here. My elusive target isn’t on the map!

@Travis_IOI, or anyone who’s actually affiliated with IOI, please can you help me out before the deadline expires?! Elusives are my favourite part of the game and I don’t want to miss one over something like this.

(video removed)

I’ve tried restarting the contract and the game, but no result.


#425

ETs don’t show up as red in the instinct ever (If that’s what you mean to show in that video?).


#426

OH. I never normally use instinct, so I didn’t know that, but he’s supposed to be in that hut in my video, isn’t he? Am I missing something?

I had to restart earlier in the day, first because of a dodgy connection, and then because I went out, and he was there both times I tried to play it.


#427

He has 3 randomized spawning locations, you can recognize him in the instinct only by the distinctive silhouette.


#428

Oh, thanks very much! I’ll go and look again, then.

It must have been pure chance that he spawned in the same place when I tried to play earlier.

Thank you again. :slight_smile: :blush:

P.S. Please disregard the above message, everybody (unless I can’t find him in the other spots). lol


#429

Hi I was just wondering if anyone knows what to do when you first get the game and all your mission have automatically updated apart from Whittleton Creek and isle of sgail


#430

Uninstalling only the razer chroma sdk in apps & futures worked - dont know why. The synapse app remains installed.
Enjoy bruh <3


#431

It’s been 6 weeks since this buggy piece of shit was released and in that time, there was 5 1/2 weeks of no SLI support, several days where we couldn’t play because IOI disabled the save/load feature and caused infinite saving screen… now that they’ve fixed that - due to the 250Mb update they released 2 days ago, the game INSTANTLY crashes to desktop EVERY SINGLE time I load the Sapienza level.

This CRASH to desktop buy plagued the first Hitman game for years, and I am NOT going to put up with it anymore. IOI used to be a great company that made great Hitman games, but since Absolution, it’s been nothing but a fucking mess.


#432

New computer about a week ago, (Ryzen 7, Radeon RX 580, 8GB Ram - not a super machine but should be able to handle this game). Downloaded the trial on steam, played fine, brought back memories of playing the early 2000 games. Bought the game, started playing in earnest yesterday, the game consistently crashes after 5 to 15 minutes of play, completely out to desktop. Apparently there was a hotfix that was put out to deal with other issues on the 21st, and now many people are having this issue. Any fix on the way? Any work around?


#433

Only gripe about that is that 8Gb RAM is not a lot. When I bought my PC 6 years ago, I went for 32Gb RAM (maybe a bit excessive at the time), but now it’s probably standard.

8Gb to handle games may be the problem. Is it worth getting an extra 8Gb stick and seeing if that helps?


#434

Posting here as well just for extra visibility.
After the PC patch of the 21st of December that fixed the Save/Load issues, I can’t play the game anymore. On the main startup screen, after pressing [Enter], the game freezes for about 2-3 seconds, and then immediately crashes to desktop without error messages. I’ve tried a bunch of different graphical settings, verified the game files using Steam’s built in function and updated my audio and video drivers. This only started happening after the patch.
I’m using an Intel Core i5 4590 @ 3.30GHz CPU and 4095MB NVIDIA GeForce GTX 970 GPU.


#435

I’m having the sierra knox glitch where she just disappears into the ocean seemingly and can’t be killed. It’s infuriating!


#436

I have the same damn problem… can’t believe people pay full price for crap like this. I’ve just had the infinite load screen bug AGAIN when loading a Bangkok save game, despite updating to v2.12.

I don’t remember Absolution or Blood Money (or even the previous games) having this many crashes ever…

And what’s worse, is that it actually didn’t crash to desktop BEFORE the v2.12 patch - now it’s doing it constantly on Bangkok, Marrakesh and Sapienza levels. They’re INTRODUCED this crash to the game now…


#437

I bought HITMAN 2 today and even though I have the Outstanding Performance coin in HITMAN 1, I do not have it in HITMAN 2. I think this is because I haven’t played HITMAN 1 in a while and so didn’t link it to an IOI account until after I activated HITMAN 2 today.

Platform: PC