Official HITMAN 2 Technical Support Thread


#130

Biggest streamer in Korea had the same issue just now.
It is a live from 2018/11/14


#131

I’m having trouble with getting access to large portions of Hitman 2.

Small history:

Got Hitman 1 Definitive Edition (all inclusive)
Pre-ordered Hitman 2, Standard edition (available as of today)

Last week I downloaded the Legacy Pack. Even though I only ordered standard, the Hitman 2 icon on my Xbox homepage gave me access to the Legacy Pack, and Hawke’s Bay, immediately. This was last Saturday.

Today I tried downloading the rest of Hitman 2. Within the game, the Miami mission has got this red colour, saying it’s not accessible. Clicking on it gives me directions to the Xbox store, which I followed.

These directions brought me to a page advertising Hitman Gold, and the invitation to buy it. Just above that is a mention of “Hitman 2: Prologue”, of which it’s mentioned it’s already installed.

After some searching, I find an overview right under that, with components of Hitman 2. Here I find the different locations ready for download: Miami, Mumbai, Whittleton, Sgail, Santa Fortuna and, again Hawke’s Bay. Himmelstein was also one of the downloads.

I download and install them all (several GB worth). This process is now completed.

Yet when I access Hitman 2, I still only get to access Legacy Pack and Hawke’s Bay. The other stuff remains red, and clicking on it takes me back to the same link.

What’s going wrong? I tried re-starting my Xbox but that didn’t help in updating my Hitman 2 hub in making these places accessible to me.

Any help would be greatly appreciated. I have a feeling it might have to do with Xbox rather than IOI, but I’m keeping options open. The Hitman: Prologue thing also worries me. It seems that the Hitman 2 icon always takes me to Hitman 2 Prologue, instead of the full game. I don’t remember buying anything with the name Hitman 2: Prologue.


#132

Hitman 2 Crashes when pressing “enter” after WB and IOI screens. Please help.

I am playing HItman 2 on a PC via Steam that meets the recommended system requirements. I downloaded Hitman 2 early release on 11/9/18. I played through Hawk’s bay without issue. The game ran great until the 10th. For some reason on the 10th the game started crashing after the WB and IOI screens where you are prompted to press “enter”. Upon pressing “enter” the game crashes without any error messages.

I have checked the integrity of the game files multiple times on Steam and re-downloaded and installed the game multiple times. I have tried to run the game on minimum settings as well. None of these actions have stopped the same problem from occurring.

Also, between my initial download and the game crashing, I did not notice any updates for the game downloading.

Any help would be greatly appreciated.

Thanks


#133

@Travis_IOI, steam issue or what? I’m in India, +5:30 GMT.



#134

Enjoy your shit performance, the game is currently completely unplayable with 8 GB RAM.


#135

Been a while. Anyway, on the storepage it says the game is free, and because I have HITMAN 2016, does that mean that I can download HI2MAN and play the legacy missions (or whatever it’s called; playing the missions from the first game in the second game). If not, what’s the purpose of it being free but then having to buy it anyway?


#136

Hello. I have the collector edition on Xbox. Last night at about 11 pm UK time (so midnight in most of the rest of Europe) Hitman started going wrong. Crash-to-desktop when loading a game. Various save files tried, all end up doing the same thing. Mostly just CTD, some load for a couple of seconds then CTD, sometimes I play okay then on a reload I just get CTD. Map is Sapienza. It crashes on two different Xbox units (white S and Halo 5). Restarting doesn’t alter anything. Other games play okay. It’s annoying, shouldn’t happen, obviously, and appears I’ll have to try starting again. Am I going to get all the XP I collected? This was the first go on Sapienza so did a lot of knocking out, areas, etc, etc, a few challenges.


#137

I can’t unlock the mastery Hokkaido/Sapienza achievements when leveled up with Patient Zero content xp. I reached level 20 on both with XP from Patient Zero an The Author missions and the achievements don’t pop up


#138

Yeah, in H2016 if i use DX12 i have always a stable 60 fps, but for some reason when i play the same maps in the Legacy Pack my frame rate can fall down to 30 and less in certain portions…


#139

Wanted to report the same things, i never had issues in H2016 by using the DX12, i always had a stable frame rate that never dropped under 60. When i play the same maps in the Legacy pack my frame rate can easily fall under 30… and let’s not even mention Mumbai, where the only things that gets assassinated are my frames per second :open_mouth:


#140

What insecurities ? As always your posts are agressive and insulting with no reason for it, my responses aren’t sad I simply stated that I answered you with the tone you use to address others, which you seem to find unpleasant, oh the sweet irony.


#141

I just deleted the game and the reserved space, then reinstalled the game by putting in the disc. It did that then an update. I started the game, loaded one of the previous saves and got a CTD, so the WB site advice didn’t work. I’ll send them a message as well as posting here.


#142

having spoken to WB support I’ve now been able to get the game running but there’s major graphical problems (see below) and I’m running at something like 3fps even with all the graphical settings right at their lowest value so it’s completely unplayable

the green glow here isn’t as bad as some other places around the house, but in lots of places it’s so bright I literally can’t see anything except green glow


#143

I got the Gold edition on Thursday and have been playing the hell out of this game. I love it all, but I’m having some crazy frame drops and hitching.

Just saw that Nvidia Game Ready driver was posted, I will go home and update soon, will update this thread if it fixes the issue.

CPU: i7-6800k
GPU: GTX 1070
OS: Windows 10
Game is installed on a disk drive due to low space on my SSD at the moment.

I had no issues with the first season of Hitman, it was nearly flawless performance with an occasional bug (walking animations sometimes freaked out). I never had this kind of hitching or frame drops before.

I’ve lowered my graphics settings to all lows and I still have very noticeable drops in frame rate. Switching to ultras made the hitches happen more often, but didn’t really affect my framerate when it was working fine.

I average 80 fps and see highs of 160 and lows of <30 fps, despite graphics settings. It’s incredibly jarring. Mostly happened in Miami, Colombia, and Mumbai, but it was present on nearly all the new maps. I’ll check out legacy maps later tonight when I’m home to see what they result in. Water effects and mist/steam/dust seemed to be a significant trigger, but I’ve had it happen across the map.

I opened up my resource monitor and noticed that my CPU was hovering at 60% usage, and the frame drops would happen, and my CPU usage would drop to 30% usage or lower. It’s not the most accurate resource analysis, but I’ve never had issues with my computer in the previous game, and I’m reading mostly great reviews about the performance, saying things like “identical performance requirements”.

I am considering doing a full reinstall of my game just to see if it fixes it, but I’d like to explore other options before re-downloading for an hour or two.

Has anyone else seen something similar? Any additional diagnosing I can do to further root out the problem?

EDIT: I have figured out more about what is causing the issues. It’s when I am viewing anything that has reflective textures and lighting applied. Water, light, mirrors, anything that is reflecting/diffusing textures seems to cause my computer to chug to a crawl. When I load Miami, the FPS is stable and smooth at the race entrance where everyone is walking into the track. If I turn left and go through the tunnel, that’s when I get my first FPS chug, when I start seeing the light reflect off the tiles. Then when I get to the dolphin fountain area, the water on the ground immediately triggers the issue. If I move my camera away from any of those textures then it stabilizes.


#144

Yep, I’m also having the issue with the game launching with a blank screen if HDR is enabled, and if I launch without it enabled, I am unable to enable it from within the game, as it says no HDR capability detected.

I’m running on:
Windows 10 64-bit
Intel 4770
GTX 1070

and have tried using both an LG HDR display and a Samsung HDR TV (via HDMI).

Works fine without HDR enabled, though, or if I alt + enter and go back (which has the side effect of disabling the HDR)


#145

Same problem here. Exclusive fullscreen and HDR are not working. I get black screen. Only way is to play windowed and or course hdr off…

pg27uq 4k, hdr 144hz monitor
rtx 2080 ti
5930k @ 4.4 ghz


#146

Unplayable? The game is a lot more bearable for me on my second PC that only has 4 GB of RAM.
And I’m saying it’s more bearable because it doesn’t have random freezes and audio crackling on an inferior machine for some reason.


#147

I get 80fps in miami on ultra with vsync off but the game stutters so much that it is unplayable, check steam forums, many people have that. The game uses all of my 8gigs of RAM, so I presume the stuttering is due to the game needing more RAM than I can provide. I have no fucking idea how it doesn’t stutter on your PC with 4GB. People even say it eats up to 12-15 GB.


#148

I’m seeing only 8 GB of RAM being used when I’m in game, and that is with other programs open on my computer. I’m seeing the same problems as you with the stutters despite the graphics settings. I do not think it’s specifically a RAM issue


#149

I refunded the game personally. They are ignoring the hdr/black screen issue on Twitter, here fb and steam forums. They kept the online nonsense from the first game after pretending it was forced on them by square Enix. Only reason square Enix let them buy the rights back is because they probably had enough with them. I sure have.