Official HITMAN 2 Technical Support Thread


#170

Okay, I feel like I’m going crazy cause every time I play this game agent 47 begins to drift (walk) to the right. Like as if I have a broken controller (playing on 1x on disc) but I don’t! Played RDR2, Spyro, and even the first season and nothing! So what the hell? This doesn’t make any sense! It makes the game super hard to play. I’ve uninstalled it both offline and online while redownloading it and still nothing. Popping the disc out too. I’ve tried looking this up to figure out what’s going on but can’t. Like I’m the only one in the world. Any ideas? P.s I downloaded the prologue off the digital store cause it’s free and it happens on there too. Idk if this is a bug or what.


#171

The game crashes to desktop Mission Colombia


#172

So I noticed this when I logged on today any idea why these wont install?Capture%20hitman


#173

Hi I was just wondering if there is an update yet for the xbox Hitman legacy pack, as I am still unable to download it even when owning hitman 1 with all 7 episode’s. Tried to follow link from Hitman 1 but keeps bringing me to xbox marketplace with error message saying to try again later. It also says when you search for either Hitman legacy pack or goty legacy pack that they are unavailable to download. And just occasionally it will load but then say it is £15.99 for it even though it is meant to be free when you own Hitman 1 with all seven episodes and Hitman 2.


#174

From the looks of it, it’s only Santa Fortuna that’s having problems for me. It’s the 15th where I’m at but it’s still marked red. I checked the Xbox reviews for the episode and there are others who are also experiencing the same problem so I assume it’s something wrong on Xbox’s part. Thanks for the help though, it’s much appreciated!


#175

Hi - I’m having an issue on the PS4 where I hit level 20 in Bangkok but the One Night in Bangkok trophy did not pop…may be an issue in itself but how do you reset your mastery level so I can reattempt level 20 to fix this?


#176

This is for hitman 2 gold edition


#177

Did you get answer? I played Miami other night everything worked fine. Today I tried and it says get access. Now for some reason I have download Miami and Santa Fortuna but I already did. WTH? Cannot even load my saves without downloading Miami


#178

Long story short, I played the first mission one time before I logged into my IO account. The challenges I completed before I logged in have disappeared. It shows that I have not completed them, but they are not available to be completed. It seems that they wont award the challenges if you are offline to prevent cheating, but now that I am logged in why can I not re-complete them? At this point it would not be a big deal to wipe my saves and start over, but is there a way of doing this?


#179

On Xbox One.
(Unsure whether this is a microsoft issue or not but I’ll just let you guys know anyway.)
I own the GOTY edition for Hitman, but when I attempt to redeem the legacy pack for Hitman 2 all of the items are installed except for the Bangkok mission. I have attempted several times and have no idea how to proceed.
All the other levels install perfectly and play fine.


#180

Never got an answer, sorry. The day after starting from midnight it all started working fine automatically. Haven’t checked the status today though.

edit: everything works fine here


#181

Need such parameters (Steam version):

  1. Separate screen resolution setting, in % that does not touch the aspect ratio, and native resolution.

  2. Sharpness (Clarity), removes soap at lower resolution. Performance is not affected.

  3. Smoothing TAA , The Crew 2 use default parameter TAA=3 , adds soap, and not bad performance increases.
    Also I noticed in the first season was FXAA and it also increased performance. And the temperature of the video card was lower.

  4. LOD BIOS +15 - returns PS1 level graphics

  5. DX12

I play only on Steam Controller, and I have problems. For the game on Steam Controller needs simultaneous use of mouse and gamepad. In the first season was such an opportunity.


#182

Hey i cannot download my legacy pack on xbox one. I own the complete first season on disc and when i access the legacy pack through there it redirects me to the xbox store where it says “redeem code” and that’s it. And when i went back to hitman 2 it said “legacy unlocked” and gave me an aluminium briefcase with NO LEGACY LEVELS. It simply says “get access” when i hover over them. I even tried it through gamepass with the same result. I contacted you guys through the forums with NO reply. Seriously IOI? this is not fair. I paid money to buy content that YOU made! I should atleast get what’s promised! Do i really have to pay money AGAIN to the content i already OWN!? I would love it if you guys can help me in fixing my issue! I just want to revisit the old levels and 100% my game and not be left out of the content that i rightfully have access to! I hope i will get a response. Thanks.


#183

Hi I bought the Gold Edition for PS4 and entered the code to redeem the Expansion Pass and the Executive Pack. But after entering the code it only gave me the executive pack and the the expansion pass. Why is that?


#184

I’ve bought gold edition and still can’t play any of hitman’s 2 levels, however my system meets minimum requirements, so it’s quite odd that old missions running fine. Also I’m not clear why expansion pack is not installed, steam says it’s in my library. The funniest thing that I spent all these days since pre release talking with support, they’re not answering so far. Cool service, cool game which I can’t check out. I won’t buy any of new game whether it will be released.


#185

What is your exact issue? Why you are not able to play?


#186

The game crashes on loading when it’s ~75%, hitman 2 stopped working and that’s all.


#187

Are you able to enter game menu? I suggest it crashes when you try to start a mission. Is that correct?
Update drivers and if you can, specify your system configuration.
Also for Hitman 1 what are fps you are getting?


#188

I’m able to enter the game menu, I’m also can play freely any of H1 levels, dlc and etc. Yes, game crashes when I try to start h2 missions.
I have latest drivers installed, verified files via steam, updated windows from 7 to 10, so I was using dx 11 and 12 so far and no result at all. Average fps in game is about 30-50, depending on the location (sometimes it drops to 20)
win 10 pro, rx 560 series, amd Athlon™ x4 635 8g ram


#189

Tag Travis_IOI in your bug report for better visibility. Hope it gets spotted out soon.