Official Whittleton Creek Trophies and Challenges Help [SPOILERS]


#21

Only one I remember is in Janus’s garage.


#23

I haven’t tried it, but there’s a furnace in the muffin woman’s basement. Try putting it in there.


#24

Furnace is for dumping bodies.


#25

Should easily burn a cardboard box then you’d think…


#26

You’d think, but I can’t interact with it unless I’m dragging a body.


#27

You cant throw it in


#28

Has anyone else had issues with “The Classics” challenges on PS4 for Whittleton Creek? Last week I had completed the Suit Only, SA/SO and Sniper Assassin Master challenges (which also unlock the Casual/Professional ones) and they showed up as completed and gave me XP.

But noticed today that the challenges are now displaying in the game as incomplete and cannot be re-completed, likely locking me out from completing the “Complete all Master Classic Challenge” unlocks etc.

Edit: I solved this issue. Tagging @Travis_IOI in case anyone contacts him regarding a challenge re-lock on how to fix and if anyone else has this issue:

  1. Go into Settings on the PS4 and open “Application Saved Data Management”.
  2. Delete all HITMAN 2 data (don’t worry, nothing except save game files will be lost).
  3. Re-launch HITMAN 2.
  4. Connect to the servers to re-download your profile data.
  5. Complete the lost challenges in-game again.

Looks like the profile data got corrupted and “ate” my challenge progress and wouldn’t allow it to be re-unlocked. Luckily the data was clean on the IO servers.


Undiscovered areas bug
#29

So for the bolded part I have the solution, you needs the paddle in the garage in the house for sale.

But does anyone know the rest?


#30

The fence exit can be unlocked with the key on the construction worker and newspapers are on the postman and on lawns around the neighbourhood.


#31

Ah. Thanks, that clarifies it. I think I’ve knocked out the construction worker before and never found a key, but maybe it was glitched, will try again.

Thanks.


#32

It has to be the worker near the fence so yes it must be glitched because I managed to do it no problem. Any other issues or…?


#33

Don’t think so, I’ll try it out later. :slight_smile:


#34

How do you get the targets to actually meet each other?


#35

Destroy all the cameras at Janus and Cassidy’s house.


#36

I only have the “due you even care” thats too many birds to shoot lol, and “priceless” it has to be bugged. Everyone tried everything and nothing. I even put it in everybodys mailbox and nothing lol. Any ideas?


#37

I finally found all the damn birds. Also for priceless I even tried placing the Canabis joint on the wood table thinking maybe he’d smoke it go crazy and destroy the package himself lol. No one ever touched the joint for 20 minutes so not sure what the point of that was.

I also tried fumigating it because the mailman says it sounds like something is alive In there. To me that might be our clue about how to destroy it but I’ve yet to figure it out.


#38

For the raft, you need to go in the for sale house to get the paddle from the garage. Then a new exit sign will pop by the raft. For the newspaper, I found 6 total. 4 are with the mailman, another one in Cassidy’s house near the surveillance computer room and another one near the lady in pink with her pink truck near the mailman. It’s on the grass near her somewhere. For the exit, I’m not quite sure I remember, but I think one of the police officer close to the door has the key. Good luck!


Priceless (Whittleton Creek)
#39

Just tried it. Doesn’t work.


#40

the first thing he says is “something’s ticking”, which means it’s a bomb, which means - if it’s an easter egg - someone on the map might have the means to blow it up


#41

If that is the case then the trigger might be in either the Cassidy Household (Batty was obstructing Cassidy’s surveillance routines and caught them burying evidence), Janus’ Household (since Janus disliked Batty for suing him) or the West Household (since she is a crazy murder house lady who has done work for Janus in the past)