Official Whittleton Creek Trophies and Challenges Help [SPOILERS]


#84

I think I have figured it out. I will try it and see if it works. I be back :slight_smile:.


#85

I hope u did. Please report back


#86

Shit I didn’t. I thought that the “oven” in the old ladies basement could be used while you dump a body that has the package on them, but a body can’t have a package on them. And if you give the old lady that makes the muffins the package she puts it on a plate with other muffins that are ready to go into the oven, but nothing happens there either. I also tried to place the package on muffin plates that are scattered around the level, thinking someone would pick it up and do something with it, but nothing there either.

I will continue and see if I find it.


#87

Yeah i tried that bro. Even tried to give her the package lol. I also tried with the insceticde but that didnt work. What are we missing…
Tried putting it in everyones mail. Even tried it when the package was on the counter in cassidys house and destroyed all the cameras so he meets up with janus but nothing happens with the package


#88

Tried everything also. Will wait to see if anyone get this, got tired. Must be something strange like the “Rep Tires” achievement in colorado, that u must feed the toy with apricots while having the hallucinogen drug in your inventory, btw, how the fff someone solved this?

Something strange I noticed in WC is that there are some highlighted apples in some places you can’t interact with, also the joint u put next to the Battys boat that seems to do nothing. Must have something to do with this.


#89

I made Cassidy look in his mailbox and made him pick up the package and tried to Talk to him as the real estate broker before he left the package to see if I could blow him up while he had it on him in the basement, but you couldn’t talk to him while he was doing that. I tried putting it in the garbage to see if the garbage men picked it up. Nothing. I even tried to see where the mailman was going for quite some time. This psycho lady has a dialogue when she’s in her basement, maybe she’s supposed to invite someone down the basement and kill them in the oven? I’m lost.


#91

Guys, priceless might be bugged, but I’m unable to check until I get back from vacation. Maybe just leave it for a few days more and then I’ll get back to you. Could be that the package ended up being indestructible before we shipped.


My Progress on "Priceless" Challenge
Anyone tried anything out with the 7 lights on the ground at the Construction Site in Whittleton Creek?
#92

Thanks for responding

Btw Martinoz found the dolphin exit yesterday. I wonder how many more exits we havent found yet lol
My favorite is the swan dive (big tomb raider fan)


#93

They forgot to make the apples pickabale, thats why it was highlighted. You can pick them up now after the patch


#94

tnx bro

202020202020


#95

Here’s my list (pre-patch)

Destruction:
-Throwing the package to the laser room
-Throwing the package to any player-blocked area (well, every manhole, river, etc.)
-Most of the explosive gear items (also combined)
-Throwing it into a manhole with explosives
-Running over it when exiting the mission (all vehicles, varied locations)
-Shooting it with Jaeger 7 Lancer (and other firearms)
-Trying to put it in the incinerator/garbage truck

AI Manipulation (with the joint on the table):
-Get James Batty to answer the door bell for nothing x times (idea - get him angry)
-Get James Batty to take spam mail x times (idea – get him angry for not receiving his package)
-Get James Batty to take a bomb from the mailbox (idea - freak him out)
-Taking James Batty’s documents, including the ones on him (knockout and call someone to wake him up, idea - get him to freak out that he’d lost his files)
-Put something in James Batty’s mailbox, make the mailman not deliver the package
-Exploding James Batty’s mailbox with/without reaction front of him/mailman (nothing changed, also a bug because the mail man puts the package into thin air)
-Killing/knocking out the garbage man that enters his house (with/without James Batty’s reactions)
-Killing/knocking the exterminator near his house (with/without James Batty’s reactions)
-Trying to interact with James Batty with every disguise
-Try to take James Batty’s disguise and find any interaction with anybody or anything (with the package)
-Blowing up James Batty’s car (idea - freak him out)
-Mail the package to every other house
-Throwing the package near Janus/Cassidy

Side notes:
-The latest patch fixed an issue with the joint interaction text, replacing “Place Meat Bone” with “Place Joint”. Either way, the action stayed the same, so safe to say it was just a text bug. But of course if it wasn’t important to the only undiscovered challenge, they wouldn’t have fixed it that fast and hash hash
-There’s a same package in Columbia, maybe there’s a way to send it to the next level (like the thing they did with Patient Zero with the sad guy)
-There are more points but I really think these are the main one, I’ve spent on this challenge more than 10 hours already. I really hope it’s not bugged


#96

Have anyone found all the clues? I’m not getting the challenge, and so far I have the diary, VHS tape, Micro film, ARK Outfit and photograph.


#97

Robe-janus neighbour house, lady with the murder basement

Diary-on a guy sitting next to the creek near the garbage truck

Letter-on cassidy guard/on kitchen counter

Cigar box-near betty shed, you have to dig it up

Micro film-janus library

Survellliance-cassidy kitchen

Photo-janus basement

Lawsuit-bettys shed

Gramaphone-janus house upstairs

There is a list on the sub reddit.

I actually like the clues. Great for preparing and hyping up for Isle Of Sgail


#98

Can’t seem to find anything to dig up, even with shovel.


#99

It’s near the frog location


#100

Been running around everywhere at this place, an nothing pops up, with shovel in my hand. Maybe there is something you have to trigger, or do something first? Could be a bug on PC.


#101

It’s pretty precise, you have to be in just the right spot. On console, when you near the spot, your controller will rumble. I suggest crouch walking very slowly.

Edit: posted pics in a different thread a while back: Enter the vault (Spoilers)


#102

I guess the developers took for granted that people would play with a controller, because it’s not only precise, you have to crouch very slowly over it or you will miss it. Thanks anyway, it worked.


#103

There is also a spagetti can near that area. When it vibrated I thought I found something cool lol


#104

Is anyone else finding Wet Bandit to not work. I’ve tried it legitimately four times with Nolan Cassidy and it never pops up. That and priceless just seem to not work for me