Poor performance on high-end PC


#1

Hi guys,
I just bought the game yesterday and I’m surprised about those poor performance compared to hitman 2016.
Here are my pc specs : 1080ti, i5 8600k, 16gb of ram.
I only have Paris episode of Hitman 1 , but the game was able to run " fine ", solid 60 fps with everything maxed out, sometimes it could drop to 55 but nothing more.
But on hitman 2 there is a huge problem, on Paris I just cant reach 60 fps excpet in rooms , my game usually runs at 50-45 fps.
Turning all settings to the lowest doesnt affect performance , maybe 5 fps more but that’s all.
The worst is at Marrakech, and Bombay, my game drop to 30 fps.

This is very frustrating beacause the game is amazing…

Anyone in that case ? Is there any tips to play at constant 60fps ?


#2

I think this is not problem of end user, it’s problem of poorly tweaked game.
Hopefully in a while the devs will configure this thing correctly.
How to measure fps?


#3

Use msi afterburner to check your fps.


#4

legacy maps perform worse in HITMAN 2. well tbh, game runs like an ass so yeah don’t even bother, hopefully they will improve it.


#5

Thanks, but I used built-in Steam FPS counter.

I have a little run in Paris, and for the most time my FPS is constant 60fps.
Sometimes (not frequent) it drops to 56, but not less.
I ran through all the level and espesially in crowded areas.
It wasn’t less 56fps for me.

My monster wears:
Motherboard: Asus ROG Strix Z370-H Gaming
Processor: Intel® Core™ i7-8086K CPU @ 4.00GHz (12 CPUs), ~4.0GHz
GPU Card name: NVIDIA GeForce GTX 1060 6GB
Driver Version: 25.21.14.1735
Memory: 40960MB RAM
Operating System: Windows 10 Enterprise 64-bit (10.0, Build 17134)
DirectX Version: DirectX 12


#6

Doesnt say much when you dont mention the resolution and quality settings youre playing with.

Im playing at 1440p with all settings on max, fps averaging between 80 and 120


#7

My current monitor does not allow the resolution higher than 1920x1080.
Game settings maximized, of course


#8

Yeah I forgot to mention that i’m playing in 1440p, everyting maxed out except details on medium.
But as I said , changing everything to low or changing resolution to 1080p doesnt affect my FPS, only 5fps but nothing more


#9

That’s incredible, I just tried to put the game in 1280*720 resolution to see and there is NO change at all, no FPS boost , same performance as 1440p how is that possible ?


#10

The game performs poor on pc, if you want more performance you should reduce the super sampling


#11

I dont use super sampling and I dont know why I would do that with a 50fps game


#12

Super-sampling is enabled by default and you can’t disable it nor reduce in-game, you have to go to regedit to set at least 0.70 if you want some performance


#13

It’s a weirdly “optimised” game. Supersampling on by default and the ridiculous godrays on Whittleton Creek slow the whole thing right down to a crawl. Don’t know anything about IOI releasing a patch any time soon but hopefully they will.


#14

I would say surely they will


#15

no it change nothing, and my game looks ugly.


#16

What is the refresh rate of your monitor? As it sounds like you are only running 60 Hz


#17

I have a 1440p 144Hz monitor


#18

Try to reduce level of detail to medium. This setting seems to be gpu limited in 2018.