PS4 Legacy pack downloaded and installed but still refues to register with Hitman2

Hi
numerous times now i have downloaded and installed Hitman1(ps+ digital) and Hitman2(disc) and the legacy pack from PS4 store (yes it is downloadable, just not usable!)
Folliwng the instructions, follwing youtube tutorials ALL EXACTLY how you intended.

Still in Hitman2 all legacy mission are and stay unavailable!
How do i fix this?

I assume you have gone through the claiming part of the process. Did you find the Legacy Pack in your add-ons section for Hitman 2? you can view your game add-ons by selecting the game and pressing the d-pad down button to the lowest point, it would look like this:


On the other hand, I would also suggest you check the PSN store page, see if the Legacy Pack is available to download in your region. I hope you can get this issue resolved soon.

Are you sure that every location + the bonus episode for Hitman 2016 is installed?

Maybe this is what happened to you.
Just try to remove H1 to an external HD and then download the legacy pack.

hi all.
yes thanks. went through the process and as said even went through redownloading and reinstalling the whole shebang multiple times. and yes i was specific in saying that i went through the legacy pack download and install process. my screen matches your screenshot. unlike many others that dont get to the point of downloading and installing the legacy pack
it just wont register with H2

Hmm… Could this be related to the version you installed? My Hitman 2 is digital version. I think you can try download the Starter Pack (idk if it is still available), then see if the Legacy Pack can be accessed from there.

I’m having the same problem. Bought the H2 gold edition (digital), installed, played a bit. Then I installed H1 which I got for free from ps+, used it to start the legacy pack download and uninstalled it again before anything from the legacy pack started installing. In the H2 the destinations don’t have a red background anymore but still prompt me to “get access” and direct me to the goty legacy upgrade. Everything’s installed on my “your add-ons” page.

Hi there. Could you check if you have activated the console as your account’s primary PS4? Cause this seems to be a similar issue:

3 Likes

Hi, just in case you’re not sure, just go to settings, then account information, and then go down to “activate as your primary PS4”. First I had to deactivate, then I activated it again straight away, and I got the Hantu Port content. Good luck, hope it works for you.

1 Like

Awesome, it worked! Thank you

Although I did also reinstall Hitman 2016 and don’t know wether that made a difference

3 Likes

Hi, hope someone can help. I purchased the expansion pass. However when I return to the game, I don’t get the checkmark like you see next to GOTY. I’m unable to access the new content. I also purchased the enhanced collection, those work even though no checkmark.

Please help

No checkmark is normal.

For Hantu Port, search in the store for it.
For Executive Pack, Collectors Pack & Winter Sports Pack, you’ll find some if not all of them in Library > Hitman 2 > Your Add-ons. Search in the store for the ones you can’t find in Your Add-ons.
(Right side)

Try deactivating the console as your primary console and then activating it again. As per the post above. Good luck.

Thank you sir, I’m now able to download. I never thought to go back and go to the store via the game by scrolling down the start.

Turns out I have 5 to download. This felt like when we did this to get hitman legacy lol.

Wish it would install as you purchase.

im happy it works for you now after hijacking my thread with a different, albeit related, problem :wink:

my problem still persists though. deactivate primary/reactivate. no avail.

All download and installation went peachy. All the storeitems are where they belong.
But in Hitman2 all the legacy campaign missions are Red and have a “get access”-arrow box and text.

Ultimatley annoying considering i bought H2 mainly for that feature as i had just started playing H1 and really enjoyed it.