Saving dynamic resources FAILED: "Permission denied"

#1

Hello. I have been getting this error on PC for a good couple of days now, and I have no clue what could be causing this. I tweeted IO about it and also PMed Travis, but they never got back to me. As far as I know more people have experienced it in the past, but I haven’t found a solution for the problem. Anyone got an idea on how to fix this?

1 Like

Official HITMAN 2 Bug Report Thread
#2

Have you tried resetting your router? Turn off pc, unplug router for 10 seconds, plug in and try to connect. That’s usually my strat when I have a connection issue with anything and it usually works even if the internet is working on other devices.

0 Likes

#3

I actually haven’t. What I did though was unplug my ethernet cable and try to launch the game while connected to my mobile data via USB tethering, which brought the same result.

0 Likes

#4

Check your C:\Users\XXXX\AppData\Roaming\Io Interactive\HITMAN\TemporaryStorage directory. The game store here all the dynamic_resources_*.rpkg. If this folder exists and has valid permissions, remove all the content inside.

0 Likes

#5

I just did that and removed the single file I had in the folder and I’m still getting this error.

0 Likes

Official HITMAN 2 Bug Report Thread
Connection Failed (FAILED: Permission denied)
#6

Did you checked the permissions on that folder in the security tab ?

0 Likes

#7

Sorry for slow reply. All permissions were correct. I actually tried setting the game to launch as administrator after removing all the files from TemporaryStorage again and it seems to have fixed the issue. I have a feeling it might have something to do with the newest Windows 10 update, which screwed some other things in the system too, my game stopped to work just about the same day as the update launched. Either way the game seems to be working now. Thanks for all the suggestions and help @immadummee47 and @Hardware :blush:

2 Likes

#8

@Britannicus If none of these solutions work, download procmon.exe and look what the game try to do.

  1. https://docs.microsoft.com/en-us/sysinternals/downloads/procmon

  2. Disable capture (CTRL+E), then add some filters

image

  1. Enable capture (CTRL+E) and try to login in the game.

  2. Disable capture and find dynamic_resources references.

image

with that you should see why the game can not create the dynamic_resources files.

1 Like

Official HITMAN 2 Bug Report Thread
#9

Hey, thank you very much for the suggestion. I ran it and if I read it right (which I am not sure of), Attributes and Allocation Size showing n/a are the issue? I’m still no closer to knowing what I can do to fix it though.

Edit: Forgot the screenshot.

Process%20Monitor%20Result

Edit 2: Regarding your suggestions from the other thread: I tried every possible combination of DX 11/12, compability and admin settings, all leading to the exact same result.

Running the game in a fresh user profile doesn’t do anything either, so I really can’t see how my settings could be causing this…

0 Likes

#10

My game has been completely unplayable for almost two days right now and I have tried absolutely everything I can think of.

Any help? Suggestions? Comment? Anything? @Travis_IOI @ioi_christianco

0 Likes

#11

You have a sharing violation on dynamic_resources file, another program on your computer try to access this file at the same time. Remove the filter on hitman2.exe process and make a new capture and look what another program is the culprit (search dynamic_resources for example). I bet it’s your antivirus software and windows search indexer.

http://blogs.microsoft.co.il/pavely/2010/11/24/the-case-of-the-unexplained-sharing-violation/

IOI can’t help you in the middle of the weekend. Wait for monday :joy:

0 Likes

#12

Edit: Nevermind, I’m just dumb. Currently trying another capture.

Well seeing how they don’t help me during the week, I thought I might as well try. :roll_eyes:

0 Likes

#13

Have you restore function enabled in Windows?
Try to restore the backup file that was created before this failure

0 Likes

#14

I just ran the other capture and no process other than hitman2.exe has any entries for dynamic_resources. SHARING VIOLATION still pops up.

0 Likes

#15

Disable all softwares like antivirus and disable Windows Search service. This error comes from your PC, it is not the game fault, something prevents the hitman game client from creating this file, another program must have a handle on this path.

You can try to use Handle to find that :

0 Likes

#16

Is disabling the Windows Search Service via the task manager good enough?

0 Likes

#17

cmd admin > services.msc > Windows Search > Stop

Can you try to create this file yourself ? (with exact same the path and filename).

0 Likes

#18

Edit: So delete the one that’s there and create a new one? How do I create an .rpkg file?

Thank you so much for all the help, by the way. <3

0 Likes

#19

Yup.

C:\Users\xxxxx\AppData\Roaming\Io Interactive\HITMAN2\TemporaryStorage\dynamic_resources_c_7_9_0_s_7_9_21.rpkg

And open all permissions on this file, for everyone.

Your problem is really weird.

0 Likes

#20

How can I create a .rpkg file myself?

0 Likes