Steam access denied

Does anybody know what this error is and how to fix. Not related to hitman.
I cant view steam on chrome. Steam app says you have 4 new items in inventory. Inventory does not open.
Steam store page does not load.

Access Denied

You don’t have permission to access “http://store.steampowered.com/” on this server.

Reference #18.dcb71002.1545133346.36d1207

Try to knock directly to Steam Support: https://help.steampowered.com/
Also try to clear your Chrome cache, or even fully reinstall it.
Try to use other browser or the app directly for now.
And, of course, check your system for viruses and like stuff

Steam app also does not work.

https://help.steampowered.com/ Same issue for help link. Access denied. Tried both in chrome and IE.

Try to see what’s going on with Hosts file if you on PC.
Maybe something has modified it to restrict access to Steam.
Or firewalls, adblockers etc

How to see whats going on with host files?

Steam app on mobile using wifi also returns same error.
But using mobile data i can brows everything steam app .
So it must me issue of my internet provider.

Did you get banned, perhaps?

Open this directory C:\Windows\System32\drivers\etc\ and choose to open with Notepad the hosts file.
If it does not work open Notepad with andmin rights and open hosts file within it

If that is sarcasm, it is not right time for that.

Or you get banned from Steam indeed

No. Steam works on mobile data.

what do i do with this host info?

Is it the whole file? Anything more under scrolldown?

C:\Windows\System32\drivers\etc\hosts

That is all there when i open it with notepad. No scroll down.

Ok. Looks fine to me.
For now I have no more clues.
But if you say you can reach Steam on mobile internet, it has to do something with your wire connection.
Try to consult your internet provider. Or your IP adress (not your account) been banned on Steam.
Change IP and try again

Why would steam ban my ip address?

@Jarbinger started working for steam now? :rofl::joy:

Have no idea.
Try to change it and check.
Anything could be for whatever reason

I dont know how to change ip address.

Easiest way is to install Opera browser and toggle on the built-in VPN