The game crashes on startup

Whenever i press play in steam it takes about 3-5 seconds before it just shuts down. I’ve searched around for a fix and tried uninstalling razer products as someone mentioned interfered with the game somehow. I disabled nvidia geforece ingame overlay as that also interfered in someway according to another person. Help me fix this so i can actually try the game please.

1 Like

Do you have updated GPU driver?
Have you tried to run the game with DX12?
It can be set in game’s launcher settings

I have updated drivers and there is no way for me to change to DX12 cause the game launcher crashes 2 seconds after going into settings.

Strange.

Post here your Windows Journal screenshot where one can see an error related to HITMAN2.exe.
You can find that message in this section
1
(though a pic has russian text, the structure is the same)

Can’t even seem to access my journal.

How come?
Maybe you have Windows problems then?
Maybe you should address to a service point if you can’t even open rather simple program.

If you don’t know how to open it, follow this guide

I googled it and it was removed in a more recent windows update. Which explains why i could not access it.

Ok, the other name for that thing I’m reffering to is “Windows Event Viewer”.
It can’t be removed and the ways how to open it I posted in a link in my previous message, use it.

To be honest I even never knew that some different application existed in Windows under the name of “Journal” :slight_smile:

Here’s what i could find

It’s not about HITMAN2.exe
Move to the next error and seek for the HITMAN2.exe text in the error message body

It does say “P1 hitman2.exe” and is the error i recieved after the game crashed…
This is the only other one

Yes, the second one is exactly that is needed.
But I never saw the faulting module like that and I have to make a research.

Though you have well-known Exception code.
Ways to resolve errors related to this code gathered in this thread:

Have a look and try to follow the guides that are garhered there

Perfect. Oh alright, that sounds problematic. Appriciate the help though.

Look at P4 signature in your first screenshot, you have a problem with Nvidia Ansel. If you can’t fix it, just disable Ansel, and that should do it.

C:\Program Files\NVIDIA Corporation\Ansel\Tools\NvCameraConfiguration.exe
1 Like

Ok, I looked up this thing in Google, and seems this module is Nvidia related.
The best way to solve it is to uninstall Geforce Experience and your GPU driver completely.
After that reboot your PC and make a clean install of Experience and the driver.

Maybe your driver or Experience app is corrupted and it prevents you to play the game.
I believe the complete clean reinstall of it will help

And for Razer related problems (game crashes at startup and launcher settings crashes too), look Blizzard Tech Support, it’s well-known issue for games that use Razer Chroma.

Basically, the solution is to update Razer Synapse to version 3 or uninstall Razer Chroma SDK and remove all razer DLL from your computer.

1 Like

i’ll give that a try then i suppose.

I uninstalled any razer related programs i had. I also disabled ansel now but there’s no difference so far

You need to remove 3 DLL manually too.

C:\Windows\System32\RzChromaSDK64.dll
C:\Windows\SysWOW64\RzChromaSDK.dll
C:\Windows\SysWOW64\RzAPIChromaSDK.dll

And for the Ansel error, just disable it using NvCameraConfiguration.exe.

If you are using the steam version, have you tried to revalidate your files? With a mod I used one of my files got corrupted, so I had to revalidate it