Xbox 360 controller support


#1

Have been trying to play Hitman for 2 days now. went to play and at the start screen, it told me to Press enter to continue instead of a. Now, I found this very confusing, as I only play with controller/the demo let me use my controller… .I don’t like playing games with k/b at all, I’ve tried to plug in my wireless adapter before launching the game but I still can’t change the game to a controller set up.

I%20disavow


#2

Also I’ve looked everywhere for a solution and it seems no one else seems to have this problem.


#3

Is it through steam? What OS?


#4

Yes it is through steam and the OS is windows 10.


#5

If you play it through Steam make sure you activate Xbox controller support in the Steam settings. That should do it.


#7

I figured out how to active 360 controller on steam but it doesn’t seem to change anything. much%20much%20ruder


#8

I just tried mine, it works. Mine is wired though.

Maybe Windows needs a driver? Even though the controller is a Microsoft product…


#9

I’ve installed a driver but I can’t update it since windows says it’s up to date.


#10

Does it work with any other game?

If you’ve installed/reinstalled the driver, did you reboot afterwards?


#11

Yes it does work with other games.


#12

Then its not a driver issue

So for me sometimes it says this but If you just start pressing random buttons, the UI auto switches to controller. And it seamlessly switches between controller and m/k

This is my controller settings on steam


#13

Reboot the computer? Yes I have.


#14

See at the bottom there it should list your controller


#15

In device manager or on steam?


#16

In steam, under the “Steam” tab at the top, settings, then controller, then general controller settings. Should bring up that window


#17

I have my wireless adapter plugged in but it’s telling me there’s no controller detected.


#18

And you’re telling me this controller works with other steam games? Please verify that now


#19

It sounds like an issue with steam, check this thread out:

https://steamcommunity.com/discussions/forum/1/846939071256311812/

One guy said the controller kept connecting to his xbox, not the wireless usb. Just need to resync it


#20


#21

Is the wireless usb adapter Microsoft-branded or a generic one?