Xbox One Legacy Pack (August 2019)

Hello Xbox One users!

If you’ve been having issues redeeming your Legacy Pack, I’m here to ask you to try again. We’ve made some back-end changes to visibility and simplified the process in a few small ways. This should result in you being able to see the correct bundle.

As another note, if your ownership of the Legacy Pack on Xbox One was through HITMAN on Xbox Game Pass, the removal of the full title from the Game Pass service has also removed your entitlement of the Legacy Pack in accordance with Microsoft’s policies. Anyone who was solely using the Game Pass version to play the Legacy Pack will now need to purchase the GOTY Legacy Pack to continue playing those locations.

The steps in the Legacy Pack FAQ haven’t changed, but please follow them to the letter and report back with what outcome you have:

If you continue to have issues with the redemption process, please report back in this thread with the following information:

  • What version of HITMAN 1 did you purchase?
  • Have you downloaded the ‘Free Starter Pack’ on the Xbox Store?
  • What version of HITMAN 2 do you own?
  • What error message do you get, at what point, and in what game, when trying to redeem?
  • Your gamertag (please send as a DM / private message with a link to your post)


still not working for me (still showing the 69,99€ despite using the disc definitive edition).

Full details with videos here: Hitman Legacy Pack GotY is not for free (Xbox one)

I am willing to do tests or whatever necessary to help fixing the problem.


That post with the video was made 19 hours ago. When did you recently check? Please tell us as much information as possible about what you bought / installed.

I tested it right after i saw your message again (Both redeeming the GotY legacy Pack through Hitman 2016 or playing the installed Versions of the Legacy Pack in Hitman 2). thats about 20 minutes after you created this thread

The whole problem is laid out in the other thread. Short recap:
I was not able to redeem the legacy pack. I played Hitman via Game pass and bought the Hitman Definitive Edition (on Disc) as well as Hitman 2 on Disc. After multiple test of installation and deinstallation WB Support decided to give me a code for the GotY Legacy Pack.

As you can see in the video (of course i can make a new one with the actual date if you want) i still see the 69,99€ when i try to redeem the GotY through Hitman 2016 and i can not install the pack via Xbox directly. I can install it via the Xbox Website.

When i do so i have (as shown in the video) two installations of Hitman 2. One with all the DLCs and one with only the normal content.

When i try to play the legacy content i get forwarded to pay again (as seen in the video).

If there is anything more i can help you with fixing the problem i am happy to help.

I have: Hitman 2016 definitive Edition as Disc with used code in my Account (as seen on the Screenshort). Before i played Hitman 2016 via Gamepass. I tried getting the legacy Goty Pack after i used the disc version.
I own Hitman 2 and the Season Pass (Erweiterungspass) known as Gold Edition of Hitman 2 (on Disc and with redeemed code in my account).

Both Games are for Xbox. I tried this using my home console and on my second console.


@Cilius You have never been able to redeem the Legacy Pack? But you were able to successfully redeem the code for it you got from WB Support? Have you at any point played any of the Legacy missions?

When you install the pack from the Xbox website, what happens then? Can you play the missions?


I have never been able to and i am still not able. Yes redeeming the code worked (done on Xbox). But on the Xbox it still shows that i have to pay for it even if it says it is installed (green installed and beneath the price of 69,99€.
I installed it via the Xbox Website and i have two separate installations one with a disc logo (only the content from the disc) and one which seems digital with the “erweiterungspass” and the legacy content.
I could play the start missions (prologue) but Paris and everything after that never worked even if it is installed. It always told me to get access to those locations. (Which i discovered some days ago an tried to solve it with WB Support) The New York Missions from the “Erweiterungspass” do work (installed where the goty content is as well). Xbox Support said that it has something to do with the code beeing the wrong region since it says 0$ in my history, but the same is true for the “erweiterungspass” and this is working.

Have you gone on to the Xbox Store and downloaded the “HITMAN 2 Free Starter Pack”. That’s a crucial part of the process for you to see the correct bundles. Can you download that from the store, then launch your 2016 DE disc and tell us what happens when you follow the prompts to install the Legacy Pack.

1 Like

@Travis_IOI I have done that in the past and checked it right now, it is still installed (the starter pack). I followed the FAQ to the word as i stated in the other thread. I checked it again, still the same 69,99€. If you want video proof / details let me know. I am happy to help, since i really do not know what i am doing wrong.

If there is a special sequence in need to install those in, please let me know. As far as i know i installed Hitman 2 first and than the starter pack when i first tried it.

OK, so here is what I have and what I have done.
I am running Hitman 2 Gold on my Xbox One, original model, I have Hitman 2016 Definitive Edition installed as well. At the beginning of the year I downloaded Hitman 2 so as to play the 2016 missions on it and get stuff unlocked, and this worked just fine for me. I then downloaded the free Hitman 2 starter pack to get New Zealand and that worked fine as well. Then came the E3 sail and that is when I purchased the Gold Edition of Hitman 2 and got access to all of the season 2 missions. Skip ahead to a couple weeks ago and the Badboy Legacy Elusive Target, and I finish up Badboy with about 20 some odd hours remaining. So everything up to that point is fine. Then something happens the next day because I log back onto Hitman 2 and Badboy is saying “Completed” and “get access” and is all red. I check and all of the Legacy maps are now unavailable despite being installed. Then I go to the internet to figure out what is happening and if this is just me or an issue across the board, I find no help anywhere and once I finally stumbled on this board (there should be a big link here from the iOi website, just saying) there are multiple people saying they have this problem and have all tryed various “official” fixes and none of them work. I proceed to try uninstalling Sapienza Legacy to see if I can reinstall it and have it work, this does not happen and I am out a Legacy mission on my hard drive until I cam across another user in the big support thread that did a similar thing and posted a link on how to get his Legacy stuff back. So I reinstall ALL of the Legacy stuff and still no dice. Meanwhile there is still no official word acknowledging this as a problem from anyone. So, I decided to make that thread to try and bring together everything about this for you guys and now here we are. I have not tried sense these “back-end changes” have been made so I guess I’ll report back tonight when I get a chance to check. Thank you guys for finally getting back to us with some information but I really wanted to do the Camilion target and now that opportunity is gone. Hope this all gets figured out before the next one though. God bless.

Just as an addition. I completely uninstalled Hitman 2 and only installed the Hitman 2 Starter Pack again. Got the same result 69,99€ store page.

Yup, so still no change.
I will post some corroborating pics and vids in the hopes that they will help.

I hope this helps. I want to get this next Elusive target and actually have the opportunity.

Uninstall and reinstall all legacy content. Re install via Hitman 2016—make sure you have all content from that game installed before you try to re-redeem the legacy pack

Only items that said Hitman 2 were still installed.
I booted up Hitman 2016 went to redeem Legacy and it gave me this…

1 Like

I am not paying 60 bucks for something I already own.


Seeing how you already downloaded the Legacy stuff you probavbly already redeemed it, right?
Otherwise there is no way you’d be able to download the Legacy stuff.

It looks like you were revoked the license to use the maps somehow?

I’d try deleting the Legacy stuff and re-download them. If you already did and I missed that part, I am sorry.

1 Like

Check the store if you can search for any Legacy location and install.

1 Like

@Gandalor75 Have you had an Xbox Game Pass subscription at any point? When you hit ‘get access’ on Paris, what do you get shown?