A little help needed - I found a glitch that enables 60fps in the Xbox One version, but it's not reliable

EDIT: Apologies in advance if this isn’t the appropriate section for this thread, I just wasn’t sure if this was worth reporting in the Bugs thread until we have a reliable way of replicating this.

So… I realized I didn’t have the Tactical Turtleneck sweater in Hitman 3, which is gained by beating The Final Test (I had done it in Hitman 2 but I guess not in Hitman 3), and I did that… And then the game turned to 60fps for the rest of the session, which is notable, because the Xbox One version of the game is normally capped at 30fps, without an “Unlock Frame Rate” feature, and this glitch shows that the Xbox One version actually can run 60fps without issue.

I’m running this on an Xbox One S.

Here is exactly what I did:

  1. I beat The Final Test
  2. I unlocked the Tactical Turtleneck
  3. The game turned to 60fps
  4. I loaded up multiple levels, and yes, they were also 60fps, every level I tried for the rest of the session was in 60fps

However… Then I restarted the game, and it was back in 30fps, so I tried beating The Final Test again (I guess to see if it would cause the game to go back to 60fps) and it didn’t. My best guess why it didn’t was because I didn’t have the tutorial messages popping up the second time around. I don’t know if them popping up during the first go had anything to do with the game suddenly running at 60fps, however.

However, this is where I need help from y’all:

Can anyone running the Xbox One version, who hasn’t unlocked the Tactical Turtleneck, do so and then report back if your game temporarily goes to 60fps for the rest of the session?

Also… If the Xbox One version of Hitman 3 CAN run 60fps, why is it the only version missing “unlock frame rate” in the options?