Can't access "Untouchable"

For some reason, I can no longer play the Carpathian Mountains story mission, despite having access to the rest of Hitman 3 - it’s greyed out and tells me to get access via the Microsoft Store, even though the Deluxe Edition is owned and installed (Xbox 1X).

Anybody had anything similar?

If only a single mission is greyed out, I think it most likely means that it isn’t installed (or in your case, not installed properly).
On EG for example, this is the case:


The weird thing is, it’s definitely showing as installed. I checked it was there, reinstalled manually just in case, and tried moving everything over to internal storage from my external drive. Still nothing - the game seems to think I don’t own the Standard Edition and says I need to buy it, but I own the Deluxe Edition…

I would then recommend posting your issue in this thread.

I’ve had this issue before with Mendoza. Not sure if you pre-ordered but I had to ring Microsoft and explain the issue to them, and they were somehow able to get it sorted for me!


I’ll give that t try, thanks :slight_smile:

Unfortunately Microsoft couldn’t help - they confirmed that I own the Deluxe edition but the game still insists I have to buy the Standard Edition to play the final level :frowning:

Great. Now I don’t have access to the Mills Reverie either, for the same reason. I hope IOI can fix this, there’ll be no point buying any year 2 content if I don’t know when it’ll be yanked away.

I have lost access to Mendoza. I’m on Xbox One X.

Specifically, I cannot access the regular mission, Escalation, or Contracts. I CAN access Envy and the Deluxe Escalation.

I tried uninstalling and reinstalling all H3 data but nothing changed.

This is really bad timing since I missed The Heartbreaker ET the first go-around and it’s about to appear again. :grimacing: