Dartmoor - Dubai - Mendoza Challenges Glitched

Hello everybody, my first post here about some challenges I cannot complete in the game.

I have discovered every location on the map though the discorevy challenge is blocked on 13/22, I cannot complete it.

And, I tried like 3 times to escape the mission with the motorcycle, and the corresponding challenge doesn’t unlock either.

It may be related to the server connection issues we’ve had since launch, but I didn’t find a way to fix this, any ideas ?


Here’s a similar issue and its solution. You could try it and see if your problem gets resolved. If not, you can post on that thread to let IOI know:

1 Like

Thank you, I already tried the solution but it didn’t work, I’ll report it on the thread.

1 Like

Okay so the motorcycle mission isn’t bugged, I had it too but the reason for it not unlocking is rather dumb. You need to exit the mission on the motorcycle on the other side, it counts as two exits, The left hand one doesn’t unlock this challenge, while the right hand side does.


The left side of the bike or the left side of the bike when you’re facing it? It didn’t work for me during the first exit, and that was using the left side of the bike when you’re facing it. It worked on the second exit using the opposite side.

When you are running towards the bike it’s the side closest to you which doesn’t unlock the challenge. So when you are facing the bike you need to run past it to the right side then exit.

It must be bugged then, because we both did the same thing with the same result.

I actually exited using the left side four to five times prior and presumed it was bugged it was only when I reloaded and went to the right did it finally unlock.

It should be unlocking on both sides.

Georhan, I’ve tried your solution and actually it worked. Thanks a lot.
I still think it has to be considered a bug, as Hayamoto says it should work on both sides.

About the discover challenge I guess it is a common problem now and I’ll wait for a patch I guess.
Thanks everybody :slight_smile:

i have the same discovery challenge bug, 21/22 , and tied deleting local data, but didnt help either

Just wanted to say thanks for the solution. I tried escaping on the motorcycle a couple of times but the challenge did not unlock. Both times I mounted the bike from the side that you approach it. I loaded a save and this time walked around the bike and mounted it from the other side and the challenge unlocked.

Just wanna say i have the same discover glitch on Dartmoor. Mine is sat at 16/22 and i killed everyone on the map and went around every area just to make sure. Map says i have it all unlocked too. Also tried the delete local data answer which did not solve my problem. Seems like it is a bug.

@Georhan major thanks man. Motor challenge didn’t pop up for me also, and i will try your solution tomorrow.
As of discovery challenge i got challenge and trophy too.

No problem guys, just glad I was able to help.

Hello, there is the same problem at dubai mission. I ended the mission but in the end server connection was lost and all counters were set to zero, but landmarks at the map are still there and so the counter does not work anymore. My counter is at 29/33. I hope this problem will be fixed very fast, because I think I will have the same problem at Dartmoor (after finish the server connection was lost and all counters set to zero)


I’ve got the exact same problem.
I got the trophy for discovering all locations in Dubai, but my progress stopped at 32/33.

There are no undiscovered locations left, so I can’t finish this challenge.

Me have same problem stuck 20/22 I was several times at the 22 areas or places and also is the marker missing on the map

Here we go again,

Mendoza stuck at 44/45 locations, challenge doesnt unlock;
Grapes of Wrath doesnt trigger,
Eyes on the target, I give the order to shoot, snipers shoot, target is down, and… mission is failed…

I hope they fix this soon, that’s already 4 bugged challenges for me, and many server issues…
I’ll stop here and wait for fixes.

I am having an issue getting the locations challenge to pop up in Mendoza. This is the last challenge I need, and it shows that I completed on the Playstation trophy for discovering all areas. How do I fix?