Freelancer | Patch 3.170.1 | Bugs and Imperfections

Sometimes one of the undercover garbage men in Whittleton (the guy leaning on a fence that eventually goes through a route involving the nearby basement) glitches and his disguise looks like a weird patchwork garbage construction guy. He also drops a Hackl Covert while in this state. I don’t know what triggers the bug, suspect escape maybe?


To be honest… It’s inconsistent. I’ve tried to replicate it, no luck. Seems that it happens maybe when 47 is stuck in ambient animation (fishing/choping wood etc.). Might also be related to having selected mission before exit or not.

Try when no mission is selected, by only taking prestige objective - then leave, come back and see if it works.


despite being classified as an assault rifle in the inventory, the Fusil G1-4/C cannot be used to fullfill Assault Rifle Kills objective


Serves it right for overeating being this ugly.


Haven villa guard armour has a bug where the mesh clips into view when opening up a freelancer crate.


A Worthy Sacrifice – Lose 50,000 Merces by failing a mission.

If you fail a mission/campaign in Hardcore mode, YOU WILL BE FUCKED OVER AND WILL NOT COMPLETE THE CHALLENGE.

I saw someone else warning of as much on Reddit and, since I’ve mostly completed Freelancer aside from the more batshit insane grindy challenges, decided to corroborate the find (I lost much, much more than 50,000 just to be certain).

You will have to switch back to Normal mode to complete that challenge, and in turn encounter what I consider to be another design issue with Freelancer – losing your Freelancer tools for switching from Hardcore mode to Normal mode. Vice versa makes sense – preventing the player from having a starting advantage in what is intended to be the hardest version of Freelancer. But the Hardcore → Normal switch also removing Freelancer tools is excessive and unnecessary.


I’ve encountered this bug multiple times in Freelancer on different levels.

When a mission starts (Xbox One) there’s considerable lag for a few seconds while everything loads up (weapons, targets, suppliers, couriers, etc.) If you open up a supply crate BEFORE everything finishes loading, you’ll soft-lock the game.


Encountered this bug twice already, when exiting a mission in hardcore mode the game will register as a campaign failed even though I killed all the targets and didn’t failed the PO

1 Like

you can’t drop the rusty nail that sometimes spawns near the shed in the safehouse (I don’t know if there are others), which means you won’t be able to get rid of the 2 inventory spaces it has and can possibly lock you from equiping an item you need for the mission.


This isn’t so much a Freelancer issue as it is the overall game itself, I think, but I’ve only encountered this in Freelancer: in Chongqing, in the ICA facility, in the room in the other side of the scanning hallway the cooks go through, where there’s a guard near a desk with the level 2 dongle, a wandering male analyst and a female analyst in a small cubby, there’s a copy room there that allows access from this area to the employee changing room, and it has a copy machine that can be used as a distraction, a level 1 dongle and a cabinet to hide bodies in. If you do something illegal in this room, like lure in an NPC and knock them out, somebody from the other side of the wall or the floor below will see you and blow your cover.


I haven’t played the normal game at all since Freelancer launched, but the more I play Freelancer - the more I notice random things that weren’t issues before that have been broken in some way now. And if these issues are also there outside of Freelancer, the game has taken a massive step backwards in terms of its overall polish. :frowning:


I’ve found a couple more issues while playing:

The arrange a meeting prestige objective doesn’t work, I used 3 different phones and none of them worked. I didn’t work for the Prank Caller challenge either. I don’t know if this a bug or if I’m doing something wrong because some times I’ve used the phone It counted towards the challenge but other times it doesn’t.

The druzhina 34 artic doesn’t have the marksman perk even though the UI says it does.

The description for the all doors locked objective is misleading (in spanish at least, I don’t know if it is the same case in english). It explicitly says “don’t open doors by force” so I assumed you could use the appropiate key to open them but that is not the case. You fail the objective even when using a key, which isn’t really opening them “by force”.

This is mostly a question but I’ll put it here regardless in case it is a bug. How do you complete the Natural Selection challenge? I used a lethal poison vial i made on 47’s shed but it didn’t count towards the challenge. Do I have to use only poisons found inside the locations?


I don’t think this is a bug. And if it is, I think it wouldn’t be unreasonable for IO to retroactively declare it a feature because it is Hardcore and therefore there should be no reward for losing there.

Definitely seems like a bug to me, but if falls under the “Imperfections” part of “Bugs & Imperfections” either way.

If it’s contingent on being in and only achievable in Normal mode, the challenge description should explicitly say as much.


I have some challenges that stop counting, like getting rifles. I bought more than ten rifles at suppliers, I spent almost all my money on weapons, but the challenges stop counting at 9 from 10 :neutral_face: someone else had that problem?

Edit: nevermind, it worked now. I counted wrong :sweat_smile:

1 Like

I had a similar issue on the rooftoop near the laundromat. Choked a guy out and someone saw from the streets below despite being impossible.


I think I just lost a silent assassin prestige objective because a body killed with fire was found. Is it because I used the gasoline bottle from the freelancer tools? If it’s intentional then that’s absolute bullshit.


Well they could easily reword it. Probably easier that way then trying to “fix” it.

1 Like

A few more issues I noticed:

  • Occasionally some of the outside items like the rusty nail or the mushroom can’t be picked up, they’re outlined in instinct but there is no prompt to take them.

  • Ever since unlocking the explosives crafting station I can’t pick up the fuse in the garage (once again, no prompt) which kinda defeats its purpose :x


The supplier’s showcase background is too generic, I think the art could be improved on that bit.