Game wont start anymore

Hello everyone…
I have a rather big problem with the game wich is that it just wont start anymore.

*Note: the problem isnt that i just got it and it dosent work! I played it before for like 150 hours, completed it multiple times and it always woked fine.

But about a month ago my pc ran into some problems because my hardware started to… “die”
It wasnt dead yet but my pc crashed multiple times during that time when i played Games like Hitman or GTA V. Now after one (the last crash that happend overall) Hitman 3 just wouldnt work anymore and i dont know waht the problem is.

Gta works just fine if anyone is wondering which makes it even more wierd to me because why does one game just stop and the other works fine…

Now for explaination: When i start the game the launcher still shows up and when i click on start the game just… dosent open. When i look in the task manager the game shows up for about 3 and sometimes even 10 seconds before it just sais “stopping” or someting like that. (im from germany i dont know what the english version of the task manager sais in this situation lol)
Anyway… i looked on the internet and looked if anyone else had the same problem but with no sucsess… i tried some things they said might help with other problems tho which i will list up later. After no sucsess with all that i reached out to the Hitman 3 support who couldnt help me either after 2 days of figuring out what is going on. And then a few days after just trying other things again i kinda gave up and came to this webside here, thinking that maybe some of you have an idea waht i can do…

Now to the things i tried: (none of these woked for me)
-verived the game files via the epic launcher
-Reinstalled the game after deinstalling it and deleting all of its registery enterys
-Reinstalled the epic launcher after deinstalling it and deleting all of its registery enterys
-updating my graphics driver
-Windows update (just generally)
-ran the game without all unessacery backround procrecess (still didnt work)
-Upgraded litterly ALL of my hardware (a few weeks after it happend, this has nothing todo with my problem every other game/programm works perfecly fine)
-tried to give the hard drive its running on more RAM
-running both the epic launcher and the game itself (directly from the files without the game launcher) in administrator mode
-gave the game extra rights on my pc

some other info:
-i have Hitman 2 on steam and it work perfectly fine
-other games in the epic launcher also work perfectly fine

Now i dont know if anyone here can help me since not even the official support was able to do so… but if anyone has any ideas feel free to tell me
The last resort i have right now for me would be resetting my pc to its original form… and even there im affraid if it still wont work and it all would have been for nothing, and also… i really dont want to do that.

Well uh… thanks in advance
-Erik

Do you have any Mods installed whatsoever? Sometimes they break for no reason with Game Updates like my Mendoza Refaced (And general ability to mod the Map.)

1 Like

Event Viewer can give some info, at least what error code it gives while the game can’t start.
Maybe that code will help to identify the problem.

Also did you install any Razer hardware or software?
It’s known that Razer things doesn’t work with some games for some reason.
If you have any, uninstall and disconnect them and try if game works

1 Like

Your shader cache is maybe corrupted. Try to remove these files in Hitman 3 AppData local folder :

C:\Users\xxxxx\AppData\Local\IO Interactive\HITMAN3\PipelineCache.bin
C:\Users\xxxxx\AppData\Local\IO Interactive\HITMAN3\PipelineLibrary.bin

Note : AppData is an hidden folder.

No i dont hav any mods installed…
But thanks for the tipp anyway

I dont have any Razer Hardware or software…

But i will try the thing with the event viewer… because like you said… at least id have an error code then.
Thanks

I think i tried this before… at least in some folder of the game.
But there are 2 things that are wierd about this… First of all the Hitman 3 folder under appdata is in an extra Epic games folder and second that said Hitman 3 folder is compleatly empty…

Still thank you

The game needs this folder to store its shader cache, if it can’t write in it, the game can’t start. Having no files here is not normal and that may explain why you can’t launch the game. You can find a precompiled shader cache in HITMAN3\Retail\PipelineCache.bin (located in your game folder).

I think i tried this before… at least in some folder of the game.

Need more details.

First of all the Hitman 3 folder under appdata is in an extra Epic games folder

Same more details are needed. The path should be exactly this :

C:\Users\USER\AppData\Local\IO Interactive\HITMAN3

okok holly shit bro it acctualy worked… ive been trying to get the game running again for like 2 weeks now and nobody told me i just had to delete 2 files bruh

my mistake was i was in the appdata/roaming folder and not local
thats why i couldnt find it… anyway

Thanks a lot buddy it just works again
Thank you

1 Like

Glad it helped you.

@Travis_IOI @Clemens_IOI It’s not an issue coming directly from the game, but I think someone at IO can make this easier to understand for people who are in this situation by adding some exception catching during shader compilation stage when the game start and suggest (with a message) that the player can attempt to cleanup the C:\Users\USER\AppData\Local\IO Interactive\HITMAN3 folder. There is no easy solution I assume, GTAV and RDR2 have that too with the RAGE engine but the game returns at least an error (ERR_GFX_STATE) that appears on the desktop, which the glacier engine does not.

When a computer encounters a BSOD (for whatever reason), there is a small chance that the shader cache of the game will become corrupted. When that happens, it is no longer possible to start the game and the only easy solution is to delete some files in appdata local folder. But when you don’t know that, you can try everything and still be stuck.

I know that this is a known thing since Hitman 1.

1 Like

Hi! I’m having a different, yet similar problem to OP. I did the steps here, but there is nothing in the AppData folder (yes I am looking at the right folder). If I try to create a file and name it ShaderCache.bin, when the game runs it deletes the file. What steps should I be taking?

It seems the game is not able to compile the shaders at launch properly. In this case, I don’t know what to do except update your graphics drivers maybe and verify you meet at least the minimum requirements ? You can find a precompiled shader cache in HITMAN3\Retail\PipelineCache.bin (located in your game folder). Maybe this will help you.

For Hitman 3, files here are called PipelineCache.bin & PipelineLibrary.bin
For Hitman 2, it’s just one file called ShaderCache.bin