Hitman 2 stuttering

Every 5-6 months, with Nvidia updates, game starts to make little jumps in the image, when i’m running or walking you can see everything around 47 making little jumps in time, like stuttering. I’ve tried everything, GeForce experience optimization, disable Nvidia layout, restore to default in graphic section, the fullscreen exclusive or fullscreen, etc. etc.

What can be going wrong here? It only happens with this game

1 Like

Have you tried to uninstall GeForce Experience and Nvidia driver?
Sometimes it helps to do a clean install of those.
After deletion you reboot your PC, install GE and a driver again, but while installation there is an option of Clean Install. Tick it before proceeding. After installation complete, reboot your PC.
I believe it should fix those issues. At least it helps me

Also it won’t hurt if you delete the file named ShaderCache.bin in
C:\Users\XXXX\AppData\Local\IO Interactive\HITMAN2 directory.
XXXX - is your PC user name

1 Like

I always use Display Driver Uninstaller (or DDU).

I never update driver. Best practice is a clean uninstall, something that DDU does. If you use nVidia GeForce experience you have to redo all settings manually.

I’ve tried everything you said and nothing

I hope it’s obvious what is happening

there are little jumps in the image (if you don’t see 47, but the things surrounding him it’s more obvious)

What Kind of monitor do you have? Gsync, resolution?

I have a 4k 120hz monitor and I noticed that Gsync doesn’t work in Hitman 2 like it does on alot of my other games. When I’m getting 90 to 100 FPS the game stutters like what you have in the video you posted. However, I have found that turning on Vsync option “1” fixes the issue for me. Option one says it cuts your FPS in half to 30FPS but it only does that on a 60hz panel. If you have a 120hz panel then it will cut it to 60FPS. It’s smooth as silk at 60FPS but not a 90FPS so it’s got to be a problem with the game’s frame times matching up with the display panel.

If you have a 120hz panel then try using the Vsync 1 option in the game. If you have a 60hz panel then use option “2”. Don’t try to force Vsync or FPS limitations through the Nvidia control panel on this title.

Usually with a Gsync monitor you don’t need Vsync at all but for some reason Gsync stutters in this game at least on my monitor it does and in game Vsync is the only way to work around it that I have found.

1 Like

Sorry, nothing worked at all

i’m beginning to think it’s a hardware problem