HITMAN 3 - Bug Report Thread

I think it’s because they can’t be found?
Isn’t there this one roof access window thingy in Berlin that also allows you to dump unconscious bodies without killing the NPC in the process?

1 Like

There’s a few places like that in Berlin. Another one that comes to mind is Marakesch. Like where Mr. Giggles hangs out. You can pull him (or any NPC) over that brick wall. They can’t be dumped though. Anyway, you can get over to that and snap their neck or w/e.

This railing in Mendoza… Like I said, there’s no way out, and I’m 99% sure 47 can’t get into those Lavender flowers - like if he needed to get to them to snap their neck.

I ended up shooting the target.

1 Like

Yes. NPCs can be found there though, and woken up. But they will immediately die as they cannot find any path.

Alternatively, on the Yates’ rooftop, you can dump bodies there and they can never be found, even if you then go onto the rooftop yourself and push them back into the normal NPC bounds.

PS5 Freelancer

Challenges are showing as complete when i haven’t actually completed them

not the worst bug in the world, but mildly annoying when i was getting used to the idea of the long grind and now i’m being rewarded challenges before they’re finished

examples i’ve noticed;
“Oil Money” - eliminate 50 leaders or members in Dubai, i think i hit around 35 when i was awarded the challenge
“You Urned This” - complete 10 campaigns, i got this one after completing my 9th
“Psy ops” - defeat 10 psy ops syndicates, i think i did 7/8

i’ve noticed other challenges ticking an extra 2 or 3 at a time some times when it should just add 1
again, not the worst bug but something that should be addressed

1 Like

PS5 Freelancer

occasionally suspects are completely immune to dart guns

i have no steps to reproduce as it seems to be a randomly occurring bug, but every now and then on a showdown every suspect will be made of empty pixels as far as the dart guns are concerned

i’ve been literally walking 5ft behind a suspect, shot a dart gun at their back (multiple times), and the dart has gone straight through the suspect with zero effect
it wasn’t just a case of delayed or negated affects due to hearing the shot or being alerted, the dart literally went through as if they didn’t even exist

extremely frustrating when coupled with a “poison target - dart gun” objective

Xbox Series X
Digital Copy
Game Version 3.140
Xbox Update Version

Xbox Display Settings:
Resolution - 4k UHD
Refresh Rate - 120 Hz

Xbox “Video Modes” Settings Active:

  • “Allow 24Hz”
  • “Allow Variable Refresh Rate”
  • “Allow 4K”
  • “Allow HDR10”
  • “Auto HDR”
  • “Allow Dolby Vision”
  • “Dolby Vision for Gaming”

Xbox Video fidelity & overscan settings:
Color Depth - 30-bits per pixel (10-bit)
Color Space - Standard

Playing off of TCL 55R655 Television
HDMI settings active:
-FreeSync Premium

Most of these will just be copy/pasted from my posts in the Hitman: Freelancer | Bugs & Imperfections thread with some formatting tweaks, but I’ve added some additional issues I’ve come across since then as well.


No clips of this of course, but definitely thought I needed to report something as severe as a game crash. Specially want to mention the fact that the game NEVER crashed once on me before this update, either on my Series X, or my old original Xbox One. I’ve had witnessed three instances of crashing so far; two happening to me, and one other to someone who was playing on their own profile on my Xbox Series X.

  • Crash after completing a mission on Chonquing. Went to exit, exit cutscene played, then hard crash to Xbox Dashboard. Luckily, when game was started back up and Freelancer was selected, 47 spawned back at Safehouse with the mission counted as complete. (Happened to other player on my Xbox).
  • Crash on New York, first Showdown Mission on Campaign One. Eliminated Leader (quite a few NPCs actually, bringing this up because it may be relevant at the end) and was leisurely exploring the map opening supply crates. Opened one in Director Athena’s office, selected Lil Flashy as the item I wanted from it, and then suddenly BOOM, crash to Dashboard. Wondering if the amount of dead/unconscious bodies in one of the bathroom stalls somehow overflowed the system’s memory or some such, and got sent over the edge by taking an item from the crate?
  • Last instance happened on fishing dock at Safehouse; was just trying to have 47 kick back a little bit, but the poor guy kept catching driftwood. I kept dropping the driftwood logs on the deck behind 47 after every time I caught one, and I think I got to around 5 or 6? Anyway, I caught a Rusty Crowbar after one cast, dropped that on the pile as well, anddddd…thats what killed the game. Just speculating here, but it seems like the game is having a real hard time with performance/handling a bunch of active entities in game at once, which was NOT an issue for the Xbox platform (either the One or the Series X) before this update.
  • Not a crash instance on my half, but I did make a thread on here after the infuriating New York Crash, and MOST of the replies were other Xbox players saying that they were also having crashing issues. Not a software engineer at all, but doing some quick googling I’ve found instances of Xbox players claiming that memory leaks were happening with their copies of the game, and this was BEFORE the update, which makes me think that, along with a lot of the other bugs I mentioned, this stuff very disappointingly was put by the wayside and left unfixed while this update was being worked on.
Baseball Bat Prestige Objective Broken

Extremely self-explanatory, the issue is evident in the clips I posted. I’m assuming because I used the “Collector’s Baseball Bat” instead of a vanilla baseball, it didn’t count toward the Prestige Objective; a completely asinine oversight considering the other prestige objectives use blanket categories that encompass multiple weapons (Epic Shotgun, Epic SMG, etc.).

And if you’re wondering why I DIDN’T just use the normal baseball bat found in this map; I threw it on the docks at Rico’s mansion to try and distract an NPC…it disappeared once it hit the ground :upside_down_face:



Suspect AI

This is an ENORMOUS one to me, because it absolutely gets in the way of the main gameplay and progression systems of Freelancer mode. Simply put, sometimes the Suspect AI just, doesn’t work. Here’s some examples from Berlin:

Berlin Suspect Loves Motorcycles

Berlin Suspect Enamored by Table
[Video Broken, description: Another Berlin Suspect, a woman who was previously performing tells, now stands in perpetual idle animation at a table]

Now, these two suspects WERE performing their actions prior to this; I witnessed both of these suspects wandering around, doing secret meetings, and performing their tells (the woman stuck standing at the table was eating pizza at another table, and drinking a beer at the bar). After the motorcycle guy had a secret meeting, I followed him afterwards, hoping to knock him out. He wandered into the garage, and then just…did this. Indefinitely. Distractions didn’t work either. I went back to the woman, and discovered she had stopped doing her behavioral tells as well, just standing idly at that table in the bar area doing nothing.

Now the obvious problem with this here is, with the two suspects both having the same physical tells, and with them NOT performing their behavioral tells anymore, there is NO WAY from this point forward to tell who is the actual Leader is. I’d just have to guess and hope I got the right person. Totally, totally unacceptable, and extremely random. Now I don’t know if this has anything to do with what happened, but as you can see I also had several optional objectives completed at this point, and several suspects were knocked unconscious as well. I’m not sure why any of that would break Suspect AI, but I thought it was worth mentioning just to be safe. Speaking about Suspect AI…

Burner Phones. Just, the whole gameplay feature.

Huge, HUGE problem with the burner phone feature in Freelancer. Specifically, in the fact that it barely seems to work. In Dartmoor, I had this happen:

Impolite Dartmoor Suspect

Placing a burner phone and hoping to achieve my Prestige Objective, I was very confused as to why only one suspect showed up, turn around, LEAVE, and walk past another suspect who was actually walking to that area not because of the phone, but because it was part of her scripted AI path. What exactly happened here? Aren’t the burner phones supposed to attract suspects to wherever it was placed? Sometime afterward, I clipped this:

Dartmoor Suspect Learns Manners

For whatever reason, THIS time the two remaining suspects did decide to go to the burner meeting location, netting me my prestige objective. Notably by this point, the actual Leader was sussed out and killed; that and the fact that I completed another optional objective appear to be the only differences between the two burner phone attempts. No idea if that has any bearing on this at all, but again thought I should at least mention it.

Had another instance with burner phone problems in New York, didn’t get a clip, but it was basically just more of the same problem; several suspects on map, and placing burner phone in the bathroom only lured one or two at a time. Sometimes one would show up, wait a little bit, leave, and then another suspect would show up, and do the same thing. I had multiple burner phones in my inventory at the time that this was happening, and I saw that I couldn’t activate another burner phone after because “Meeting was already taking place” (or something of that nature), even though every Suspect was ignoring the already activated/placed phone and nobody was even in the same room as it.

PART 2: Ok so, this shit is just straight up broken. From my experiments and goofing around, I’ve come to the conclusion that, atleast on this Whittleton Creek Showdown Mission, Burner Phones have no consistent way of working.

First clip, pretty straightforward; Playing a showdown mission on Whittleton Creek, Level 3 Syndicate on my first campaign; activated a Secret Burner Phone (action “RT to ARRANGE SECRET MEETING (Invite All Secret Agenda Suspects)”) to complete my “Arrange a Meeting” Prestige Objective (and to progress the “Prank Caller” challenge) anndd…the Secret Agenda suspects all come to investigate, but it doesn’t count towards the Prestige Objective/Challenge? (The grey haired lady suspect moving through the garden is the Leader, not sure if that matters at all, but thought I should mention it.)

(Same mission as above)
Now in this example, we see here that activating the Business Burner Phone (action “RT to Arrange Business Meeting (invite all business agenda suspects)”) DOES pop the “Prank Caller” challenge and “Arrange A Meeting” prestige objective…so for some reason, one type of burner phone counted in this instance, but another kind doesn’t. Keep in mind, the description for the Prestige Objective and Challenge both DO NOT specify what kind of meeting to arrange, just that you need to arrange one.

(Same mission as above)
Leader eliminated and body hidden, Assassin alerted, Suspects come to investigate phone, No prestige objective pop.

Same as above, only difference is Leader body was found and not hidden (non-target NPC bodies found as well)

(Same mission as above)
For good measure, here’s one more Secret Business Agenda meeting attempt; notable for the “Investigating Distraction” PIP not showing when the Suspects start heading for the phone, and for…whatever is happening with those magazines stuck to the Suspects hands there. (other example of Prestige Objective/Challenge not popping as well.)

EDIT: OK so, this is another Secret Agenda Burner phone run, attempted much later than the last few I posted and…it worked. I have no idea what is happening here. So far my only guess is that its completely and totally random in when it decides to work and when it doesn’t.
I also noticed that activating the phones in a second floor of a house never got them to work, but trying them on ground level of the map got it to work more than not, so it may be elevation based?? But then again in that first clip I posted in this section I placed it at ground floor and it didn’t work, so honestly I have no fucking clue what is happening with this phone mechanic.

Another instance Prestige objective working, again no idea what the deciding factor is: In this case, the Leader is eliminated, their body hidden, and I placed phone on ground floor of Cassidy’s house.

(Same mission as above)
And one LAST phone bug; placed the Secret Meeting burner phone after some uh, mistakes were made in the mission, resulting in the remaining Suspects fleeing the map (the Leader was already eliminated by this point). Now of course the Suspects couldn’t come investigate, seeing as how they had left the map already, BUT the “Investigating Distraction” PIP still shows in the corner revealing…nobody at all. Not a gamebreaking bug by any means, just a funny (but glaring) oversight.

Npcs seeing through walls. Again

I really thought we had this issue taken care of, but nope, it seems like its back, and its back HARD. Three examples below:

Dartmoor NPC with best phone camera on the planet

New York NPC sneaking a peak through the bathroom wall

Sapienza NPC and I honestly have no idea where or who was looking at me

More of this shit. Level 2 Syndicate showdown mission, first campaign. Berlin. Self explanatory.


Suppliers who are too into their Roles

In Whittleton Creek, the supplier in the garage disguised as a baker was doing this:

Whittleton Creek Supplier is committed to the bit
He was like this the entire mission, even when other NPCs were not present. For whatever reason, he wouldn’t exit his animation loop of kicking the car tires, no matter how long I waited. This happened everytime the baker was the supplier for Whittleton Creek, so even coming back on another mission didn’t fix him.

Lethally Poisoned? Just hold your breath or something idk

Attempting to Lethally Poison some Suspects and guards in Nolan Cassidy’s house on Whittleton Creek using the fumigation machine, turns out that these crime syndicate guys have REMARKABLE resistance against inhaled poisons:
Not only does it take forever for them to die, their lookouts become alerted and they begin escaping. They don’t make it, but for a method that is supposed to instantly kill, it sure does take a while for it to kick in.

Attempted to recreate the same event later: one Suspect goes down much quicker this time and nobody gets alerted, but one Suspect does manage to make it out of the house unscathed, despite her being right next to her co-worker when I released the poison.


Assassin Alert Bugged?

No solid proof on this one yet, but I believe that assassin’s have bugged alert states. Might be missing something about the particular situation showcased in my clip, but it seems that as soon as the assassin became alerted, so did every single other person in the area? The Leader becoming alerted I understand as we are in the same room, but looking at the map and using instinct it seems like everyone surrounding the house also went into alert state as soon as the assassin went hostile. Don’t have a clip of it, but I also had a similar experience in New York; entering the bathroom next to the bank’s entrance, I shut the door and shot the civilian and guard npc inside with my silenced Assassin’s Pistol, and somehow the Assassin who was chilling outside heard it and alerted everyone else around…which unfortunately included Lookouts and Suspects.

The Indisturbable Whittleton Creek Yoga Man

Whittleton Creek yoga man goes into alert state, compromises 47, and then…just goes back to doing yoga, even after being fired upon. Just a weird but pretty severe AI glitch, probably the most severe I’ve ever seen in the game.

Emetic briefcase "item dropping" glitch still not fixed

A bug thats been around a while and has been brought up many times; After activating the Remote Emetic Device while inside a held briefcase, a NPC will get the question mark above their heads and go into “investigate mode”, heading toward wherever you activated the case. They’ll then bend over and act like they’re picking something up, give “it” a look over, then go back about their business. This happens consistently everytime the Emetic Case method is used, and has been an issue for a while.




(this one is of special note as apparently this guard NPC crosses the entire backyard to come investigate the suitcase activation area? Saw this happen multiple times, NPCs crossing the map to investigate the activation area, sometimes from houses away.)

Courier NPCs who aren't couriers?

Another one of those really fun instances that I keep running into were I don’t if whatever is happening is a bug or not, but on this Showdown Mission in New York, there was an NPC wandering around on the second level acting like a courier; pacing around on a set route and spouting courier dialogue. However, he did not show up on my map as one, and didn’t have the icon either. Indeed once I knocked him out and checked his body, he didn’t drop anything of note. I’ve only run into these “Fake Couriers” a few times and not so many lately, maybe only an early campaign issue.




Double Vomit Bug Toilet Sharing

Another classic, emetically poisoned NPC going to throw up in a toilet already occupied by a vomiting NPC (in this case the nervous interview guy in New York). This bug has been around for a while and its disheartening to see it still present.


Emetic Poison Animations not triggering

Self-explanatory, did the Remote Emetic Device briefcase trick on an alerted Suspect, she got poisoned and started wandering toward a toilet, but the “I’ve been emetically poisoned and my stomach hurts” animations never triggered, resulting in some confusing feedback.

Weird Camera in Safehouse *Safehouse Mastery Unlock Spoilers*

So after turning 47’s basement office into his own private Dedicated Jam Room, I noticed something very strange whenever 47 would start his drum practice; the camera doesn’t seem quite able to keep centered on him? The only time I’m able to is when I place it RIGHT in front of him, and even then it seems extremely close. Very bizarre bug, especially in a game where I’m not used to encountering any bad camera issues or glitches like this.

Performance Drop in Safehouse, looking at gun rack

Self-Explanatory, running around the shooting range and when turning around to look back at the main basement area/Gun Rack, got a pretty noticeable Performance Drop. Have had several other instances of this as well, just not clipped unfortunately. This is a pretty notable issue due to the fact that, well, I’m playing on a Xbox Series X, and it should have more than enough processing power to handle looking around the Safehouse. In fact, this is the very first time I’ve noticed ANY performance issues on the Series X version, it ran flawlessly before this latest update. Not my area of expertise but definitely thinking this is some sort of optimization issue, pretty disappointing.

Daydreaming NPCs

There seem to be a lot of issues where NPCs just decide to stop working and stare into space indefinitely. Here on Haven, Tyson Williams has decided to stop dead in a doorway and block me from entering. Have a hunch it has something to do with bodies being found, or other NPCs that usually interact with the “daydreaming” NPCs being eliminated in some way, but no hard evidence of that theory.

Same case here with Nolan Cassidy on Whittleton Creek; has decided to stop in his garage indefinitely. You can see I come back a NUMBER of times over the course of the mission to check on him and see if he’s started moving again, but he was stuck like this the entire time.






Another case on Whittleton Creek, the Assassin who was assigned to the Syndicate Leader becomes paralyzed after her elimination. This one is extra funny/weird to me because I’ve seen assassins who DO have behaviors that they exhibit if their Suspect escapes/dies; on the very same mission, i ran into an assassin leaning up against a fence having a smoke break after his Suspect was gone. So why this one got stuck staring at a wall instead is anyone’s guess.



Just another weird AI instance, a guard in Whittleton Creek staring dead into an open door. Not really sure what else to say here, not a game-breaking bug but definitely seems like it shouldn’t be happening.
(Probably just hanging back and door just happened to be there)

Marrakesh following me thru wall?

This is one I’m not 100% sure of and is making me question my own sanity; doesn’t it look like the guards here are staring at 47 thru the wall? Like not activating a vision cone or anything, but moving their heads toward his direction? Again this could just be me hallucinating, but considering all of the other weird bugs and glitches I’ve encountered so far, I’m going to err on the side of safety with this one.

Visual glitches upon starting Freelancer

Self-explanatory, just weird color/texture pop-ins and random fading to black; stuff like this seems more common since the update dropped.

Absolutely INSANE visual bug

This clip was captured by another user but I got their permission to post it here; ALSO of note, this was captured on the Xbox One, not the Xbox Series X like all my other clips. Regardless, this is absolutely insane and I cannot even begin to guess what is happening here. I’d say it was situational but it seems to begin and end randomly.

Weird Bloom effect on HUD

Again pretty self-explanatory, but for some reason, at a random point on this mission in Dubai the HUD began producing this strange blooming effect (specifically the yellow “trespassing” graphic).

Inadequate Information Conveyance

More of player-feedback than a bug, but there is quite a lot about Freelancer mode that makes it feel more like an in-progress fanmade mod than an official game mode. Despite all of the new assets and production elements added, there’s a rushed, slapdash feeling to the whole thing; it lacks a polish. One area I think needs the most work is clarity in conveying information to the player. You can see from a few of the bugs/issues I posted that I wasn’t even entirely SURE if what I was experiencing was a bug or not; gameplay that leaves the player confused and questioning if whats happening is the intended experience or not isn’t exactly the ideal situation. I’m not advocating for more hand-holding being added, but some things like CLEARLY defining how exactly the new Assassin and Lookout NPCs operate outside of a general “these are like bodyguards but harder” and “these guys will alert people”. I also originally thought several Supplier NPCs were bugged (although to be fair, it turns out atleast one was), but it wasn’t until later that I found out that they won’t sell to you with other NPCs around. Having that atleast brought up in a loading screen tip would go a long way.
The very first bit of feedback I had for Freelancer mode was that the vanilla prompt of “Exit to Menu” is STILL present in Freelancer missions, even though it takes you back to the Safehouse in a failed state, instead of the Main Menu. Egregious examples like this are what I’m talking about when I say the mode still feels unfinished.

Thats enough of being an unpaid game tester for one evening I think (although my DMs ARE open if you need more help IOI). I’m done with the game until a patch drops with fixes for not just these, but all of the other issues I’ve seen people having with this last update. Very disappointing work from a studio and product I’ve held in extremely high regard since I started playing this new trilogy in 2016.

1 Like

^ Yeah, this. It also applies to any NPC, not just guards, and also applies to briefcases.

You can ‘disassociate’ yourself from the item quickly by moving far enough away from it, otherwise it takes about 15+ seconds (rough estimate - it feels like an eternity in play) for the item to be deemed ‘abandoned’.

1 Like


The word “canister” is misspelt in the objectives that the word. It has two n’s. It’s also misspelt in the objective description. Note: This is the “kill the leader with a canister” Prestige Objective.


I can’t redecorate the safehouse kitchen countertop in Freelancer. It disables Instinct mode afterwards,

Loaded into Freelancer

Found out someone smothered 47 in the night

This shouldn’t happen as 47 went to great lengths to hide the location of his safe house


Steam PC; Hokkaido, Miami (and probably others)
Dead ‘suspects’ continue to appear w/ bright purple icons on minimap.

I noticed this last night on Hokkaido, but the screenshot I thought I took is not there.
It was a showdown with 6 targets. I killed one with a broken neck and stashed them in the closet.
The icon remained bright purple. Happened again on Miami map. I killed two suspects and their
trailing assassins (I’ve been hoarding silenced pistols mwhahaha). The two suspects I stashed
in the container in the security office and both showed their purple suspect icons.

I’ll see if I can grab a screenshot if I see this again.
I don’t know if it’s frequent or was only those two maps.
Hokkaido didn’t come up today… yet. Miami is not doing same thing so it
may have been just a glitch for that campaign.

1 Like

Steam; PC.
No specific map.

Suspect camera does not work through windows or through bars. Whenever a suspect through the camera through glass or even the fence in Maldeves the camera shows “no suspects here”.
The message at least is in error.

1 Like

Steam PC; Freelancer mode.
In the safehouse.

I unlocked level 32. Items already unlocked showed icons as if they were new and the option
buttons got locked onto 47’s back.

The icon to change the safehouse stuff will no longer show up.
In trying clear it I picked up the firepoker. I’m locked holding the firepoker. Drop item button does not work and I’m over gear capacity. The entire inventory menu option does not work.
I’ll need to exit to main menu to clear this glitch.

I restarted the entire game after this above glitch. Unlocked the shed and poison still.
I found the rusty nail on the ground. It uses 2 gear slots and for some reason I can’t drop it once collected. I dropped everything else and the nail will not go away.

Actually the whole interaction menu has vanished. No inventory and I cannot interact with anything now. Here’s a video clip: Hitman Freelancer Mode interface glitched. - YouTube

This began with level 32 .

I’ve further linked this bug with one prompt in the safehouse near the counter on the right of the door from the lower bunker level. The one at 50 seconds into the video clip. Hitman Freelancer Mode interface glitched. - YouTube
If I Interact with that one prompt all other prompts in the safehouse break except entering a mission.

1 Like

Hitman 3 (WOA)
Platform: PC (STEAM)

Location: Bangkok

1.Start the game
2. Start “Club 27” Mission
3. Listen to “Mean Machine” convo in tables section or select “Mean Machine” Story
4. Go to Bar Area where Abel de Silva roams on two bars
5. KO one waiter, dress up, use emetic pills on Silva’s drink
6. Silva will never drink after the drink is poisoned, disabling you to get his outfit

Platform : Steam ; PC
Freelancer mode.
Location: Dartmoor ( probably others too)
Freelancer Suspect camera zoom bug.
Zoom indicator changes, but no zoom effect is observed.
Video clip here:

This has only happened this once so far.


Freelancer / Hokkaido
I’ve never experienced this lighting before in the Morgue… and I thought it was actually pretty awesome!


Have the same issue on PC steam.

PC Steam

Distractions inside the Dartmoor manor are still broken. NPCs are hearing things that they logically shouldn’t be.


Steam PC ;
Freelancer mode Safehouse.
Reward crate empty at campaign end

It was empty for the 2nd to last mission before the showdown at the end of the campaign and after
finishing the campaign too. My freelancer tools box is full and before this it kept only giving me
items I’d used in the mission just finished. So I used an EMP and it gave me an EMP.

Not sure’s linked to a particular map or campaign other than that this is the fourth campaign I’ve finished and total completion is now 30%.

This is why. This reward box only gives you Freelancer tools. When you have them all, it becomes empty until you lose an item or use it.

Not a bug.

1 Like