Hitman 3 doesn't start (it used to long time ago)

Platform: PC, Win10

Description :
I haven’t played H3 in a long while, it just quit starting upon launch. I used to run it smoothly. Since last summer I think, upon load and splash screen that offers “Play”, “Options”, “Quit”, spinner spins for few seconds and nothing happens.
I tried deinstalling/reinstalling.
I bought it from Epic site, early when it was released. I updated all possible updates that was offered to me.
I even tried deinstalling, and installing demo version from Steam. Same result.

Steps to reproduce: Start the game.

Frequency : Always

P.S. I browsed the forum, found similar issues, but they had black screen. I don’t have black screen, just nothing happens after I click “Play”.


Sorry, I don’t know what that means.
Do you mean this?

I’ve had similar happen in the past.

I don’t know if it’ll work for you, but try ‘Options’ and setting things to low.

If that gets you back into the game - change everything back to the default settings, or to whatever you prefer.

Good luck. :confused:


Thanks but that was the first thing I tried :slight_smile: (didn’t solve the problem)

If you are using RTSS (Rivia Tuner Statistics Server) to use as a scanline-sync or monitor performance, make sure you have the launcher black-listed. For whatever reason, this became an issue in a random update a few months ago.

If you are not using RTSS, then I am sorry for not being much help.

EDIT: Accidently said to white-list it (always enabled). This was a mistake, I meant to black-list it (always disabled).


I don’t. Thanks anyway

1 Like

So I contacted support (back and forth, how it usually goes) and finally they told me that

"After investigating the logs you sent over closer, I was able to see that your computer does not meet the minimum system requirements (AMD Radeon HD 7870) in order to play the game. "

However I told them that I used to play it for a year or so after it was released, and I proved it with the screen capture of my Epic games account saying “You’ve played 87h 42m”.

They just basically repeated the last answer like " as long as your computer does not meet the minimum required specifications as indicated by the developers, we cannot guarantee the game will run well."

So can somebody help me out, how to setup my PC to run it again? (I never changed any my settings so that could cause problem) So basically, I want somehow for the game to detect “Ok, this is playable on this device”. If the performances are not high, that’s on me.

1 Like

Hey, just to clarify: What is your setup exactly? An easy way to check in by pressing `[Windows Key + R]` on your keyboard and running the command `dxdiag`.


There, you should find your motherboard, CPU, RAM, DirectX version, GPU (under Display 1) and other relevant driver versions.


1 Like

Haha, wow. Those are some really old graphics drivers. I wouldn’t be surprised if that is the problem.

I suggest updating them, you can find your drivers here.

You will just simply click this link:

Unfortunately, I cannot guide you through this as I do not own an AMD graphics system myself. If you have problems with this link, you can try ‘Auto-Detect and Install’ method provided by AMD.

Let me know how it goes.

1 Like

Thanks but it didn’t help. I installed the AMD Radeon Settings and within the console within the games I configured all the lowest possible values for the H3 game (for some reason it is listed entitled “Warframe” and it has H3 avatar).
Same result as before.

Have in mind that I don’t think the drivers are to blame, because I regularly play H2 without any problem, and I can run some other games like Arkham Knight or so.

1 Like

Apologises for the late reply, I had a busy day.

Unfortunately, it sounds like that the game has just aged outside the spec range of your hardware.
You are of course using integrated graphics from your CPU, you don’t even have a dedicated GPU.

I am sorry I cannot be of much other help.

To answer your question regarding the profiles having other games listed; this behaviour is normal. It just means that they share the same profile and other games.


1 Like

Thank you. I managed to start it after all, after multiple tries and downloads of the links you provided.
Thanks again


I am incredibly happy to hear this. I am very happy I was able to help! :grin:


I’m sorry to say, I have the same problem again, all of the sudden :frowning:

I upgraded the drivers from this page: https://www.amd.com/en/support/kb/release-notes/rn-ryz-vega-win-17-40
I selected the recommended (at the same time the latest) version.