Hitman 3 Unplayable Glitch: Screen pulses black every few seconds during gameplay

I played the Hitman 3 demo with no problems, then upon buying the game and attempting the prologue chapter, things started acting up. I began the first mission and during the cut scene where they introduce the party boat, the “black fade transition”–which I’d assume is used to bridge some of the shots together–started being used once every 1 to 8 seconds (sometimes rapid back to back, sometimes not: very inconsistent). This gave it this pulsing effect where everything would go very dark, slowly fade out to reveal things at normal brightness, then cut back to being dark, fade out to brightness, and repeat.

The cut scene ended and it was time to move the hitman around. This pulsing continued, making it like I was doing the mission blind half of the time. I tried messing around with the options for a while, researching similar problems (but found none), trying out different missions in the chapter, and tried uninstalling and reinstalling the game (which took 3 hours to do both times I installed the game). In the demo, the outer rim of the screen would occasionally darken during the gameplay as if to simulate the hitman blinking, so I thought that maybe that’s what was happening, but somehow the effect was glitching and making the whole screen almost totally dark. I’m not sure if this is it, but I tried looking up ways to disable this effect but to no avail.

The issue has persisted still and honestly the game is unplayable. Even when I pause the game during a mission, in the background, the pulsing still continues. It’s driving me insane and as a someone who almost never buys or plays games and is brand new to Hitman, this is definitely putting a bad taste in my mouth.

Anyone feel they can assist with this situation? I took a video of it with the intention of attaching it to the complaint, but I see no way of doing that. Any help is very helpful. Thank you all.

While I don’t think I personally have the knowledge to help you, you can try reaching out the official player support channel in the link below:


In addition, I don’t see any details about which platform you play on or in case you play on PC, your PC specs. I’d recommend you to provide such details in your request so IOI’s staff may assist you more. It would also be better if you may attach some screenshots of your game as the issue takes places.

1 Like

Thanks so much for the speedy response! I really appreciate it. I made sure to file a report with the link you provided so thanks for that as well!

I’m playing on a PC through Steam. I made a video demonstrating the issue that can be found here: Hitman 3 Unplayable Glitch: Screen Fading Black Repeatedly Problem - YouTube

1 Like

I found this, it seems a similar problem, may be you already checked that.


Dang, that sounds like it really could be it, but unfortunately it looks like there’s no way for me to fix it seeing how I don’t have a VR headset to be able to access the VR settings to turn off that motion blinder setting.

Thanks so much for finding that for me. However, frickn what the crap am I suppose to do, iOi? I have no idea how to remedy this situation.

1 Like

Yes, if that’s the issue it’s not clear how the setting was activated. Furthermore the june patch notes say that the issue has been fixed. I don’t know if that setting is user specific but may be you could try running the game as another user to see if that goes away.

Anyway you should open a ticket to the zendesk ioi support like it was suggested in this thread.

I did actually when I got the reply, but iOi hasn’t responded quite yet. Would being another user mean I would have to buy the game under a different steam account and then try that way? If so I don’t know if I want to buy the game twice… If there’s a different way though where I don’t need to spend anymore, do please let me know.

Thanks for your help though bro. Like, got some stuff going on in my life and kinda really need an outlet to zone out, thus my being a new gamer and never having really bought a ton of games before.

I am on console now so I am not familiar with pc gaming but I know Steam has family sharing so I guess another account could play hitman on the same pc without buying another copy if you authorize it.

Alternatively you could try to reset your Hitman 3 game settings but as I said I am a console gamer so I am not sure how to do it in a proper and safe way. May be other forum members can help about that.

I had that back last year, but after a while it just vanished, idk how it did but it did

Check your game settings and make sure that the monitor and Graphics Card you are using support them. Sometimes there’s a conflict between the display settings and the Graphics Card Driver settings (e.g., refresh rate supported by your monitor). You can play with the settings and run the benchmark tool to see the effect each change has on your issue.

I just recently bought and installed Hitman III and now ran into exactly the same issue. Were you in the end able to solve it and if yes - how did you do it?
I would be really happy if you could help me (:slight_smile:

1 Like

Hey @Loge ,

Unfortunately, no. It’s just sitting on my laptop being I played because it’s literally unplayable rn. I just fatigued of trying to get help and turning up with nothing. If there’s another person this could help though, that may reinvigorate me to find a solution though. Us hitmen gotta look out for each other.

Actually this is perfect: Loge, I dragonfighter4776 (a name I chose ironically for my spam email account and feel I must say at the risk of someone thinking I chose this unironically) make a promise to thee—I shall begin seeking assistance for this problem and shall pledge myself to this mission of restoring our hitman 3 playing ability. You have my absolute allegiance and loyalty. I will do all I can to not fail you m’lord. I shall report back here with updates of my mission as they occur. I don’t know if English is your native language and if you can read this all or not, but if not, let this be a message be one said and heard in spirit.


Will report back soon Master Loge. If anyone comes up with anything in the meanwhile, please post it here.

Loge, I remain your obedient servant.


Hi @dragonfighter4776,
Thank you very much for your answer.
I am very honored and pleased by your promise, fearless dragon-knight! I myself swear to you, to inform you about any possible solution. Today I already explored deep down into the dark forests of the Hitman-Support-Ticketsystem, but the woodmen only gave me some generic solution-ideas for the time being. Currently my loyal computer is reinstalling the game, in hope it will help.
As far as I experienced, the bug turnes out worst in the ICA-Facility, in the other missions it’s still really annoying, but it turns less dark, so one could actually play them kind of. Did you try out the other missions as well?

Best Regards, my brave Fighter!

1 Like

Ah Master @Loge , welcome back.

Those woodmen: what can be done? Useless swines (jk I have utmost respect for people in the customer service field: may your burdens be light and may the gods bless you).

I’ve messed with the initial options configurations and tried out different maps and it seems that it occurs the worst with maps that are “darker” (ie: the training maps at the boat party, etc…) that’s when it’s unplayable. If I go to the Dubai map, it only occurs when I’m in darker rooms. When I jumped ahead to the Dartmoor, England map, I haven’t headed inside to the mansion yet, but when I’m just outside, there’s very minor pulsing (perhaps due to it not being fully light outside but not being totally dark). I have wondered if it’s some issue with the shadow settings, but I have everything set to the lowest setting possible.

Since there’s not a lot of complaints about this specific issue, I’m going to try looking up solutions to other problems that fall under the same genre of the problem we are dealing with: perhaps there are settings or actions that other people have done to fix similar problems that would help us as well.

Also, I must inquire: How art thou this fine day, my king? Dost thou have exciting plans for the weekend?

Once again, I shall report back post haste with any updates.

I remain your obedient servant, my king.

I suggested before in this thread that the issue could be the ‘VR Blinders’ applied in non VR mode but since you don’t have VR headsets I am unsure how it got activated in the first place. This is an example in miami

It has a definite elliptic shape. So if yours is different may be it’s another issue.

An idea could be to check your local setting file if contains something related to VR (if the file is readable with a text editor).

Otherwise may be you can compare your graphics card configuration.

Anyway, a little disappointed by zendesk support.

I think I have another problem, my bug does not look like this. The screen is turning dark, instead of a vignette. But thank you very much for the suggestion.
@dragonfighter4776 yeah this does exactly sound like my issue, so maybe the other missions would even be playable, but it would still be really annoying.

1 Like

Hi dear dragonfighter,
After some chat with the support they could actually offer me a solution. I was able to completely get rid of this pulsing screen. The issue is apparently linked to corrupted driver and memory leak. However the solution process seemes to be quiet complex and individual, so it might be the best, if you write to the support yourself.
I really hope, it works for you as well!
Best regards