HITMAN fails to connect to server since days


I bought HITMAN 1 (2016) on steam a few days ago.
Since three days, the game fails to connect to the server.
And it seems that I’m not the only one in this situation (see ¹ and ²).
Is there a problem ? Thank you.

  1. Cannot connect to HITMAN Server :: HITMAN™ Tech Support
  2. https://www.reddit.com/r/HiTMAN/comments/ql8oe8/connection_issue_with_hitman1/

Hello, netfab.

The website here made by fellow member @Hardware can help you track whether the servers are online or not. There are tabs for all 3 games. You can disable the other two to only show the first game’s servers’ status. By now the servers for HITMAN 2016 should be online for all platforms.

And here’s a link to the official IOI player support page. Despite it says it’s for HITMAN 3, you should be able to send a request to report your issue there too. Then their staff should reply to your problem.


1 Like

Thank you. I will try. I found this page before posting here, but it says everywhere «HITMAN 3». This page deserves to be clarified.

1 Like

You don’t have any 3rd party programs running like Fiddler or anything similar?

1 Like

Also some Anti-virus soft might prevent the game to go online due to maintaining with some sertificates or something, and game does not like that.
Try to disable your Anti-virus if you have any and try the game. If it helps, add the game to Anti-virus exceptions lists to allow the game fully bypass Anti-virus and it should all back to normal

1 Like

Thanks for trying, but I do not have any antivirus nor firewall. In fact my OS is not Windows. The funny thing is that it worked very well during two days, then it started to fail. Once a day (the first time I’m trying it) it succeeds to connect then instantly disconnect saying that the connection was lost. I have an ethernet 400 Mbs fiber connection, everything is fine, except with this game. I contacted IOI support, asking them to check their logs, their final answer was to try with HITMAN 3. Very great. Will never buy other titles from them.

Maybe that’s the issue because

Yeah, to be frank H3 Support is not that supportive…
I myself struggling with My Favorites tab in Contracts mode just disabled from July 20, the tab is just empty and I can’t add or remove favorites, game just disconnects when I’m trying.
I addressed to them few times and the best answer I got is my problem forwarded to technical department and they should see what’s going on. But still, Favorites does not work for 4 months now…

What exactly is your setup?

But that’s the specs for HITMAN 3, not HITMAN 1.
HITMAN 1 is supported on all platforms : have a look here :

If that’s not the case, then they must stop sell it.
Why does it worked fine during two days, and suddenly it stopped working ?
Mystery of marketing.

Windows, MacOS and Linux are not all.
Will be better though if you’ll mention the OS you’re using so we’ll not play guessing game here

Linux. I should have said that my platform is supported. Sorry.
But it won’t change anything anyway.

  1. First thing first, try to use another account with steam family sharing to check if it’s not account-related. If it’s working, you must have an issue with your primary account, and you need to contact IO via https://ioisupport.zendesk.com/hc/en-us/requests/new.

  2. Then check with Geforce Now (free), If it’s working with your primary account, you must have an issue on your computer or your local network / ISP.

  3. Try with another network.

I assume you have basic linux knowledge, and thus you are not too afraid of using tcpdump cmd. But first, try the first two tests.

1 Like

Already done. I tried with another hardware on another steam account, same result.

It seems to me really complicated, and I highly doubt about it. Especially since I have no other network problem on multiple different devices on the local network. This also includes dozen of multiplayer games on the same steam account on the same hardware.

Here is the interesting part of the output from tcpdump when the game tries to connect to the server :
This sequence repeats itself every 7 or 8 seconds.
I’m not an expert of TCP protocol, but it seems to me that the connection is opened, and simply closed.
Can someone generate the equivalent output, to try to see the difference ?

Are you aware that you are doing the job of IOI support ?
I asked them to check their server logs, they didn’t even answer me.

Thank you.

1 Like

All seem fine in this capture, but game client doesn’t do much. It’s not a filtering/firewall issue. DNS resolution is ok, and HTTP flags seem good (SYN, PUSH, SYN-ACK) and no connection reset.

Can you check the SSL certificate chain & issuer to make sure that something doesn’t replace it (which can happen in university residences or companies, or with some security solution set up by you or your network administrator or your ISP. Hitman client has a cert pinning protection and definitely doesn’t like that.

Command :

openssl s_client -showcerts -connect pc-service.hitman.io:443

Mine is showing something like this :

Certificate chain
 0 s:C = DK, ST = Copenhagen, L = Copenhagen K, O = IO INTERACTIVE A/S, CN = *.hitman.io
   i:C = BE, O = GlobalSign nv-sa, CN = GlobalSign RSA OV SSL CA 2018

I made a mistake about the support, it’s not IOI’s support team you need to reach but Feral’s support. More information here :


If the certificat is good (issued by GlobalSign), contact Feral and attach in your mail the tcpdump file (.pcap) and a screenshot of the error message.

1 Like

Yep, exactly the same. I’m preparing a folder with screenshots and other stuff. I will try to contact Feral to see what they think about it.

Some news !

I contacted Feral and explained the problem, but it took some time.
In the meanwhile from the same system I tried the Windows version using Proton (from steam) and the game connected perfectly.

After a few exchanges of mails, Feral answered me :



Glad to hear that :+1:

I advise you to send an email (you can reopen your ticket) to the IOI’s support team to tell them that Feral Interactive took the lead on this case (which is the normal process for all linux versions of Hitman 2016, they are supposed to know that). That way, next time they’ll be able to give another user a better advice instead of asking you to try Hitman 3 (especially since hitman 3 does not officially run on a Linux distribution).

@Travis_IOI @Clemens_IOI @ioi_christianco


@netfab thank you!

Also bought the game just a week ago, on Linux, and was trying to make server connection working.
Finally found this forum thread and just want to thank you for pushing this to Feral support :slight_smile:

After latest update server connection works without any issues and additional configurations!