Lost access to the game on Xbox

Already reported this in the technical support thread but just hoping I’m not the only one with this problem and this is a general thing?

I’m on Xbox and lost access to the game. I can only access the free content.

Everything is still installed on my Xbox and my profile is still recognized in the game (I even get that synchonizing message when booting up the game), but the game menu doesn’t give me access to the missions aside from the free prologue and Dubai and tells me to pay for everything again.

Not to mention I lost all freelancer progress, though when going to that menu, while I can’t go play it, it still seems tot recognize I completed some Challenges there.

What is going on? Going panic attack here seriously.

It says I need to buy Hitman World of Assassination for 70 euros but I already had everything that is in it.

1 Like

This issue has plagued Xbox for awhile now. It randomly happens and then will just decide to fix itself at some point without you doing anything based on various messages I’ve seen on the Discord.


As @thrison said, this is frequent. Happens to me regularly.

It seems to be an issue when you go from the “press start” menu to the main menu. The login to profile menu. I guess it doesn’t properly synchronize.
There is one way out though :

  • disconnect your xbox from the internet (personnaly, I’m on wifi, so I do this from the setting menu)
  • open the game
  • press start on the opening menu
  • you will arrive in the offline main menu
  • reconnect your xbox (again, personnally I do it from the setting menu), while the game is open in the menu
  • select “go online” in the menu
  • the game will properly link your profile and its content access
  • done

To be precise : I talk of the connection between this menu and the main menu :


Thankfully there’s no more elusive targets.

Thank you @thrison, you were right, it worked out by itself, but also my sincere thanks to @LandirtHome to know there is a fix for when this happens again in the future.

IOI should consider putting this on their known issues page because I didn’t find anything about this.


Hope - yet

1 Like

Hi there, Had the same issue you had just now but don’t worry this has happened to me before and I know that if I just wait then everything should be good.

You mentioned that you lost your freelancer progress correct? What exactly do you mean by that? Did you lose your mastery progress, did you lose your mercers, or did you just lose your campaign progress? And after this issue is resolved did you get back your lost progress back or is it still lost?

Do let me know as I’m worried that I might lose hours of progress, but if it’s just losing campaign progress then that’s fine. I’m still somewhere at the beginning of my current one.

EDIT: Well the issue is fixed and thankfully none of my freelancer progress was lost so phew that’s a relief.

Sorry for having worried you needlessly. The progress is saved indeed, I had lost nothing in that regard.

Yesterday I encountered the same problem but there’s no need to just wait it out. The trick provided by some other users here works: start the game, disconnect from the internet, connect again, go online in the game, and access appears as it should. It’s a bit annoying so I hope IOI (or Microsoft?) works on a fix for this. Would avoid a lot of stress with those encountering this for the first time.

1 Like

Thanks for the reply, I’ll try that trick next time whenever this thing happens again.

Posted this a while ago. This is usually the reason it happens on Xbox. It’s a problem with the Microsoft store.

1 Like

My “FIX” unplug the ethernet. my series x is connected to Both wifi and ethernet, I have issues where it says GET ACCESS yet I have game pass with a subscription left, seems that closing game then switching from wired to wifi and loading game again fixes it

1 Like

You can also try switching accounts (if you have more than one) or simply signing out and then signing back in.

1 Like

Oh my gosh, I was just posting about this in the technical help thread too, but your fix completely worked! Thank you so much!