Running Hitman: Contracts (and the other classics) on Win10 in widescreen properly

Ah, that seems to create a mess :smiley: Gonna try playing with it a bit tomorrow…

Let me rephrase the previous question though. Is there a way I can check while playing the game what card is it running on?

I know of Msi Afterburner which shows temperatures and usages for many things like gpu and cpu but I’m not sure if it actually shows if a game is running of the onboard or dedicated gpu…

1 Like

According to some screenshots, it should, but anyways, I downloaded it and tried. It´s showing GPU1 usage at 0% and GPU2 usage at 99-100%. GPU1 is the dedicated one and GPU2 the onboard one, so I guess the core of the problem is pretty much settled. Now to just find a fix :joy:

1 Like

Yep, disable it from Device Manager under Display adapters :stuck_out_tongue:
I’m curious, you can check this in afterburner in the General tab. In the Master graphics, what does it show?

I wonder if there´s a gentle option as well :joy:

You mean this?

1 Like

Oooo, disable that bad boy!
Also we have the same cards :stuck_out_tongue:
But yeah, once disabled you should have only the dedicated GPU and no longer will games try to use the Intel one :smiley:

1 Like

:rofl: Ok, ok. I´ll tinker with it tomorrow. It´s 3 am and I need some beauty sleep.

1 Like

So, I kinda let go of trying to solve the issue back in January cause I didn´t have the nerve for it, plus a lot of shit´s been on my mind in the meantime…

Anyways, I finally tried disabling the Intel GPU today to see if the game (Contracts) starts using GeForce instead… And the result? Sill ignores the existence of GeForce and apparently uses the Microsoft Basic Display Adapter instead… :joy:

I noticed Hidden and Dangerous 2 does the same thing actually. When running the settings panel, the only GPU available is the Intel one (confirmed via MSI as well), and when that one is disabled, MBDA takes its place. Probably some other of my games have the issue as well, though in HD2s case, running on Intel doesn´t hamper the performance/visuals (for now).

So… I wonder how the fuck am I supposed to solve this? :joy:

1 Like

Hmmm, in the Search bar type and open Change device installation settings and set it to No. After that simply open Device Manager, expand the Display Adapters and uninstall (not just disable) everything else than isn’t your actual GPU and restart your PC.
Hope it works :grimacing:

I also saw people using command prompt to get rid of it. Uninstall the drivers from Device Manager, use the 3 commands bellow in cmd and restart PC.

 takeown /f C:\Windows\System32\Drivers\BasicDisplay.sys
 cacls C:\Windows\System32\Drivers\BasicDisplay.sys /G Administrator:F
 del C:\Windows\System32\Drivers\BasicDisplay.sys
1 Like

Cheers. So the first procedure is for disabling the Intel card, and the second (cmd) one for disabling MBDA? I’m not sure if disabling the Intel card on its own would work, if the games automatically go for MBDA as an alternative and still don’t detect GeForce… :roll_eyes:

I’ll see if I’ll give it a go. I’m not exactly a technical type and am a bit cautious about using command prompts and disabling stuff if I don’t know what exactly it does :sweat_smile: Will see if I give it a go.

What puzzles me though is how come it works perfectly fine for you, whereas some of us (me and @vrubayka apparently) have this issue… Particularly since we have the same GPU. Wonder where’s the catch… :roll_eyes:

1 Like

You can never be too sure with PCs and all the possible hardware / software configuration that can cause issue to one but non for the other :confused:

Hope it works though :slight_smile:

1 Like

is your monitor plugged into your GPU or the Mobo?
that was my issue for a while, being plugged to the mobo forcing Contracts among other games to run on the CPU (intel graphics) rather than the proper dedicated GPU.

the solution was simply to connect with a HDMI cord rather than an old VGA boomer cord

I have a laptop and I have absolutely no clue how stuff is connected inside it and whether that might be the root of the problem… (I assume you were referring to desktop PCs only?) :sweat_smile:

Anyways, I managed to get Contracts (and SA) working properly. It´s only C47 now that refuses to run properly in HR with AA, which we were discussing in another thread: How to configurate Classic Hitman games on Win10 - #47 by Rimland

I believe that theres no way to use AA in Codename 47, its always greyed out in the menu and tampering with the .ini doesnt seem to do anything to change it.

1 Like

Force it through the Nvidia Inspector :sunglasses:

1 Like

As I mention in the other thread, I was able to get AA running via DgVoodoo (simply forcing it through NI doesn´t work for me), but at the expense of the widescreen patch not working. Haven´t tried tinkering with it since, cause it´s a pain, but I might try again some time soon. Anyways, my laptop is giving me a hard time with the old Hitman games… :sweat_smile:

1 Like