Running Hitman: Contracts (and the other classics) on Win10 in widescreen properly

So I´ve finally decided to install the classic Hitman games on my “new” (i.e. 3 years old) laptop to replay them again, and so far I haven´t been able to get either one of them running in a satisfactory manner (that is in 1920x1080 widescreen, fluently, in max details, and - if possible - with antialiasing). After 3 or so hours of tinkering with possible fixes and changes, my blood pressure has just about had it, so I´d like to ask you guys for help if you could share your tips/instructions on how to get them running properly (including things like compatibility, fps lock, GPU settings, etc.).

My main issue atm is with Contracts, which is why I´m posting the thread here rather than starting three separate ones, but I have issues with C47 and SA as well. I´ve got Windows 10, an Nvidia GPU, and all three games are the GOG versions (I have the Steam ones as well if that helps anything).

The main issue here is that the game suffers from a sort of microstutter where it “freezes”/lags for about half a second (maybe even less) roughly every 10 seconds (I sometime experience a similar problem with other older games if I have them installed on the HDD, but not when they´re on the SSD - which is the case of the Hitman ones). Also, the framerate seems somewhat low and the game isn´t nearly as fluid as it should be.

The issue only disappears when I switch the game´s rendering from D3D to OpenGL, but then it loses all the visual and weather effects and the cutscenes and loading screens are completely messed up. I´ve tried capping the framerate to 60 and switch compatibility, but to no avail. Also, the issue is there regardless of whether I run the vanilla version or with a widescreen fix, but seems to be worse with the fix.

I have very much the same “freezing” problem with Codename 47. Again, it´s only in D3D and disappears if the game renders in OpenGL, but then I can´t run the game with the widescreen fix (at least not the one by nemesis2000 that I downloaded).
EDIT: When using the widescreen fix in C47, there is also a massive drop in framerate when looking at buildings etc.

EDIT 2: H2SA has the same lag issue. Actually the most severe one (0,5-1s). And again, regularly every 10 seconds or so. Using D3D rendering and no widescreen fix (haven´t tried it yet). Again, it´s not there in OpenGL, but I heard OGL causes graphical glitches in the game, so it doesn´t sound like a long-term solution.

Any suggestions? :confused: (@MrOchoa on C47?)

1 Like

Try and force V-sync / cap fps to 60 or your monitor’s refresh rate. On very high fps the game goes into slow-motion.

2 Likes

well, i had no problems and just edited the ini file, i think. maybe try non-fullscreen mode with the required resolution (that was my way for h2sa if i remember correctly). also, i used direct3d

1 Like

“Screenshot” of my Hitman.ini for Codename 47, try forcing vsync or try without its 50/50, cap the game at 60FPS.

1 Like

Thanks for the suggestions guys. Unfortunately, no improvement so far. I forced vsync and a 60 fps cap on all three games, but with no luck (monitor refresh rate is also at 60). I´ve also updated the original post with info on H2SA and C47.

Did that as well, otherwise it won´t even start in higher resolutions. Doesn´t affect the lag though.

So overall, the common issue is a freeze/lag at regular intervals, and when using the widescreen fixes also a framerate drop in “intensive” environments. And it appears to be present only when the games are rendered in D3D. It´s not there in OpenGL.

As I mentioned, I´ve had a similar lag issue with other older games, but only on the HDD and not with such a precise regularity, so I´m wondering if it´s something with my PC/settings?

Or perhaps it has something to do with DX8 or something else related to graphics?

@misterkiller Would you have any idea?

All legacy Hitman games run fine for me on a 1440p 144hz monitor with the latest Win10 build and Nvidia driver. I use RTSS to limit my framerate to 110fps on all 4 games but it’s only really required for Silent Assassin and Contracts from what I have experienced. And I use only DirectX, because I have some issues with OpenGL (except for Codename 47 maybe but I prefer to stay with D3D + 1024x768).

Hitman 2 Silent Assassin :

DefaultScene=mainmenu.gms

SoundDll SoundEngine.dll
ScriptDll SDL_Engine.dll
ScriptIfDll ScriptInterfaces.dll
DrawDll RenderD3D.dll

LocaleFile=Locale\English.xml
Resolution 2560x1440

AutoDumpName ScreenDump0000.jpg
ColorDepth 32
ErrorLog error.log
EnableConsole

Anisotropy 1
AntiAlias 0
ShadowDetail 2
TextureResolution 0
UseDirectInputMouse
UseDirectInputKeyboard
HeroControlMode 1
MouseSpeed 0.848789

SpeechVolume 100
MusicVolume 99
SoundEffectsVolume 100

ConfigFile=Keyboard.cfg

DisablePolyLimit
UseEAX 0

Window 1
StartUpperPos 0,0
NumSoundBuffers 24
DrawDistance 1.200000
LevelOfDetail 2
Subtitles 1
WeatherEffects 1
GammaValue 1.000000
DisableTrilinearFiltering 1
SoundRender DirectSound

Hitman Contracts :

DefaultScene=mainmenu.gms
SoundDll SoundEngine.dll
ScriptDll sdl_engine.dll
scriptifdll scriptinterfaces.dll
DrawDll RenderD3D.dll
SoundRender Direct Sound (SW)

ColorDepth 32
Antialias 0

StartUpperPos 2,2

InvertMouse 0

SpeechVolume 90
MusicVolume 90
SoundEffectsVolume 90

AutoDumpName dump0000.jpg
TextureResolution 0
NumSoundBuffers 64
UseEAX 0
DrawDistance 1.000000
Subtitles 1
WeatherEffects 1

DisablePolyLimit
DisableBump 0
GammaValue 1.000000
LevelOfDetail 2
ShadowDetail 2

VibrationMode 0
PostFilterLOD 1
WeatherMultiplier 0.000000
Resolution 2560x1440
DisableTrilinearFiltering 1
Anisotropy 1

Hitman Codename 47 :

Include Setup\Locale.zip
//DrawDll Render3DFX.dll
DrawDll RenderD3D.dll
//DrawDll RenderOpenGL.dll
SoundDll Sound.dll
ScriptDll GSC.dll
LocaleDLL Locale.dll
Resolution 1024x768
Anisotropy 2
AntiAlias
DisableLight
ColorDepth 32
ShadowDetail 2
TextureResolution 0
DisableDXT
DisablePAL
1 Like

Thats what IO finally did with HITMAN 3, from 2016-2021 it was 0. :grinning:

1 Like

Try to reinstall all legacy directx drivers maybe ? Steam does it automatically, I’m not sure about GOG. You need DirectX 7 for Codename 47 and DirectX 8 for Silent Assassin and Contracts.

1 Like

Hmmm, try this then Windows 8/8.1 DDRAW FPS Fix - DLL files - PCGamingWiki PCGW Community

1 Like

Now while we are on the subject of Contracts, do anyone of you know a fix for the steam version? It doesn’t save progress on Professional.

Hmmm, check if there is a “Save” folder in the game directory and run the game as an administrator. Never heard of the game not saving before. What about the other difficulties?

1 Like

If remember correct it’s all difficulties, expect easy or normal. However it’s fairly common problem with the steam version of Contracts.

Interesting, have the Steam version but I only played GOG and Retail. Like I said, create a folder with the name Save in the game directory and see if that works. :slight_smile:

1 Like

Will try that, I want to revisit the game soon.

1 Like

Sure thing. Also @Rimland’s issues with the old Hitman games inspired me to create this thread. You can have a look over it whenever you want to replay Contracts. :stuck_out_tongue:

I´ll try installing the Steam versions then, see if there´s any difference.

Will do. Since that´s DX5-7, it would only apply to C47 right?

Like @EvilGeniusRo suggested, creating a Save folder should fix that:

Great thread you made there :+1: I´ll probably try following it on the next reinstall :grin: (I mean I always go to PCGW for the troubleshooting, but this is a nice step by step guide)

A little update though on my issue. I wondered whether it could be that the games for whatever reason are not running on my Nvidia gpu but the Intel one instead (even though I specifically assigned the Nvidia one to them), and found this guide: Definitive fix for this game (Cutscenes, FPS, Widescreen, Crashing) :: Hitman: Contracts General Discussions, which mentions:

Game using my iGPU and not my dedicated GPU/Low FPS (Using D3D8)

If you have a laptop, there’s a big chance the game won’t use your dedicated GPU when using D3D8 mode (refer to previous question, RenderD3D.dll). There are 2 workarounds for this: You can improve GREATLY your performance if you go to the in game graphics options and disable Post Filter, or you can do the next.

First, download this widescreen fix http://ps2wide.net/pc.html#h3 and extract h3.7z files inside your Hitman Contracts folder (password: h3). Then, modify h3.ini and put the resolution you want. And now, you’ll want to download a d3d8 to d3d9 wrapper. Just download this: https://github.com/crosire/d3d8to9/releases (d3d8.dll file) and replace the one in the game’s folder with the one you just downloaded. Voila! Now you can have d3d8 wrapped in d3d9 functions, and the game will now use your dedicated GPU, so no broken cutscenes and no bad framerate. You can enable those post filter effects again, too!

So, having already applied the widescreen fix, I downloaded the wrapper and replaced the d3d8.dll file, and indeed, the lag and framerate drop was gone. However, since this replaced the d3d8.dll that came with the widescreen fix, the fix no longer works, so fixing one issue leaves me with another :sweat_smile: I´ll have to try to tinker with it again, maybe in a different order, but anyways it seems like the D3D8/9 + GPU is at the core of the issue…

1 Like

Contracts is very CPU heavy, so even if you have a great GPU 1080p can be out of the question (it is in my case) however I’ve got it running flawlessly with max settings at 1600x900 res.

my specs are i5-7500 and a 1060

it is possible to force it to use GPU and run at 1080p but you will run into issues like cutscenes failing.

I have a I5-8400, a Nvidia 1050TI and 16gb ram and I’ve never had to many problems with CPU usage, it would stay around 10-15% usage, GPU usage on the other hands goes up to 70%…

1 Like

Ok, so I gave it another shot. @EvilGeniusRo I followed your guide step by step. Downloaded Nvidia Profile Inspector, set the exact same settings for Contracts (attaching image), then did a clean install of the game and applied the widescreen fix before even launching it (plus I set the compatibility to WinXP).

Started the game, the fix was working and the game was running without any lags. Tried restarting it and still good. However I had a feeling the AA was not working. Then I increased some of the graphics settings (texture quality and objects detail), it was still running good and then it went tits up and the issue reappeared again and is still there. I´m attaching two images from the first level if you can tell whether the AA is working or not.

I have a suspicion that the game is still simply ignoring my Nvidia GPU and is launching with the Intel one. Is there any other way I could try forcing it? (asides from the Nvidia Graphics Settings panel which I already did with all three games)


1 Like

Open up device manager and see what you have under Display adapters. If you have both Nvidia and Intel, disable the Intel one. Maybe that will fix it.