Hitman 3 Not launching ((epic version))

Hello Agents,
I had an issue starting my game today, it said that the D3D12.dll was not found, I got this issue solved, now another issue pops up, lol. Now when I click Launch, it does not launch???

All drivers
All Windows
all have been updated

Any ideas? Any help? I am taking withdraws lol

Hi, Agent44. I don’t know PC gaming setup well, but you probably want to contact IOI to resolve this issue. Just submit a ticket via the following link and there should be someone that will help you. Remember to post as many details as possible, such as your PC specs.


I hope you get this solved soon so you can enjoy the game! :slightly_smiling_face:

I would advise to reinstall the GPU driver completely, like a first ever installation.
To do this, you can use the latest Display Driver Uninstaller.
To do it properly, boot your PC in a Safe Mode and launch the DDU app.
After it has done its job, start PC normally and install the latest GPU driver.
Then, just in case, you can start game’s files integrity check.

Hope this will help

1 Like

integrity check? how do I do that

Launch Epic Games, go to Library, find HITMAN 3 and hit 3 dots near it, in the menu that appear select Manage, and in a window that will open push Verify button at the very top option

ty I had never seen that before lol thanks again

integrity check done all good but still not launching I even did a full reinstall

Did you do a GPU driver full reinstall?

yea and nothing , could this be a EPIC launcher issue?

Don’t think so.
Try to go to Event Viewer, into Apps section and look for any records for HITMAN 3.
Click on them and see what the details say.

Also if the game worked previously, you can try to restore the previous PC state if you have any restore points left

Originally it started by saying my D3D12 was corrupt, I fixed that by reinstalling Direct X

then as soon as it was fixed this happens

If it’s not finding that DLL, then either your GPU doesn’t support DX12, or windows defender/ your anti virus may be overreaching and blocking the DLL from running.

That seems quite unlikely. I’m not sure how it could be as EGS’s launcher turns off essentially once you start the game, and goes into quiet mode (I.E - It doesn’t interfere with things; it just launches EOS, which again, wouldn’t do this sort of thing, and is a different issue entirely).

If you can’t get it running, try running the game via Heroic to see if that helps, though I suspect it won’t.

1 Like

The DLL Issue was a corrupt Direct X issue, I fixed it VIA reinstalling of DirectX

Now it will let the game screen where you click to PLAY and the box where you start the game **with PLAY on it ** disappears and nothing starts

1 Like

When I click play here… it disappears like its gonna start and then nothing happens

I’d just restart your computer just so the settings apply properly.

I did a full reinstall of the game too so not sure whatelse to do

I have restarted a few times thhis started yesterday

then I have no clue. check task manager to see if the game boots?

Found the solution since I had the exact same problem.
Go to C:\Users\user\AppData\Local\IO Interactive\HITMAN3 and delete the file PipelineCache.bin. Playing each map the first time would take like 3x the amount it would normally but the game was running and running fine after.


The idiots at Epic told me to uninstall the game, and reinstall it. now its not reinstalling … and they dont want to get off their butts and fix it