Legacy Pack for GOTY in hitman 3

Unbelievable. I have had hitman one installed months ahead if this, and I have Hitman 2 installed as well. I carry over my progression, go to check everything out, and bang: no access to any season 1 locations. I don’t know what’s going on at IO but I know for a fact I am not paying $30 for a game access pass that I already own and was promised to be free. Any updates on the matter would be nice.

Calm down. You may try and list some of your details to help people address your issue.

  • What platform are you on?
  • Which editions of all 3 games do you own? Digital or Retail Disc?
1 Like

Hello, I have the same problem (Xbox user) . Levels from S2 are working perfectly, but S1 levels are missing. I have Digital GOTY Hitman Season 1, but S2 and S3 are on disks. I’ve even checked my purchase history on ms store and guess what - GOTY edition is there. The weird thing is that link redirects me to store and it says that ‘you dont own this product’. TBH i don’t know what is going on, but i suspect Microsoft screwed something with those editions in store…

The game doesn’t detect your Digital GOTY Hitman Season 1, it detects whether you own Legacy Pack on HITMAN 2. Please have a read at all the details here:

How to get it
– Consoles: If you have previously downloaded the HITMAN 1 Legacy Pack, HITMAN 1 GOTY Legacy Pack or HITMAN 1 GOTY Upgrade for HITMAN 2, you will be able to download it for no additional cost. (Yes, that’s a free upgrade to the GOTY Edition if you only own the Standard Edition of H1!). The price for this Access Pass will be listed as ‘free’ when you look for it in the store.

Ok I’m confused, but I do have Legacy pack in Hitman 2, played all the levels. I had it as a free upgrade.

So what? I need to buy it again, makes no sense to me.

Edit: OK, I get it… i need to install legacy pack in Hitman 2, because I deleted it few months ago. Then game should allow me to download pack in my games section (as I did with H2 Legacy pass)

I’m a PS4/5 user, whilst playing H2 I had to download the free Legacy pack update and though it didn’t work at first, I restarted the console and it worked.

Right there is my issue. I’m on xbox and everything is digital. I played hitman 1, when 2 came out I got the legacy pass for it, played 2, and now while 3 is here I only have access to maps from 2 despite having redeemed maps from 1 onto 2 theoretically I should have no problems, but alas, no season 1 maps for me

  • davies2983 posted this in another thread a little while ago. looks like they are aware

https://twitter.com/IO_Travis/status/1351895465785225221

Xbox Series X with the same issue. All 3 games are digital purchases. I own Hitman 1 and 2, got the GOTY legacy upgrade thing from 2. All levels show up for Hitman 2 but it says I need to buy the access pack. I’ve uninstalled and reinstalled 1 & 2, went into each game to check the GOTY addon stuff and it redirects me into the MS store where it says “you own this” and that I can manage it.

Never finished the first game. Started on the second by completing everything in the Paris mission but never got back around to it. Figured I would go back and play it all from inside 3 but it’s kinda hard to get started when the first game’s content isn’t available.

Maybe it’s tied to the servers being hammered for the progression? The site was up and down about all night until a few hours ago and it has remained down since. Maybe some URL or domain can’t resolve to something hosted on it to track purchases properly or associate purchases with accounts correctly?

That’s all I’ve got to contribute. I’ve emailed them about it and hope to hear something back. The autoresponder said forum, Twitter or Reddit if no email reponse. Don’t use Twitter and all Reddit is good for is “look at me” or “look what I did” pictures.

Hi, I’ve managed to work it out. I couldn’t do it on my console for hours, so i remotely installed Legacy pack for hitman 2 (via xbox store webpage) and then when I went back to hitman 3 page it said that i own this product (Legacy GOTY for Hitman 3). I’ve installed it remotely and boom, 20MB download and it’s working perfectly.

Could you post the link you used? If I search for “legacy pack for hitman 2” all I can find is HITMAN - GOTY Legacy Pack which it says I own (like so - Imgur: The magic of the Internet)

Searching for any of it I get the same stuff I see in the MS store on the console with the same “you own this game”.

I thought they probably had fixed it and you were mistaken about it but it seems that’s not the case.

I’m able to remote install the GOTY Legacy pack but it still seems to think I need to purchase the 30 dollar Access Pass. I’ve spent 3 hours this morning reading and trying various fixes. I left PC to avoid this very thing but I guess with everything connecting and syncing and always on, etc those days of simplistic console play are over.

I hope MS will refund me on this but I’m probably screwed because out of boredom last night I played the training mission and it unlocked 2 achievements. I also left the game running doing the transfer thing for a few hours while watching tv.

Absolutely disgusted atm

Alright so I got it to work. I had to “purchase” this but it’s gonna show not available. Don’t panic just keep reading https://www.microsoft.com/en-us/p/hitman-legacy-pack/bp2h94p932wk

You can also find it in your store app on the Xbox but it also not available there. However if you go to the link at the bottom here you can “buy” it for $39.99. I signed in to pretend to buy it and it changed the price to free. Then I remotely installed it and started up H3 and the H1 content is accessible.

Just FYI if you can’t get remote install to work through the web on an XSX check your devices under your microsoft account. I own two One’s and this XSX. I had to tell it my launch One is no longer my home console (via the 3 dots in upper right hand corner on the thumb nail) and then go into the settings on the XSX and make it the home console. When you attempt the remote install it will still say Xbox One but should now have (home console) or some such in parenthesis and you should be able to do it.

There’s posts on a reddit thread that seem to think installing the H2 Starter pack is necessary for these fixes to work. It’s worth mentioning I had already installed that earlier before attempting the purchase of the Hitman Legacy Pack that fixed the issue.
Reddit thread is here - https://www.reddit.com/r/HiTMAN/comments/l1obqz/xbox_hitman_3_access_pass_hitman_goty_fix/?utm_medium=android_app&utm_source=share

2 Likes

I tried everything. Deleted, reinstalled Hitman1, Hitman legacy for Hitman2 etc, starter pack. No luck.
Under bundles in xbox store on xbox, I see I had Legacy 1 owned, but nothing installed or pending. So can’t initiate install on xbox.

I then read your post

I went to xbox.com and selected buy for $29.99, verified my identity via 2 factor authentication, then next page where you would expect to be asked for credit card etc, it instead said “You own this product”, and had “Install on my device” option
Selected install, and 30 secs later I am all good!

Thank you so much

Doesn’t work for me over in the UK. Think it’s different issues in certain regions.

I believe IOI are developing a wider fix which is releasing this coming week :grin::+1:t2:

Doesn’t work for me (on Xbox). I might be an unusual situation, as I never owned the Hitman 1 content directly, and can’t access it from within the Hitman 1 game. I started with Hitman 2, bought the Hitman 1 upgrade, and can access all the content from within there. With Hitman 3, I can access all of the Hitman 2 content, but can’t access any of the Hitman 1 content.

I tried all of the suggestions and success anecdotes, but no joy here :frowning: