Unable to go Online

So, since I haven’t seen any Topic about this, I might aswell make one. Has anyone the same issue. Everythig worked fine until Romania, though since then I just can’t connect, which sucks cause I literally can’t do anything. Hell, I couldn’t even properly complete the Finale.


Literally can’t do anything? How is that possible?

I had that too but it was after i finished romania and closed the game. Came back an hour later and i couldn’t reconnect. Weird shit

1 Like

Nothing in terms of sense. No Contracts Mode, No Completing Challenges etc.


Aaah the joy of always-online right? :roll_eyes:
Hope this gets solved soon.


Yeah… the joy.
I will never understand why we can’t do Challenges Offline, it’s such BS
and ever will be.


Challenges, Unlocks, Ratings…

Basically everything useful from the game is locked through online DRM :tired_face:

I let it go for the first two games, might pass on this sequel.


You people are lucky! I haven’t been able to connect a single time since release.


This is happening to me now on PS5.

Was playing fine and then the game froze (yet again) and so I had to relaunch it and now I’m stuck. :confused:


Thanks for the always online feature, friends. So much utility


I’ll give them until tomorrow morning before I bust out the good old cellular device and and laptop to contact PSN. Surely they will just redirect me to Io which at this point is not is not even acknowledging half of its player base being locked out of progression and online capabilities… ouch. If they were a big company like Bethesda they would have so many people complaining. Seems to be a double standard communication wise for smaller developers . Almost like we should forgive them for there lack of capabilities because they are self publishing.


I really don’t want to get a refund, i just want to play it. I feel bad for the people who haven’t even had that chance at all yet! I just don’t understand why this issue is not being given the highest priority.


Same here. Was in the middle of a Master Chongqing SA/SO last night when I disconnected. Hasn’t worked since.

1 Like

I feel you, man. Happened to me on the second playthrough of Dartmoor.

1 Like

Same here. Unable to fetch configuration since thursday on PC. Before that it was a struggle to get the progression carry-over done. I think this is also somehow related to carry-over progress because Hitman 2 connection works on steam just fine.


Same here. This has been a total disaster. Been a fan and player since the original and this has just been brutal.


Issue has been acknowledged by the developers. Please wait until there’s more announcements.

Players are encountering a ‘failed to fetch profile information’ error. This is most prominent on PS4/PS5.
Status : We are aware of the issue and investigating a fix.

But it’s all platforms not only ps4/5

1 Like

Yep. Well, atleast PC is heavly involved.

That’s why they said “This is most prominent on PS4/PS5.” I believe they have noticed other platforms have similar issue as well.