HITMAN 3 - Technical Support

Platform: PC.

Description: Game crashes on some maps.

Steps to reproduce:

  1. Open game and select dartmoor or bank map.
  2. Wait for it to load.
  3. It freezes and crashes.

Frequency: All the time on the maps. Some maps work some doesn’t.

I have tried reinstalling and verifying files nothing works.

I caught a bug. On the loading screen with the target’s face and name, there are letters randomly clipping above the name of the target(s), it’s only letters e, m, n, r i think.

I got disconnected from the game twice, with the blue screen and the error code C-4 something. I have an old internet router, so i guess that’s the problem, it’s not the game right?

Platform: PS4, Disc

Description : I can’t access Hitman 1 and 2 locations even though I own both on disc and both are installed. The Hitman 1 and 2 locations are accessible in the Hitman 3 Starter Pack though.

Steps to reproduce: Happens when the game is loaded

Frequency : Happens every time.

Platform: [PS4, Xbox One, PC, etc]
Disc or digital?

Description : Tell us about the problem in a few lines
I recently purchased hitman 3 on steam and when I click play the h3 launcher opens and when I click play it just closes and nothing happens

Steps to reproduce: (How can we reproduce the issue?)

  1. click play on steam

  2. wait for h3 launcher to open

  3. click play on h3 launcher

  4. nothing happens after

Frequency : (Did it happen once, or lots of times? Does it ALWAYS happen?)
Always happens

Attach or link to any videos or images that will help explain the issue


Hitman 3 does not launch for me on my Steam Deck (it never did before, I mean I just installed it for the first time). It opens the launcher but no matter what I press - play, settings or, well, quit - the game quits afterwards and boots me back to Steam.

System: SteamOS stable 3.2

I tried several compatibility options - none worked: Not with Proton experimental, not with Proton 7.x, not with Proton 6.x

I validated the game files

I skipped the launcher via parameter, then the game instantly crashes (Steam logo for ~7 seconds, then crash)

Other games run perfectly fine…

Any ideas?


Platform: pc epic games

Description : Purchased DLCs still showing “get access” in game
Steps to reproduce: (How can we reproduce the issue?)

Frequency : always

Are the servers down or something? Been trying to connect on Xbox for about 30 minutes now.

Did you get it fixed somehow?

Same problem here,
none of the internet suggestions seems to help.

Even did a full re-install …

same here

Cool fix IOI with 0 score

1 Like

I can no longer connect online with HITMAN 3. I have the Epic version of the game on PC, I can play it offline, but as soon as I try to connect, it authenticates, saves, and it softlocks at the last “connection” message. I have to alt-tab to close the game.

I have even reinstalled the game. No idea what the issue is. Is this a server issue?

EDIT: Fixed itself. If I just waited long enough on the softlocked screen, it would correct itself. Very strange issue in the…500+ hours I’ve had with the trilogy, never once had that happen before.

Hi all, new here so if this is in the wrong place feel free to delete.
I have a ryzen 9 and 6900xt gpu and 32gb ram.
When i put the ray tracing options on performance is killed.
Does anyone have a similar spec and the right settings?
Thanks in advance

I’m having the same issue on Xbox series X. How long did it stay soft locked before it connected?


YouTube link to the issue (just one example out of many) SEIZURE WARNING

This has actually been happening to me a few months ago. I’ve noticed it before in Hitman 2 but this is now occurring in almost every map. The issue is most prominent in the following:

  • Paris (looking at the stage area, even if it’s not in line of sight; some angles when looking at the river will also trigger it)
  • Mendoza (many areas, usually outside - almost always happens at the sniper team vantage point looking at the party)
  • Colorado (as per the video, Sean Rose’s house)
  • New Zealand (particularly when looking at the house windows and reflections are on)
  • Mumbai (some NPCs with smartphones will trigger glare)
  • Bangkok (some areas inside the hotel in 2F/3F have this glare)

Latest Nvidia drivers installed. System specs as follows:

NVIDIA GeForce GTX 1080 Ti (Driver Version 516.59 - latest as of July 28)
Intel i7-8700K
2560x1440, 165Hz

Troubleshooting steps attempted:

  • Reset all graphic settings to default - did not work
  • Turned off Mirror Reflection Quality - worked in New Zealand, ineffective everywhere else
  • Changed resolution to 1280 x 720 - resolves the glare issue but graphics quality obviously reduced due to low resolution. Not an acceptable solution

I yanked Akka off the place where Nolan Crest fell, and she just got KO’ed

Platform: PC, Digital, Epic.

Description : Dropping any item in the inventory would cause the game to crash to desktop.

Steps to reproduce: Play the game for a long time.

Frequency : Once I play a game long enough, it always happens.

Attach Here’s the video demonstrating the bug https://drive.google.com/file/d/1fH-SQSOF7nyYbvBhmkGZHZ8IbO8eRR8f/view?usp=sharing

This may not be the right section to go to, but I’ll try.

  1. Add subtitles to the audio guide at the Delgado Museum. It is interesting to learn lore, but very difficult for those who do not know English.
  2. Mendoza. Add an alternative exit through the car at the starting location (when replaying). If 47 came from there, then he can go back.
  3. In connection with the last mission, is it possible to give weapons to the targets (in Colorado)?

Platform: PC
Epic Games Store
Description : After I had to verify my Epic Games account, Hitman 3 would not open. When I tried to open the game, it would give me a little popup saying Epic Validation Failed (or something like that) and gave me an error code (screenshot below). I have tried everything from deleting the game and reinstalling it, contacting the Epic Support team (they just sent me here), restarting my PC, updating Windows. I have tried it all.
Steps to reproduce: It just does this whenever I open it.

Frequency : All the time.

Screenshot (2)

In case the screenshot doesn’t show up it’s an error code that says Epic Validation Failed: 1017-0

Platform: PS4
Account: Steynkie69
When I opened my contracts today, I discovered 4 contracts that I definitely DID NOT create. Someone must have hacked my account and is making contracts under my name. How do I stop this? This is URGENT, please help!

Update the password of your PS account, and also your IOI account password for safe measure, if you have one.