Possible fix for PC users who cant get online

I posted this in r/HITMAN subreddit as well…

Ive been reading that some people can delete the contents of

C:\Users<USERID>\AppData\Roaming\IO Interactive\Epic\0d26eb5669b04fbf80ccd94d8492b825

and were able to get back online. Others have said it hasnt. Didnt work for me either. I think they may have missed a crucial step when describing and not realizing it.

If you delete the contents THEN launch the game, EGS will alert you that config files are missing and attempt to recreate it which recreates the error. But if you launch the game, wait for the title screen (at this point EGS passed off control to Hitman3 and does not attempt to recreate files from EGS cloud).

But if you launch the game, get up to the "press X (or enter) to start, then delete the files, come back to Hitman, press X to start, it connected for me.

So to summarize:

1: back up everything in C:\Users<USERID>\AppData\Roaming\IO Interactive\Epic\0d26eb5669b04fbf80ccd94d8492b825

  1. Launch the game to the point where you press X to start. (I used desktop icon, heard that may be relevant)

  2. Delete contents of C:\Users<USERID>\AppData\Roaming\IO Interactive\Epic\0d26eb5669b04fbf80ccd94d8492b825

4.Go back to Hitman 3 and press X to start

You will lose all save games, and you for any reason you can always replace the backup you made at any time if wackyness occurs.

Working for me now. @Travis_IOI


Can confirm this actually WORKS. Awesome mate. Perhaps tag @Travis_IOI so it gets out to IOI where the problems might lie if that fixes it.

Essentiall it could mean not creating any save file should fix it permanently until IOI figures out what corrupts them

Curious if this is just a placebo effect?
Tried it out and it doesn’t work for me. On PC, I’ve been getting “connection error” for the past hour or so. :cry:

Good evening, unfortunately it does not work for me … Thank you anyway. I can’t wait for a fix to come out! :frowning:

1 Like

Did you open up the game upto where it says “press A/enter to start”? There, don’t start the game and instead tab out of the game, delete what the OP said and then start. It should work.

I know how to follow directions. :wink:

Was the game running and at the “press A to start” when you deleted the files? You have to tab out if the game on that screen. It’s an important because you have to delete the files in the window between game being launched and connecting to server

Possibly placebo but was disconnected for 3 days and haven’t been since.

It is possible the exact issue might be unrelated? :thinking:

Afterwards, I shut the game down, put 2 quick save folders back relaunched the game (by the way, I did it from a desktop icon, that may be important too idk)

EGS asked me there was a cloud conflict, I chose local, the game launched, got online and I loaded my old game

I completely turned off cloud sync for the moment.

1 Like

Yeah… It just does not work on my end. I follow the directions to a T, the PRIVACY POLICY comes up, I accept it, and… CONNECTION FAILED.

1 Like

Did you launch from EGS launcher or desktop icon? I heard that may be relevant to use desktop icon and updated my OP to add it

Well, this actually worked for me, thank you! I hope the connection error doesn’t return, at least not until IO fixes the problem.

I didn’t use a desktop icon.

1 Like

Up to this point I’ve been launching the game from within the Epic Launcher.
I tried using the HITMAN3 shortcut on the desktop (as you suggested) and it still doesn’t work.

I’m in following ‘most’ of the directions.
(Saved then) deleted the ‘local profile’ folder out of that subdir.

Started (from desktop icon)
Choose ‘local files’ to sync
Waited for press ‘ENTER’ (or whatever your flavour is)
Tabbed out but nothing to change
Tabbed in
Pressed ENTER
Confirmed privacy policy and gameplay settings

Works (for now)

1 Like

Hasn’t worked for me either, and I am following all the directions.

Thats even weirder than the hole ‘reinstall the game’ that works for some not for others.

I also tried that by the way.

But placebos make people think all sorts of things. A couple days ago I managed to get the game working coincidentally after updating a driver and even though I knew there could be no connection I treated it as a fix until it broke several hours later.

I noticed on Discord that there are certain time frames where more than one user reports that is started working again. I and two others suddenly could play for an hour or so. These sudden fluctuations could fool us our esoteric attempts at fixing it actually work out.

I tried this and it did not work for me, but I don’t see how this is really different than the initial “delete this folder” solution.

Well, back to not working I guess. It won’t work anymore either, but at least I was able to do some progress in Dartmoor.

It might have also been the same case for me but then it’s a weird coincidence that it started working just when I tried OP’s method. It hadn’t been long before that I had tried connecting normally which obviously didn’t work.