Simple Mod Framework

Error is it :

 INFO	Initialising error reporting
INFO	Discovering mod contents
INFO	Discovering mod: Offline Unlocks
INFO	Invalidating cache
INFO	Analysing framework mod: Offline Unlocks
INFO	Deploying riisikumi.offlineunlocks
DEBUG	Applying JSON patch K:\HITMAN – World of Assassination v.3.170.1 (2016-2018-2021)\Hitman 3\SMF\Mods\offlineunlocks\content\chunk0\unlockables.JSON.patch.json
This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). The promise rejected with the reason:
TypeError: The "path" argument must be of type string. Received undefined
    at deploy (C:\snapshot\simple-mod-framework\compiled\deploy.js)
    at async doTheThing (C:\snapshot\simple-mod-framework\compiled\main.js)

Hey everyone, I have solved a few issues with my simple framework installation and voila:

I cannot even deploy a atampy26 mod now?

Any tips:
INFO Deploying Atampy26.AnyNPCReplacesAgent17sSignatureSuit
DEBUG Converting entity D:\Epic Games\HITMAN3\Simple Mod Framework\Mods\NPCReplacesAgent17\content\Heidi Santoro 2-1afc40fb-b6db-4e25-8dd7-2dba57c3c73c-0-0\chunk0\suitToReplace.entity.json
DEBUG Copying dependency 00FD4998C59CB320 from cache
thread ‘’ panicked at src\
called Option::unwrap() on a None value
note: run with RUST_BACKTRACE=1 environment variable to display a backtrace

Also the modlist and log, (done in another try though) if needed

Quick Question is there a way to Undo the skip intro so you can unskip it since i accidently press the skip intro box in SMF I open up hitman 3 and it skips the intro. Do i need to delete thumbs file or no?

Should be able to just untick it in SMF and then deploy mods

I did untick and it’s still skip the intro when I open the game

I heard a rumour once it’s been deployed with that option on once it will never go back unless you delete thumbs.dat and validate files

Dose it mean I have to re install simple mod framework too? After I verify files

Shouldn’t, just don’t have it ticked

Hi, the game update was 3 days ago. I’m still not seeing an update for the framework. Haven’t seen any update in general in a long time. Has this project been abandoned?

Update has been released.


Development is focussed on version 3 (summary is linked somewhere above) right now, but it’s mostly on hold because it’s waiting for other tools to be completed that I don’t have control over.

idk if im doing something wrong, or if my pc just decided to delete something but the smf has been updating for an hour now

anyone know whats happening?

Your version of SMF you have installed is way too old to update to the current version.

You will need to redownload the installer from Nexus mods and install SMF v2 first and then update from there.


that worked, thanks!

1 Like

Getting this error when trying to update 2.33.9 → 2.33.11. What do?


Try restarting your computer.


That sorted it. Cheers.

1 Like

@LoverOfTaylorSwift Regardless what this framework can do and what not, this forum does not support any discussions on cracked game versions and making them work.