How to configurate Classic Hitman games on Win10

Step 1. Cap the framerate to your monitor’s refresh rate
This method works for Hitman: Codename 47, Hitman 2: Silent Assassin and Hitman: Contracts.

For Nvidia users, use Nvidia Inspector
How to configurate Nvidia Inspector:

Summary

Start up nvidiaProfileInspector and from the drop down bar next to Profiles: select the game you want to limit the fps

Under Sync and Refresh set the Frame Rate Limiter to the value your monitor refresh rate is. Mine is a 60Hz monitor so I set it to 60.7fps.

Step 2. Force Antialiasing and Anisotropic filtering. Force both Antialiasing AND Anisotropic
only for Codename 47, for Silent Assassin and Contracts force ONLY Antialiasing!

Summary

Similarly with capping the fps, use Nvidia Inspector.


Note: Seams will be visible on 47’s model and text might be difficult to read with this enabled.

For Antialiasing to be forced in Hitman: Contracts, follow the previous guide and under Compatibility: set Antialiasing Fix to On and in the Antialiasing compatibility drop-down menu paste 0x000020C0

Step 3. Configurations for each game separately

Hitman: Codename 47

Summary
  • Widescreen and draw distance patch. Password: h47

Simply extract the files into your game directory, open h47.ini and set the desired resolution
[MAIN]

Width = 1920
Height = 1080
For the draw distance, you can keep the default value of 8.0 but for the Colombia and Rotterdam missions I recommend lowering it down to 6.5 since the game might start to lag.

  • In-game Video options

  • How the Hitman.ini should look for you
Summary

Include Setup\Locale.zip
//DrawDll Render3DFX.dll
DrawDll RenderD3D.dll
//DrawDll RenderOpenGL.dll
SoundDll Sound.dll
ScriptDll GSC.dll
LocaleDLL Locale.dll
Resolution 640x480
Anisotropy 2
AntiAlias
DisableDXT
DisablePAL
ColorDepth 32
ShadowDetail 2
TextureResolution 0

End Result

Hitman 2: Silent Assassin

Summary
  • Widescreen and draw distance patch. Password=h2

Simply extract the files into your game directory, open h2.ini and set the desired resolution
[MAIN]

Width = 1920
Height = 1080
You can leave the other settings to their default values.

  • In-game Video options


  • How the Hitman2.ini should look for you
Summary

DefaultScene=AllLevels/Logos.gms

SoundDll SoundEngine.dll
ScriptDll SDL_Engine.dll
ScriptIfDll ScriptInterfaces.dll
DrawDll RenderD3D.dll

LocaleFile=Locale\English.xml
Resolution 800x600

AutoDumpName ScreenDump0000.jpg
ColorDepth 32
ErrorLog error.log
EnableConsole

Anisotropy 1
Antialias 0
ShadowDetail 2
TextureResolution 0
UseDirectInputMouse
UseDirectInputKeyboard
HeroControlMode 1
MouseSpeed 0.8

SpeechVolume 100
MusicVolume 88
SoundEffectsVolume 100

ConfigFile=Keyboard.cfg

DisablePolyLimit
UseEAX 0
NumSoundBuffers 16
DrawDistance 1.200000
LevelOfDetail 2
Subtitles 1
WeatherEffects 1
GammaValue 1.000000
DisableTrilinearFiltering 1
SoundRender DirectSound

End Result


Note: When starting the game up if you see the intro play but with no sound and in slow motion, double click and things will work as normal.

Hitman: Contracts

Summary
  • Widescreen patch. Password=h3

Simply extract the files into your game directory, open h3.ini and set the desired resolution
[MAIN]

Width = 1920
Height = 1080
You can leave the other settings to their default values.

  • In-game Video options


  • How the HitmanContracts.ini should look for you
Summary

DefaultScene=AllLevels\Logos.gms
SoundDll SoundEngine.dll
ScriptDll sdl_engine.dll
scriptifdll scriptinterfaces.dll
DrawDll RenderD3D.dll
SoundRender Direct Sound

Resolution 640x480

ColorDepth 32
Antialias 0

StartUpperPos 2,2

InvertMouse 0

SpeechVolume 90
MusicVolume 90
SoundEffectsVolume 90

AutoDumpName dump0000.jpg
TextureResolution 0
NumSoundBuffers 64
UseEAX 1
DrawDistance 1.000000
Subtitles 1
WeatherEffects 1

DisablePolyLimit
DisableBump 0
GammaValue 1.000000
LevelOfDetail 2
ShadowDetail 2

VibrationMode 0
PostFilterLOD 2

WeatherMultiplier 1.000000
DisableTrilinearFiltering 1
Anisotropy 1

End Result


Note: If you are playing the Steam version and if the game doesn’t save progress, go into the game’s directory, create a new folder and name it Save .

Hitman: Blood Money

Summary
  • Widescreen patch. Password=h4

Simply extract the files into your game directory, open h4.ini and set the desired resolution
[MAIN]

Width = 1920
Height = 1080
You can leave the other settings to their default values.

That’s pretty much it for Blood Money, this one isn’t such a hassle to get it to work on Win10 :stuck_out_tongue:

Most of the information was taken from PCGamingWiki PCGW - an encyclopedia of PC game fixes :+1:

16 Likes

it’s a shame i ran out of likes for the time being. greatly appreciate the thread

2 Likes

the nvidia inspector isn’t working for me,
I tried to cap FPS on Silent Assassin, but my counter still saying it’s over 1000 FPS and everything in the game is moving janky.

1 Like

Yeah, Nvidia Inspector doesn’t work on some newer driver versions. You can use Rivatuner Statistics Server to cap the fps. :frowning:

1 Like

that works perfect,
thank you!

1 Like

Your screens of Contracts look fantastic. How did you manage to get anti aliasing working on that? It works for the other games, but not Contracts. :frowning:

1 Like

Here you go :stuck_out_tongue:

Also if the game lags on your PC, change the Antialiasing to a lower value e.g. 4x Multisampling

Ah, I see where I went wrong there. The Anti aliasing fix is very important not to miss. XD

1 Like

Can someone help me on this?

I followed the guide for Codename 47 but whenever I played the Colombia and Rotterdam missions the game’s FPS drops to seconds per frames. I think this is because I can see a large portion of what was previously hidden in the fog so I wanted to know how to bring back the fog (or partially bring it back)

I have already did this but it is still lagging a lot on those missions. I’m not sure what to do here. (Is there a way to reset Codename 47 into the version downloaded on steam with no additional configs or files to reset it and reapply the widescreen fix?)

After getting the widescreen fix for C47 my UI became very small which made things harder to see. Does anyone know how to resize it?

1 Like

Did you force Antialiasing / Anisotropic filtering? If you did, you can reset it back to default in in Nvidia Inspector but keep the frame limiter on!
If that doesn’t solve the issue, you can simply delete the files from the widescreen patch. h47.ini, h1w.dll and ddraw.dll.

Sadly no, there is no way to resize the UI with higher resolutions. :frowning:

1 Like

Very jealous for that sexy Hitman Contracts antialiasing. Nvidia Inspector setting has no effect on my game :sob:

1 Like

Did you follow the steps I mentioned a few replies earlier to JoesGuy? Maybe you accidentally forgot to set Antialiasing Fix to On. It is very important to have that set in order to get antialiasing to work :stuck_out_tongue:

1 Like

Yes I did. I googled a bit and it seems that some people are experiencing issues like I do, when Antialiasing just won’t work when forced in Inspector. Seems like a Windows update issue. The problem is, I could use dgVoodoo2 to force antialiasing but it conflicts with the Widescreen Fix d3d8 wrapper so that won’t work either. Some day I’ll get a new PC with Nvidia DSR and just force the game to output at 4k and downscale it to my monitor and no more fiddling with all these AA solutions.

1 Like

As it happens, despite not touching anything in Inspector, AA isn’t working for me anymore. O_o

I noticed that after a driver update, it might reset. Reset the values in Nvidia Inspector then redo them and it should work again :slight_smile:

Oh, you’re right. The compatibility flags reset on driver updates. What a pain. >_<

1 Like

I have a question. Do you guys know if there is any mod that can fix the HUD on the oldest titles, specially on Codename 47? Because If I play on high resolutions, text, subtitles and hud are very tiny.

Hmmm, there is a method on PCGamingWiki but I have never tried it. Maybe that can help. :thinking:

Yes maybe I’ve found the widescreen mods that I need, thanks!

1 Like

@vrubayka Is Contracts even running on the Nvidia card for you? Just wondering if you have the same issue as me… (it ignores GeForce and runs on Intel GPU only instead)